Jboss Plugin for RAD 6

Hi, I need to install and run JBOSS server from within RAD. I hate building an ear and dropping it off in JBOSS directory everytime so I am looking for a plugin that WORKS.

I have already tried to put the plugin they have for eclipse under rad/eclipse folder but RAD is not picking it up (upon restart). They say the best way to add a plugin to RAD is go to help->software update and give it the external URL link. The URL which JBOSS had for the plugin is no longer working.

Somebody please give me the URL or let me know how to run JBOSS from within RAD 6.

Madhu_AAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

amorelosCommented:
1.- For this plugin that you are copying to you installation folder, are you using the -clean switch when you launch RAD again?

2.- I just tried with this update site: http://download.jboss.org/jbosside/updates/development/ , with the previous update site I updated a Ganymede install (Eclipse 3.4) and seems like I got a lot of JBoss stuff in my IDE. The previous update site is for the development release, this one is for the stable release: http://download.jboss.org/jbosstools/updates/stable.

3.- I'm using RAD 7, and I can perfectly work with a JBoss 4.0 server from this IDE, just in case you are considering to update your IDE.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Madhu_AAuthor Commented:
Hi, thanks for the links.

When I tried to select the necassary plugins from that site (JbossAS.. etc) it gives an error preventing the installation of the  plugin:
"JBossAS Tools (1.1.2.GA) requires plug-in "org.eclipse.jst.server.core (1.0.102)", or later version."

I checked for updates to my RAD and the update size is about 1.6GB!! (from RAD 6 to RAD 6.0.12)...I will try to get that update and then see if the plug in can be installed.

-- Yes for the previous plugin which I dropped in the rad/eclipse folder, even after restarting with "rationalsdp.exe -clean switch" I did not see the plugin.

Any other ideas while I update my RAD (might take the whole night!)
0
Madhu_AAuthor Commented:
I think it all depends on which version of RAD we are using. RAD6 does not like the plugins or something but for now I am living with starting/stopping server from outside the app.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Editors IDEs

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.