Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

Jboss Plugin for RAD 6

Posted on 2008-11-06
3
Medium Priority
?
1,385 Views
Last Modified: 2013-12-15
Hi, I need to install and run JBOSS server from within RAD. I hate building an ear and dropping it off in JBOSS directory everytime so I am looking for a plugin that WORKS.

I have already tried to put the plugin they have for eclipse under rad/eclipse folder but RAD is not picking it up (upon restart). They say the best way to add a plugin to RAD is go to help->software update and give it the external URL link. The URL which JBOSS had for the plugin is no longer working.

Somebody please give me the URL or let me know how to run JBOSS from within RAD 6.

0
Comment
Question by:Madhu_A
  • 2
3 Comments
 
LVL 1

Accepted Solution

by:
amorelos earned 1500 total points
ID: 22902409
1.- For this plugin that you are copying to you installation folder, are you using the -clean switch when you launch RAD again?

2.- I just tried with this update site: http://download.jboss.org/jbosside/updates/development/ , with the previous update site I updated a Ganymede install (Eclipse 3.4) and seems like I got a lot of JBoss stuff in my IDE. The previous update site is for the development release, this one is for the stable release: http://download.jboss.org/jbosstools/updates/stable.

3.- I'm using RAD 7, and I can perfectly work with a JBoss 4.0 server from this IDE, just in case you are considering to update your IDE.
0
 

Author Comment

by:Madhu_A
ID: 22902475
Hi, thanks for the links.

When I tried to select the necassary plugins from that site (JbossAS.. etc) it gives an error preventing the installation of the  plugin:
"JBossAS Tools (1.1.2.GA) requires plug-in "org.eclipse.jst.server.core (1.0.102)", or later version."

I checked for updates to my RAD and the update size is about 1.6GB!! (from RAD 6 to RAD 6.0.12)...I will try to get that update and then see if the plug in can be installed.

-- Yes for the previous plugin which I dropped in the rad/eclipse folder, even after restarting with "rationalsdp.exe -clean switch" I did not see the plugin.

Any other ideas while I update my RAD (might take the whole night!)
0
 

Author Closing Comment

by:Madhu_A
ID: 31514180
I think it all depends on which version of RAD we are using. RAD6 does not like the plugins or something but for now I am living with starting/stopping server from outside the app.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Here is a helpful source code for C++ Builder programmers that allows you to manage and manipulate HTML content from C++ code, while also handling HTML events like onclick, onmouseover, ... Some objects defined and used in this source include: …
Before we dive into the marketing strategies involved with creating an effective homepage, it’s crucial that EE members know what a homepage is. In essence, a homepage is the introductory, or default page, of a website that typically highlights the …
The viewer will learn how to use NetBeans IDE 8.0 for Windows to connect to a MySQL database. Open Services Panel: Create a new connection using New Connection Wizard: Create a test database called eetutorial: Create a new test tabel called ee…
The viewer will learn how to use and create new code templates in NetBeans IDE 8.0 for Windows.
Suggested Courses

571 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question