• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1364
  • Last Modified:

How do I re-enable auto-detection of devices such as speakers, headphones, etc.?

Hi there, I'm having trouble with a rather stupid Vista interface decision.  Before, whenever I plugged in my speakers and/or headphones into the computer Vista would show a window asking what I had intended to plug in.  If it was plugged in the right slot, it would say "device successfully installed" or something along those lines and my speakers/headphones/mic would then just work.  However, I recently accidentally checked the "Do not show this message again" box when trying to plug my speakers in the other day.  Because I hit that box, Vista no longer shows the auto-detect window when I plug things in, and as a result I can't get any audio playback from my computer whatsoever.  I know the problem is not my speakers/headphones, which work fine on any other computer I try them on.  I'm quite certain the problem is due to hitting that checkbox... however I am very unsure how to turn that feature back on.  Up until now internet searches for the problem have been fruitless.  Any suggestions???  
0
RhythmRunneR
Asked:
RhythmRunneR
  • 6
  • 6
2 Solutions
 
nobusCommented:
i believe it is not a vista option, but a sound driver option; so look in that software to enable it
0
 
RhythmRunneRAuthor Commented:
To be honest I'm not really sure how to do that.  I tried tinkering around with what I thought was the driver, but I think I might have just made things worse as I now don't have a device called "Speakers" listed.  Any way you could step me through the process it a bit?
0
 
nobusCommented:
i'll try.
what sound card do you have? and what software ?  soundmax?
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
RhythmRunneRAuthor Commented:
My sound card is integrated in my P5Q Deluxe motherboard.  It says in the direct diagnostics tool under sound1 name: SPDIF interface (SoundMAX Integrated Digital HD), and under sound 2 name: Digital Output (SoundMAX Integrated Digital HD).
0
 
nobusCommented:
did you install this driver ?  
http://support.asus.com/download/download.aspx?modelname=P5Q Deluxe&SLanguage=en-us
0
 
RhythmRunneRAuthor Commented:
I installed it but it didn't do anything.  I can't believe so much trouble has been caused by clicking a single checkbox.... as I said earlier though, under Control Panel\Hardware and Sound and inside Sound I no longer have a device called "Speakers" and instead SPDIF Interface is all that is listed.  The problem with that is under it's properties in Jack Information it says Real Panel Optical Jack... but I don't have speakers that plug into that.  "Speakers" used to have the traditional 6 multi-colored jacks listed in that same area, but I have no idea how to get that back.
0
 
nobusCommented:
if you right click the icon in the system tray, and select playback devices; then right click on the speakers - does that give you anything more ?
0
 
nobusCommented:
btw - i have vista and soundmax too..
0
 
RhythmRunneRAuthor Commented:
I tried using the system tray but the only two options in it are SPDIF Interface and Digital Output... I got rid of the speakers option on accident. : (  Any ideas there?  And have you ever have this much trouble with vista and soundmax???  This whole thing is driving me crazy, I need my music back! haha
0
 
nobusCommented:
right click the spdif - are the "show disabled devices" checked?, and"show disconnected devices" ?
0
 
RhythmRunneRAuthor Commented:
Ok thanks, I did that and now speakers is back.  I still don't have sound though.  I tried pressing the "configure" button but none of the test options worked.  It seems I'm very close to the solution, I just need a little help.  Thanks for the help so far, hopefully you can help me finally get sound back!
0
 
RhythmRunneRAuthor Commented:
Nevermind, I was able to figure out the rest by tinkering with the options a bit more.  Thanks for all the help!
0

Featured Post

Prep for the ITIL® Foundation Certification Exam

December’s Course of the Month is now available! Enroll to learn ITIL® Foundation best practices for delivering IT services effectively and efficiently.

  • 6
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now