Cannot join samba domain with Vista

I've just received a dell notebook with vista business. I'm trying to connect it to our samba 2.2 domain running under redhat but with no success. This is the first vista machine i am trying to connect.

I tried changing the Network Security: LAN Manager authentication level from "NTVLM2 responses only" to "LM and NTLM  use NTLMV2 session security if negotiated"

Any ideas?

Thank you.
Teo
temmelvAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

woolmilkporcCommented:
Hi,
 
this seems to be a problem of  password encryption.
Try to use unencrypted passwords!
 
wmp
0
temmelvAuthor Commented:
If you're referring to "Send unecrypted password to third-party SMB servers" this is disbabled.

Teo
0
woolmilkporcCommented:
So, enable it and see what will happen!
 
0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

temmelvAuthor Commented:
No luck.

I forgot to mention the error message which is the same
"Logon failure: unknown user name or bad password"

Teo
0
woolmilkporcCommented:
Sorry, but I have to ask this -
is the user you're trying to connect as really defined in the samba server (smbpasswd) and is the password correct?
wmp
 
0
temmelvAuthor Commented:
Yes it is. I disconnected my old laptop which was running xp. I'm using the same user.
I also tried root to connect. This is something that we do for every pc we connect to our domain.

Maybe i'll try to delete the user from the server and create it again.

Teo
0
woolmilkporcCommented:
Did your IP address change while there is a 'hosts allow' statement in your smb.conf, either global or for your share?
 
wmp
0
temmelvAuthor Commented:
Yes i'm using a different ip, but we dont use the "hosts allow" statement.

Teo
0
woolmilkporcCommented:
One more silly question -
did you enable 'NetBios over TCP/IP' in your TCP/IP / WINS properties?
This, along with the 'encrypted passwords" thing are the only clues with Windows Vista and Samba I know about.
 
wmp
 
.
0
temmelvAuthor Commented:
It was set to default and i set it to enable. no luck again.

if i spell wrong the domain it gives me a message that it cant find the domain controller.

so it is finding the dc but as you original stated something is going wrong with the user/password.

teo
0
woolmilkporcCommented:
One more (rather strange) hint -
please check in your registry under
 HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Lsa
the setting of
  LmCompatibilityLevel
Is it set to '1' (should be, according to your post).
If not, set it to '1' and give it a try!
 
wmp
0
woolmilkporcCommented:
... and check your personal firewall settings regarding LM/NTLM.
I have no Vista at hand now, so I can't tell you where it might be.
 
wmp
 
0
woolmilkporcCommented:
... and again -
in secpol (where you set your LAN Manager authentication)  check under  Domain Member  the settings of digital encryption/signature. Test by setting to 'disable'
0
temmelvAuthor Commented:
no luck.

i can understand now why alot of people have trashed vista.

teo.
0
woolmilkporcCommented:
Well, right you are, but some people do get samba shares mounted under Vista.
To resume -
the most important thing is the one you did before asking your question - the LM/NTLM stuff,
second, the 'send unencrypted oasswords'  part
and, given the samba config on the server is correct,  perhaps some firewall settings,
and (as it is only Windows) -
 
reboot.
 
If this is all done, I must confess - no more idea.
 
But - I'll do some more research ...
 
wmp
 
0
woolmilkporcCommented:
Do you have security = share in your [global]?
I hear there could be problems with that, too.
0
temmelvAuthor Commented:
no

Teo
0
woolmilkporcCommented:
Try '[WORKGROUP]\[username]' instead of [username] alone.
 
desperately -
wmp
 
0
woolmilkporcCommented:
Do you see a chance to install samba 3.0.2 on your server?
 
Read this -
 
http://www.swerdna.net.au/linhowtosambavista.html
 
wmp
 
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
temmelvAuthor Commented:
Yes, i guess we have to do this.


Teo
0
woolmilkporcCommented:
So,
good luck, and have fun and success!
 
Norbert (wmp)
 
0
woolmilkporcCommented:
Hi again,
there is one more thing that once helped to solve the issue -
- do you have 'netbios name = [something]' in your smb.conf?
Try to leave it out! As I guess, you don't need it and - it once helped!
 
Norbert (wmp)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Server Software

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.