ActiveX Error on Server 2008

Server 2008 Standard with Hyper-V & SP1
Virtual Server 2005 R2 with GUI interface

When I click-on the Remote View Thumbnail to view a Virtual Machine (guest) from the Virtual Server Administration Website web page, I receive a new web page with the following error message:
------
"The Virtual Machine Remote Control uses an ActiveX control that requires Internet Explorer 5.5 or later. If the Remote Control view doesn't appear above, verify that you have enabled the "Download signed ActiveX controls" option in Internet Explorer. For additional help using the Remote Control, click here."
------

Other Information:
1) The Remote View Thumbnail works as expected if I run it from a remote computer
2) I have tried changing the {...Download ...} settings in IE but still doesn't work
3) If I use a VMRC client method, the VMRC thumbnail works but the Admin View page very limited
4) The WS2008 machine is part of a SBS 2003 Premium domain
5) The SBS 2003 machine has dual NICs and is running ISA 2004
6) I am logged on as a Domain Admin
7) UAC has been turned off


I suspect the issue is with the ?New&Improved? security ?features? in WS2008 but I have done all I know how to do.

Thanks for the help,
Slator
SlatorAsked:
Who is Participating?
 
Rob WilliamsConnect With a Mentor Commented:
Have you tried turning off IE Enhanced Security Configuration, at least for admins? You can do so by clicking on "Configure IE ESC" (for right) in the Server management console.
Also within IE set the following to enable or prompt:
Tools | Internet Options | Security | Custom | Active-X Controls and plug-ins |
-Download signed Active-X controls
-Run Active-X controls and plug-ins

0
 
dfxdeimosConnect With a Mentor Commented:
1) Go to %SYSTEMROOT%\Program Files\Microsoft Virtual Server\WebSite\VirtualServer\activex.

2) Extract VMRCActiveXClient.cab to a temp location.

3) Right click on VMRCActiveXClient.dll or VMRCActiveXClient64.dll file (depending on your system).

4) Click "open with", browse to %SYSTEMROOT%\WINDOWS\system32, and open with REGSVR32 to register the DLL.

You can delete temp files afterwards if you want.
0
 
SlatorAuthor Commented:
Sorry for th delay!

For RobWill
---------------
Yes, I have already tried you suggestion(s) and +++
Nothing in this area made any difference.


For dfxdeimos
------------------
I implemented your solution - but the problem still exists - with same errors
NOTE:  I received a "...success..." message after 4)

Is there something else I need to do - restart, etc.



0
 
SlatorAuthor Commented:
The problem is still un-resolved but I implemented a work-around for now.
I split points with those who took the time to comment - thanks.
0
 
Rob WilliamsCommented:
Thanks Slator. Sorry we were not able to resolve.
Cheers !
--Rob
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.