Can't run .exe from share "Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the files."

I have two Windows 2003 R2 Std. servers.  one KDC & one Exchange server.  I have a share setup on the KDC that contains .exe's.  I map/browse to the sharepoint from the exchange server and receive the following message when trying to run the .exe
"Windows cannot access the specified device, path, or file.  You may not have the appropriate permissions to access the files."

I know my perm. are set correctly because I can create, modify .txt files in the same share from the Exchange server.  Additionally, I can also go to a workstation (XP) login as the same user and run the .exe.  I've seen an article that tell me to disable the IE ESC, which I have done and it didn't correct the problem.  I fixed this by adding file://<servername> to the trusted sites list in IE.  

This doesn't seem right to me.  Why do I have to add an internal server to my trusted sites list.  Obviously this server is trusted in other regards as it authenticates the use logging in and also supplies the server with its browsing list.  Can anyone give me some information for this?  Is something misconfigured?  Is this normal?

Thanks Experts
LVL 1
ZorniacAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

cahancockCommented:
Go to the Control panel, and Add/Remove programs and then click windows Components. Check to see if the Internet Explorer Enhanced Security Configuration is checked. Uncheck it if it is to disable this feature. Then logoff and log log on again and it should be working as long as you have the proper permissions for the share,
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ZorniacAuthor Commented:
cahancock- i had previously removed IE ESC from Windows components, and when that didn't work, I added the UNC to the trusted sites list.  Things then began to work.  I however didn't logoff after removing IE ESC.  So I removed the UNC from trusted sites list logged off/on and I can browse the share and run the executable w/o having to add it back to the trusted sites list.  

What I want to know is, I previously worked in an environment where we had IE ESC enabled but I was also able to run .exe from any of our servers remotely while logged onto a server w/o having to add them to a trusted sites list or disable IE ESC.  The difference was we used IE 6 vs. now we use IE 7.  

I would like to know why these changes have to be made now, as opposed to not having to make these changes previously.

Thanks
0
cahancockCommented:
It is Microsoft's attempt to increase the security of its OS and Web Browser. They have taken a lot of heat about their security compared to Linux and firefox and even Mac OSX and safari. This is one of their security "improvements".
0
ZorniacAuthor Commented:
That seems reasonable, quirky, but reasonable.  Thanks for the infor cahancock
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.