[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

split tunneling

Posted on 2008-11-07
14
Medium Priority
?
687 Views
Last Modified: 2012-06-27
Right now my asa 5505 is running split tunneling so my internet traffic goes out the local ISP. I want to change that so all traffic from the site with the 5505 goes to our corporate location. Below is my current access list config on the asa.

access-list IPsec-traffic extended permit ip 10.30.1.0 255.255.255.0 10.1.0.0 255.255.0.0
access-list nonat extended permit ip 10.30.1.0 255.255.255.0 10.1.0.0 255.255.0.0
0
Comment
Question by:dtadmin
  • 6
  • 6
  • 2
14 Comments
 
LVL 4

Expert Comment

by:futurefiles
ID: 22905639
can we have the full config please minus your external ip's ;0)
0
 
LVL 4

Expert Comment

by:futurefiles
ID: 22905668
I think you just need to remove these two lines?
split-tunnel-policy tunnelspecified
split-tunnel-network-list
0
 

Author Comment

by:dtadmin
ID: 22905692
ciscoasa# sh run
: Saved
:
ASA Version 7.2(4)
!
hostname ciscoasa
domain-name ad.davey-tree.com
enable password Rpz2/mE0AmvJusgU encrypted
passwd lzKclDVaWpZCEbwl encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.30.1.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address dhcp
!
interface Vlan3
 no forward interface Vlan1
 nameif dmz
 security-level 50
 ip address 192.168.1.1 255.255.255.0
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns server-group DefaultDNS
 domain-name ad.davey-tree.com
access-list IPsec-traffic extended permit ip 10.30.1.0 255.255.255.0 10.1.0.0 255.255.0.0
access-list nonat extended permit ip 10.30.1.0 255.255.255.0 10.1.0.0 255.255.0.0
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu dmz 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list nonat
nat (inside) 1 0.0.0.0 0.0.0.0
route outside 0.0.0.0 0.0.0.0 192.168.0.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
http server enable
http 10.30.1.0 255.255.255.0 inside
http 10.1.0.0 255.255.0.0 inside
http redirect inside 80
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ASA esp-3des esp-md5-hmac
crypto map IPSEC 10 match address IPsec-traffic
crypto map IPSEC 10 set peer *******
crypto map IPSEC 10 set transform-set ASA
crypto map IPSEC interface outside
crypto isakmp identity address
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash md5
 group 2
 lifetime 86400
crypto isakmp nat-traversal  20
telnet timeout 5
ssh 10.0.0.0 255.0.0.0 inside
ssh 10.0.0.0 255.0.0.0 outside
ssh timeout 5
console timeout 0
management-access inside
dhcpd dns 10.1.200.108 10.1.200.16
dhcpd wins 10.1.200.17 10.1.200.16
dhcpd domain ad.davey-tree.com
!
dhcpd address 10.30.1.10-10.30.1.30 inside
dhcpd enable inside
!

username admin password GxVBLPl/Y2el0TMp encrypted
tunnel-group ***** type ipsec-l2l
tunnel-group ***** ipsec-attributes
 pre-shared-key *
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect netbios
  inspect rsh
  inspect rtsp
  inspect skinny
  inspect esmtp
  inspect sqlnet
  inspect sunrpc
  inspect tftp
  inspect sip
  inspect xdmcp
  inspect icmp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:5a332da80ad7a47e768fedd071577867
: end
0
Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

 
LVL 2

Expert Comment

by:lnavin
ID: 22906272
You should change the following;
This determines what traffic traverses the IPSEC tunnel.
access-list IPsec-traffic extended permit ip 10.30.1.0 255.255.255.0 10.1.0.0 255.255.0.0
TO
access-list IPsec-traffic extended permit ip 10.30.1.0 255.255.255.0 any

Update the following line to increase the no-nat scope.

access-list nonat extended permit ip 10.30.1.0 255.255.255.0 10.1.0.0 255.255.0.0
TO
access-list nonat extended permit ip 10.30.1.0 255.255.255.0 any
0
 

Author Comment

by:dtadmin
ID: 22906895
Am I going to have to update my access lists on the firewall at the corporate location that the ASA terminates into?
0
 
LVL 4

Expert Comment

by:futurefiles
ID: 22907429
what hardware does it terminate to?
0
 

Author Comment

by:dtadmin
ID: 22907439
PIX515
0
 
LVL 2

Expert Comment

by:lnavin
ID: 22907535
Can you post the 515 config?

You will likely need to increase the NAT scope to include the remote network.
0
 
LVL 4

Expert Comment

by:futurefiles
ID: 22907576
I dont agree with lnavin's comment
surely all that would do is allow any ip to traverse the tunnel?

I dont claim to be an expert but have configured quite a few ASA 5505 / 5510 / 5520's over the past few weeks.
My understanding is that split tunneling applies to the client software, and achieved using security policies, like this...
group-policy vpnclientgroup internal
group-policy vpnclientgroup attributes
 dns-server value 192.168.1.10
 wins-server value 192.168.1.10
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value Split_Tunnel_List_ACL
 vpn-tunnel-protocol IPSec
 default-domain value YOURDOMAIN.com

Someone please correct me if i am way off...
What your trying to achive is forcing all traffic from the ASA to go out via the Pix right?
surely thats just routing?

0
 

Author Comment

by:dtadmin
ID: 22907601
yes that is correct. I want internet bound traffic to go through corporate instead of the local ISP.
0
 
LVL 4

Expert Comment

by:futurefiles
ID: 22907668
OK I think you need the split tunnel commands but using
split-tunnel-policy tunnelall
I got it wrong about only being for the client, it does actually work with site to site
Have a look at this post

http://www.experts-exchange.com/Security/Software_Firewalls/Enterprise_Firewalls/Cisco_PIX_Firewall/Q_23751765.html
0
 

Author Comment

by:dtadmin
ID: 22907802
how would I set this up for my scenario. I have 1 pc hardwired into the ASA and want the internet traffic from it to go through the tunnel to corporate.
Where do I apply the "split-tunnel-policy tunnelall" command?
0
 
LVL 4

Accepted Solution

by:
futurefiles earned 1500 total points
ID: 22907833
Give me till tomorrow and I will test it out and post the config
0
 

Author Comment

by:dtadmin
ID: 22907859
roger that. Thanks!!
0

Featured Post

A Cyber Security RX to Protect Your Organization

Join us on December 13th for a webinar to learn how medical providers can defend against malware with a cyber security "Rx" that supports a healthy technology adoption plan for every healthcare organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

As managed cloud service providers, we often get asked to intervene when cloud deployments go awry. Attracted by apparent ease-of-use, flexibility and low computing costs, companies quickly adopt leading public cloud platforms such as Amazon Web Ser…
In this article, the configuration steps in Zabbix to monitor devices via SNMP will be discussed with some real examples on Cisco Router/Switch, Catalyst Switch, NAS Synology device.
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…
Suggested Courses

872 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question