CLASSPATH setting in WebLogic 10.0

hi

How and where (setDomainEnv.sh or CommEnv.sh or startWebLogic.sh) do you set the CLASSPATH for the admin server and for the managed servers in weblogic 10.0?

In my environment I had set the CLASSPATH in setDomainEnv.sh. And when I start admin server it is taking the path from setDomainEnv.sh.
And moreover when i start Managed servers with out node manager they too are taking the CLASSPATH from some where.

How and where do i set the classpath is i have to start managed servers with node manager?
Any reference docs for the same?
skolakanuruAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rajesh_balaCommented:
Hi,

1. Weblogic take the classpath from setDomainEnv.sh. StartWeblogic.sh internally makes a call to the above script. So it is highly advisable if you could change your CLASSPATH and PRE_CLASSPATH (if you would like some classes to be loaded before everything) setting in setDomainEnv.sh.

2. Node always gets the configuration settings from admin server. That is the reason, you start it like startManagedWeblogic.sh <nodename> <adminserver:port>

When starting the node, it contacts the admin server and fetches the config.xml from the server.
0
skolakanuruAuthor Commented:
hi rajesh,

where do you set the classpath when using the node manager to start the nodes.

is that in SetEnv.sh script?

coz according to the below doc i am thinking that it should be set in setEnv.sh

http://e-docs.bea.com/wls/docs100/cluster/trouble.html#gc

0
rajesh_balaCommented:
We can either set it in setEnv.sh (in which case, you have to run setEnv.sh before starting the managed server).

Other crude option is to directly set it in setDomainEnv.sh which is as well called by startManagedServer.sh.

Both should work
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
skolakanuruAuthor Commented:
Thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Java App Servers

From novice to tech pro — start learning today.