Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

OWA and Remote Web workplace over PIX firewall

Posted on 2008-11-07
6
Medium Priority
?
678 Views
Last Modified: 2012-08-14
Hi everyone,
I am having a tough time here.  I am trying to get Outlook Web Access (OWA) and Remote Web Workplace (RWW) to work over a PIX firewall.  The server is running Microsoft Small Business Server 2003.  I have OWA and RWW running on a SSL cert INSIDE of the firewall just fine.  However, once I try to access it through the PIX, I get nothing.  Check out my code below.

Important IP's :  My server 10.100.100.2
                         PIX inside interface 10.100.100.1
                         Our ISP static IP 24.x.x.30
                         Our ISP gateway IP 24.x.x.1


pixfirewall(config)# show run
: Saved
:
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password FQ4orRPEuDfqzY4w encrypted
passwd FQ4orRPEuDfqzY4w encrypted
hostname pixfirewall
domain-name ciscopix.com
clock timezone EST -5
clock summer-time EDT recurring
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 10.100.100.2 Server
access-list remote_splitTunnelAcl permit ip 10.0.0.0 255.0.0.0 any
access-list inside_outbound_nat0_acl permit ip 10.0.0.0 255.0.0.0 10.100.100.0 255.255.255.224
access-list outside_cryptomap_dyn_20 permit ip any 10.100.100.0 255.255.255.224
access-list inside_access_in permit ip any any
access-list fromoutside permit tcp any host 24.x.x.30 eq 3389
access-list fromoutside permit tcp any host 24.x.x.300 eq https
access-list fromoutside permit tcp any host 24.x.x.30 eq 444
access-list fromoutside permit tcp any host 24.x.x.30 eq ftp
access-list fromoutside permit tcp any host 24.x.x.30 eq smtp
access-list fromoutside permit tcp any host 24.x.x.30 eq www
access-list fromoutside permit tcp any host 24.x.x.30 eq pptp
access-list fromoutside permit tcp any host 24.x.x.30 eq 4125
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 24.x.x.30 255.255.255.0
ip address inside 10.100.100.1 255.0.0.0
ip audit info action alarm
ip audit attack action alarm
ip local pool vpn 10.100.100.10-10.100.100.20
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp 24.x.x.30 smtp Server smtp netmask 255.255.255.255 0 0
static (inside,outside) tcp 24.x.x.30 https Server https netmask 255.255.255.255 0 0
static (inside,outside) tcp 24.x.x.30 3389 Server 3389 netmask 255.255.255.255 0 0
static (inside,outside) tcp 24.x.x.30 www Server www netmask 255.255.255.255 0 0
static (inside,outside) tcp 24.x.x.30 4125 Server 4125 netmask 255.255.255.255 0 0
static (inside,outside) tcp 24.x.x.30 pptp Server pptp netmask 255.255.255.255 0 0
static (inside,outside) tcp 24.x.x.30 444 Server 444 netmask 255.255.255.255 0 0
access-group fromoutside in interface outside
access-group inside_access_in in interface inside
route outside 0.0.0.0 0.0.0.0 24.x.x.1 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 10.0.0.0 255.0.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
sysopt connection permit-l2tp
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup remote address-pool vpn
vpngroup remote default-domain medart.local
vpngroup remote split-tunnel remote_splitTunnelAcl
vpngroup remote idle-time 1800
vpngroup remote password ********
telnet 10.0.0.0 255.0.0.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address Server-10.100.100.129 inside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
terminal width 80
Cryptochecksum:410a099298f4871dff60c20fa8921ee8
: end

Open in new window

0
Comment
Question by:dcaggiano
  • 2
  • 2
  • 2
6 Comments
 
LVL 63

Expert Comment

by:SysExpert
ID: 22907624
Not sure, but you need port forwarding of  port 25, 80, 443 , 3389 from the outside to the SBS server on the router. That's it.


I hope this helps !
0
 
LVL 63

Expert Comment

by:SysExpert
ID: 22907633
ALso need to have a Public DNS IP on the router.

access via

https://server-DNS/exchange

0
 

Author Comment

by:dcaggiano
ID: 22907832
I have all of that.  The "ip address outside 24.x.x.30 255.255.255.0" statement is setting my ip address (and yes it is a static IP from the ISP).  Also, ports 25(SMTP), Port 80 (Http), Port 443 (HTTPS), and port 3389 are enabled as far as I can tell unless there is an error in my code.  Any pix experts out there with some insight?
0
The IT Degree for Career Advancement

Earn your B.S. in Network Operations and Security and become a network and IT security expert. This WGU degree program curriculum was designed with tech-savvy, self-motivated students in mind – allowing you to use your technical expertise, to address real-world business problems.

 
LVL 28

Expert Comment

by:batry_boy
ID: 22908085
Try this:

no static (inside,outside) tcp 24.x.x.30 smtp Server smtp netmask 255.255.255.255
no static (inside,outside) tcp 24.x.x.30 https Server https netmask 255.255.255.255
no static (inside,outside) tcp 24.x.x.30 3389 Server 3389 netmask 255.255.255.255
no static (inside,outside) tcp 24.x.x.30 www Server www netmask 255.255.255.255
no static (inside,outside) tcp 24.x.x.30 4125 Server 4125 netmask 255.255.255.255
no static (inside,outside) tcp 24.x.x.30 pptp Server pptp netmask 255.255.255.255
no static (inside,outside) tcp 24.x.x.30 444 Server 444 netmask 255.255.255.255
static (inside,outside) tcp interface smtp Server smtp netmask 255.255.255.255
static (inside,outside) tcp interface https Server https netmask 255.255.255.255
static (inside,outside) tcp interface 3389 Server 3389 netmask 255.255.255.255
static (inside,outside) tcp interface www Server www netmask 255.255.255.255
static (inside,outside) tcp interface 4125 Server 4125 netmask 255.255.255.255
static (inside,outside) tcp interface pptp Server pptp netmask 255.255.255.255
static (inside,outside) tcp interface 444 Server 444 netmask 255.255.255.255
access-list fromoutside permit tcp any interface outside eq 3389
access-list fromoutside permit tcp any interface outside0 eq https
access-list fromoutside permit tcp any interface outside eq 444
access-list fromoutside permit tcp any interface outside eq ftp
access-list fromoutside permit tcp any interface outside eq smtp
access-list fromoutside permit tcp any interface outside eq www
access-list fromoutside permit tcp any interface outside eq pptp
access-list fromoutside permit tcp any interface outside eq 4125
no access-list fromoutside permit tcp any host 24.x.x.30 eq 3389
no access-list fromoutside permit tcp any host 24.x.x.300 eq https
no access-list fromoutside permit tcp any host 24.x.x.30 eq 444
no access-list fromoutside permit tcp any host 24.x.x.30 eq ftp
no access-list fromoutside permit tcp any host 24.x.x.30 eq smtp
no access-list fromoutside permit tcp any host 24.x.x.30 eq www
no access-list fromoutside permit tcp any host 24.x.x.30 eq pptp
no access-list fromoutside permit tcp any host 24.x.x.30 eq 4125
no access-group inside_access_in in interface inside

These commands are essentially just changing the syntax of your existing static translations and access list statements to the syntax Cisco recommends when performing port redirection.  You also can remove the ACL applied to the inside interface since that is the default behavior anyway.
0
 

Accepted Solution

by:
dcaggiano earned 0 total points
ID: 22915050
Hi Everyone,
Thanks for your help.  I found out the problem on my own.  The ISP was blocking certain ports and I had to upgrade from a small business connection to a business connection.  I guess armstrong cable blocks ports 1-100 on the small business accounts.  Anyhow, once the service was changed it started working immediately.  Thanks for your input though batry_boy.  I will look that code over more and try to clean up mine.
0
 
LVL 28

Expert Comment

by:batry_boy
ID: 22917215
Glad you got it resolved!
0

Featured Post

Nothing ever in the clear!

This technical paper will help you implement VMware’s VM encryption as well as implement Veeam encryption which together will achieve the nothing ever in the clear goal. If a bad guy steals VMs, backups or traffic they get nothing.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

WARNING:   If you follow the instructions here, you will wipe out your VTP and VLAN configurations.  Make sure you have backed up your switch!!! I recently had some issues with a few low-end Cisco routers (RV325) and I opened a case with Cisco TA…
As managed cloud service providers, we often get asked to intervene when cloud deployments go awry. Attracted by apparent ease-of-use, flexibility and low computing costs, companies quickly adopt leading public cloud platforms such as Amazon Web Ser…
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…
Suggested Courses

581 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question