• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 10342
  • Last Modified:

Dell PowerVault MD3000i - Setup?

Hi,
I've purchased a Dell PowerVault MD3000i, dual controllers, with the below hard disks installed:

10x 146GB
2x500GB
3x750GB

I need to build the following 'drives':

6 disk RAID 10
4 disk RAID 10
2 disk RAID 1   (using the 500GB disks)
3 disk RAID 5   (using the 750GB disks)

I've physically installed the SAN into my rack, but have no idea how to cable it up properly to utilise the redundancy and software install.

Is there a guide on the web? Where do I start?

Id much appreciate a good kick start!?!

Fals
0
falsit
Asked:
falsit
  • 9
  • 9
1 Solution
 
-JerodRCommented:
Dell usually tries to sell remote assistance with this unit.  Make sure you don't have it before you start to dig in too deep.  They might still help you to some extent, just calling tech support.  Their experts have proved to be quite helpful to me in the past.

Here is the tech support number: (866)876-3355


0
 
falsitAuthor Commented:
Thanks JerodR, however I'm a newbie in the UK! :)
0
 
futurefilesCommented:
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
falsitAuthor Commented:
Thanks futurefiles, i'll take a read.

in advance, will i need to modify my host NICs for jumbo frame size.  i understand that the default NIC frame size is something 1500 and i'll need to modify the frames to 9000.

what's the deal with jumbo frames when it comes to this SAN?

do i need special network switches too?
0
 
falsitAuthor Commented:
Also, the above link lists a few decent PDFs however none talk about cabling.  in one of the PDFs it references "Setting up your powervault md3000i" as being the one about cabling but the above website doesn't list this PDF.

any ideas about MD3000i cabling?
0
 
futurefilesCommented:
in what respect? network cabling... adding DAE's or? please be more specific about what you want to achieve.
0
 
falsitAuthor Commented:
Hi,

I've cabled the MD3000i up as follows:

1xMD3000i with two dual RAID controllers.

3x servers (2xDell PE2950 and 1xDell PE1950)

Two switches, one Powerconnect and and existing Netgear.

Each RAID controller plugs into the Dell PowerConnect and Netgear switch for redundancy.
I plug 1 management port per RAID controller into the Dell Powerconnect and 1 management port into the Netgear.

I have installed the MD management software onto the three servers, with only one active search (i forget what it called it, but it said upon install that only one instance of the software could search (?) ).

Each server can find the storage array via out-of-band configuration.   when i first autodetected the array both management ports were detected and had an IP address.

Problems:
1. trying to give each management port a static IP address, I've 'accidentally' turned on remote login for one of the management ports, and now it won't get an IP address, on the summary page it only recognises 1 management port in out-of-band.  I've tried to allow DHCP again to give the IP, but it gives a 192.168.120.101 IP, whereas my subnet is 192.2.12.x.      i can't remove the 'remote login' as it says the port isn't configured as out-of-band, and i must do that first.     I've countless times tried to search for the RAID controller, but nothing works.    How do i get the management port/raid controller to be recognised again, so that i can remove the 'remote login' option?

2. I'm not able to add any hosts.  do i need to do anything on each host? maybe with this initiator? that i've pre-req installed - any config needed for each server?

0
 
falsitAuthor Commented:
ok, now i've played around with them management ports so much, I now can't even auto detect the array!!!   how do i add the storage array to the MD software it it won't autodetect and if i don't know the manual IP addresses?   i've tried the default 192.168.128.101 and x.x.x.102

any ideas?


How can i reset the array back to factory settings???
0
 
futurefilesCommented:
I'll try and get answer on the management port issue, but you should still be able to access the system regardless.
Are your servers running windows? is this your first time using ISCSI?
If so install the windows iscsi initiator then open it and click on discovery click add and pop the ip address of the MD3000i in there. You should now see the disks in the targets tab click the disk you want and click logon
0
 
futurefilesCommented:
let me look through the manual!
0
 
futurefilesCommented:
0
 
futurefilesCommented:
The storage array looks for dhcp by default so has it picked up an ip from your dhcp server?
0
 
futurefilesCommented:
If youve set it for inband management the IP'S are

Controller 0, Port 0: IP: 192.168.130.101

Controller 0, Port 1: IP: 192.168.131.101

Controller 1, Port 0: IP: 192.168.130.102

Controller 1, Port 1: IP: 192.168.131.102
0
 
falsitAuthor Commented:
Thanks futurefiles, the link you've given there is the one i've been using throughout, very informative.

This is the first time i've used iSCSI, so yes do need to configure each Initiator on each host, one of the hosts is server 2008, the other two are windows 2003.

I'm not able to do what you ask in the intiator discovery tab as i don't know what the management port IP addresses are, it's not accepting 192.168.128.101 or x.x.x.102 and the DNS/DHCP isn't showing the MD3000i SAN listed.

I'm not physcially present, so i must need to force a reset of the SAN hardware.

I would like to know how to start again from fresh with the knowledge i now have I'm confident i won't breka it again!   How do i reset to factory default settings?

0
 
falsitAuthor Commented:
when i search for the array, it fails to find it...is actually now just hangs towards the end of the search.

looks like it needs a hardware reset.  :S
0
 
futurefilesCommented:
I'll see if i can find out how to do a fctory reset, my hunch is using the management cable (round plug about 9 pins i think) and opening a terminal session..... did you get one of these cables?
I'll find out if this is correct...
0
 
falsitAuthor Commented:
no, pretty sure i didn't :(
0
 
falsitAuthor Commented:
Hi - I've now got it all working...

Two switches, both iSCSI ports being plugged in each switch.

The two management port,s 1 being plugged into each switch.

1 host, with two NIC, plugging into each switch.

Isolated away from rest of network, so no access to DHCP/DNS.

1 host NIC's IP configured as same subnet as the management ports:
192.168.128.10
subnet: 255.255.0.0
management ports are 192.168.128.101 and 192.168.128.102

I've set the subnet to 255.255.0.0, so as the iSCSI initiator can see the ports.  
On the host, i've configured the iSCSI initiator, on Discovery new portals by adding each of the 4 RAID IPs:
RAID controller 0:
192.168.130.101
192.168.131.101

RAID controller 1
192.168.130.102
192.168.131.102



ok...the next problem i have is when i plug the SAN into my network, my network slows to a crawl and dies!. ouch!
I believe this is related to JUMBO mtu packet sizes of 1500 and i believe they should be at 9000.  this being set on each hosts' NIC cards.

Can you confirm this, what's your expereince with JUMBO mtu packet sizes?
0

Featured Post

Get your Disaster Recovery as a Service basics

Disaster Recovery as a Service is one go-to solution that revolutionizes DR planning. Implementing DRaaS could be an efficient process, easily accessible to non-DR experts. Learn about monitoring, testing, executing failovers and failbacks to ensure a "healthy" DR environment.

  • 9
  • 9
Tackle projects and never again get stuck behind a technical roadblock.
Join Now