?
Solved

Received from  www.mydomain.com[127.0.0.1] change to www.mydomain.com[my rdns address]

Posted on 2008-11-07
6
Medium Priority
?
321 Views
Last Modified: 2013-12-18
In all the emails my site is sending in its header a 127.0.0.1 address as its first hop! This is a problem because some spam blockers will block on this. denying anything that orginates from a 127.0.0.1 address. Any ideas on how to change this to my dns address?

Return-Path: <service@mydomain.com>

Received: from www.mydomain.com ([216.x.x.x])
      by uni02mr.unity.ncsu.edu (8.13.7/8.13.8/Nv5.2008.0610.1) with ESMTP id mA7J8J0D014820
      for <me@someotherdomain.edu>; Fri, 7 Nov 2008 14:08:19 -0500 (EST)
Received: from www.mydomain.com (www.mydomain.com [127.0.0.1])
      by www.mydomain.com (8.13.1/8.13.1) with ESMTP id mA7J7YVi027954
      for <me@someotherdomain.edu>; Fri, 7 Nov 2008 14:07:34 -0500
Date: Fri, 7 Nov 2008 14:07:34 -0500
Message-ID: <27312399.1226084854114.JavaMail.root@www.mydomain.com>

host file:
# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1               mydomain.com

0
Comment
Question by:mhp2007
  • 3
  • 2
6 Comments
 
LVL 86

Expert Comment

by:CEHJ
ID: 22908007
>>Received: from www.mydomain.com ([216.x.x.x])

Is what it's saying isn't it? That's a public address
0
 

Author Comment

by:mhp2007
ID: 22908055
Yes, but that's not the message for the original hop, I'd like that one to use the public address.
0
 
LVL 86

Expert Comment

by:CEHJ
ID: 22908414
I'm guessing that you're using JavaMail to send on the first hop. Is that the case?
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:mhp2007
ID: 22908432
Yes, you guess right : <27312399.1226084854114.JavaMail.root@www.mydomain.com>... can i set a from IP address in java?
0
 
LVL 26

Accepted Solution

by:
jar3817 earned 1000 total points
ID: 22914188
The first hop is the localhost address because the first hop is from a local process (a webserver) to the local mail server. Don't worry about it, this is common and not the reason your mail is getting rejected.
0
 
LVL 86

Assisted Solution

by:CEHJ
CEHJ earned 1000 total points
ID: 22915532
The important thing, as far as anti-spam measures are concerned is that the domain/address can be checked at each stage. Obviously, 127.0.0.1 can't be. Try setting the property

mail.smtp.localaddress

to your public address
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this post we will learn how to make Android Gesture Tutorial and give different functionality whenever a user Touch or Scroll android screen.
As cyber crime continues to grow in both numbers and sophistication, a troubling trend of optimization has emerged over the last year.
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…
Established in 1997, Technology Architects has become one of the most reputable technology solutions companies in the country. TA have been providing businesses with cost effective state-of-the-art solutions and unparalleled service that is designed…
Suggested Courses
Course of the Month16 days, 7 hours left to enroll

862 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question