event id 3005 - HTTP status code: [400].

I have an Exchange 2003 sp2 front end/back end configruation.  I'm getting an event id 3005 over and over and over..   Below is the actual event id.

Event Type:      Error
Event Source:      Server ActiveSync
Event Category:      None
Event ID:      3005
Date:            11/7/2008
Time:            1:53:40 PM
User:            domain\user
Computer:      MAILSCAN2
Description:
Unexpected Exchange mailbox Server error: Server: [backendserver.domain.local] User: [user@mydomain.com] HTTP status code: [400]. Verify that the Exchange mailbox Server is working correctly.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
gopher_49Asked:
Who is Participating?
 
florin_sCommented:
Hi,

here is a list of causes and resolutions found on another site:

Jerry Haskins (Last update 8/3/2008):
I started getting this error and mobile phones would not sync anymore after adding alias IP addresses to the server. After removing the alias IP addresses the error went away and mobile phones could sync with the Exchange server again.

Anonymous (Last update 9/10/2007):
In my case, these errors started when I implemented the use of host headers on my IIS web sites. I have two web sites on the Exchange server and started using host headers to distinguish them. To fix the issue I created an identity with a blank host header on the site hosting Exchange.

Mihai Andrei (Last update 7/4/2007):
This issue may occur if one or more following conditions are true:

1. The authentication method is incorrect for the virtual directories that are used by Microsoft ActiveSync.
2. The application name points to an incorrect entry in the Outlook Mobile Access virtual directory.
3. The application name points to an incorrect entry in the Microsoft-Server-ActiveSync virtual directory.
4. An incorrect application pool is associated with the virtual directories that are used by ActiveSync.

See M937635 for information on solving this problem.

Christian Egger (Last update 5/15/2007):
The meaning of this error depends on the HTTP Status Code it contains. 507 could mean that the users Mailbox is over its quota, which can cause a problem for Active Sync to save information in a hidden mailbox folder.

Bill Olah (Last update 2/4/2007):
This issue can appear if the security settings on the Virtual Directories are altered. Verify that the following settings are enabled for the front-end and back-end servers.

Front-end Exchange Server:

Default Web Site:  Basic Authentication
ExAdmin: Integrated Authentication
Exchange:  Basic Authentication
ExchWeb:  Anonymous
Active Sync:  Basic Authentication
OMA:  Basic Authentication (note: Default domain must be \)
Public:  Basic Authentication.

Back-end Exchange Server:

Default Web Site:  Anonymous, Integrated Authentication
ExAdmin: Integrated Authentication
Exchange:  Integrated Authentication, Basic Authentication
ExchWeb:  Anonymous
Active Sync:  Basic Authentication
OMA:  Anonymous, Integrated Authentication
Public:  Anonymous, Integrated Authentication.

Francois Couture (Last update 11/22/2006):
This solved our problem:

1. Right click on the virtual directory and click properties
2. Uncheck "Enable anonymous access" in Authentification method
3. Synchronize your PPC.

David Fosbenner (Last update 11/22/2006):
I got this event every 15 minutes on my Exchange 2003 system. The source of the error was a user's smartphone which was configured to use ActiveSync to synchronize with the Exchange Server. The smartphone had the Exchange server name and user credentials, but was not synchronizing successfully.  We decided to prevent the smartphone from using ActiveSync to sync with the server, and that eliminated the 3005 errors. Instead, the smartphone syncs using IntelliSync which came bundled with it.

Anonymous (Last update 11/12/2006):
For the past week or so, I have upgraded my domain to Windows 2003 native. My DCs were all previous running Windows 2000. The exchange server was running 2003 exchange on a 2000 server operating system. I upgraded my system to 2003 all of them without a hitch. I then installed SP2 for Exchange 2003. Everything seemed to work aside from ActiveSync. The weird thing is it worked half the time and the other half it did not. I would get an Active Sync HTTP_500 error on my palm and an EventID 3005 from source ActiveSync "Verify Exchange is working properly" on the server end.
For the past week, I have dedicated most of my time trying to fix this problem. I have tried every KB article I could find and every registry hack you could think of. I finally broke down and spent 100 bucks to contact Microsoft about the issue I noticed several other people on groups experienced. I figured I would post this to anyone else that might have this same problem with ActiveSync.

1. Open up Systems Manager (Start -> All Programs -> Microsoft Exchange Systems Manager).
2. Look for the "Servers" folder and drill down.
3. If you have a Front-End/Back-End (FE/BE) scenario like me you will have to do this fix to both machines.
4. Drill down to the server you want and then to "Protocols HTTP Exchange Virtual Server".
5. Once you have drilled down there, right click on the "Microsoft-Server-ActiveSync" and click Delete.
6. Right click on the "Exchange Virtual Server", click New, and then Virtual Directory.
7. Under Microsoft-Server-ActiveSync -> "Exchange Path" click "Exchange ActiveSync".
8. Then OK out of it.

Give it a shot, this worked for me.

Alaskowski (Last update 11/9/2004):
This problem is usually attributed to an Exchange situation involving excessive items in the users calendar. Refer to M842541 for hotfix.

Ger J. Kleinsman (Last update 7/14/2003):
This is an Exchange 2003 Pocket PC Server Activesync error.  


they also  point to these 2 articles which you will find above:

http://support.microsoft.com/default.aspx?scid=kb;en-us;842541
http://support.microsoft.com/default.aspx?scid=kb;en-us;937635
0
 
gopher_49Author Commented:
i've done everything but what's mentioned in M937635.  I currently do not have a subscription to eventid.net. Users have always been able to sync, however, I'm still getting the error.
0
 
florin_sCommented:
have you modified something in the configuration lately on the exchange server or applied new patches?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
gopher_49Author Commented:
I didn't notice these errors until I first enabled mobile phones...    I think they've been there since I enabled mobile services...  I just installed all of the current patches on the backend server and that didn't help...  I'll get a subscription to event id in the morning and I'll review what's they have to say..  It seems that all of my permssions are correct though...
0
 
gopher_49Author Commented:
I did just get done doing a mirgration from Exchange 2000 Enterprise to Exchange 2003 Standard.  I had to install a additional server and move all mailboxes over, uninstall the old exchange and then installed the new exchange.  I then made one a front end and one a back end.  This error did not occur until I connect 3 x iphones and enabled mobile services....
0
 
gopher_49Author Commented:
I did notice that my \public folder virtual directory what setup incorrectly.  I manually re-created it based on the font end's config, however, one thing I noticed is that when you cilck on the \public folder in IIS it shows the Exchange servers public folders.  This is IIS 5.0.  I noticed on another backend server I have running IIS 6.0 when clicking on the public folder you do not see the exchange public folders..  This doesn't seem to be correct...  
0
 
gopher_49Author Commented:
I ran updates and it went away.
0
 
gopher_49Author Commented:
I tried everything and the error didn't go away.  I eventually ran more updates and rebooted and the error is now gone.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.