Publishing companyweb to the internet

I have followed the instruction on this webpage:
http://support.microsoft.com/kb/838304

But still not able to connect to my companyweb from outside...I'm able to connect to it by typing http://companyweb from a computer inside the network but from outside i can't even connect to using the sharepoint.domainname.com

What do I need to check...I've looked every where on this website but I can't find solution yet.  I have an ISA 2004 that comes with SBS.  Please help me publish companyweb to sharepoint.oparc.org

Thanks for the help
LVL 1
edmund7sAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnGerhardtCommented:
What happens if you ping the domain name inside the network...
edmund7sAuthor Commented:
Ping request could not find host sharepoint.domainname.com.  Please check the name and try again
JohnGerhardtCommented:
Is your external domain the same as your local domain...?
The 7 Worst Nightmares of a Sysadmin

Fear not! To defend your business’ IT systems we’re going to shine a light on the seven most sinister terrors that haunt sysadmins. That way you can be sure there’s nothing in your stack waiting to go bump in the night.

edmund7sAuthor Commented:
how do I check?

If this is right
My internal Domain: servername.domain.local
My external domain: xxx.domain.com
JohnGerhardtCommented:
I presume that your external domain is working fine from someone outside the organisation...

You will often hit problems with DNS that is not configured properly if you have (eg)...
you internal DNS domain name  called
experts-exchange.com
and your external domain
http://www.experts-exchange.com or ftp.experts-exchange.com etc...
This is because you DNS will resolve this locally rather than to the internet...
edmund7sAuthor Commented:
the external is different from internal

my internal domain is abcd-sbs2003
JohnGerhardtCommented:
Ok, then we need to work out why when you ping sharepoint.domain.com you dont get a response.. Can you confirm that from outside your network it works...
edmund7sAuthor Commented:
do you think i might need to fix the redirector in the IIS or any settings on the website's properties
JohnGerhardtCommented:
Is the website hosted on your site?
Can you confirm that from outside your network it works...?

For the moment if you can't ping the site then you will never be able to connect to it regardless of IIS settings...
edmund7sAuthor Commented:
i can't ping sharepoint.domain.com from outside of the network although I'm able to ping the server just fine xxx.domain.com

By the way I'm trying to setup companyweb to be accessed from the web.
I'm able to ping companyweb just fine...and able to goto http://companyweb from internal network but not from outside
JohnGerhardtCommented:
If you want to get sharepoint.domain.com to work then you will have to create a DNS alias for it.. Are you the DNS administrator..?

http://support.microsoft.com/kb/315982
edmund7sAuthor Commented:
I have created a Alias(CNAME) for companyweb with the following:
Alias: companyweb
FQDN: companyweb.domain.local
FQDN for target host: servername.domain.local

I am able to ping companyweb.domain.local but I'm still not able to ping companyweb.doamin.com
edmund7sAuthor Commented:
when I use the web browser and point to companyweb.domain.local
this brings me to the main page of the server instead of the companyweb.

What should I do? Do you think this as something to do with ISA 2004?
JohnGerhardtCommented:
ISA could very well do this..
In order to ping companyweb.domain.com then you are going to have to speak to DNS server on then web that is authoritvate for that domain, your DNS server isnt..

are companyweb.domain.local and companyweb.domain.com meant to be the sam place
Rob WilliamsCommented:
Is there a router on the public side of the SBS? If so you will need to forward port 444 from the router to the WAN interface of the SBS.
As a test, can you access the site using: httpS://xxx.domain.com :444
edmund7sAuthor Commented:
JohnGerhardt,
What do  you mean by "companyweb.domain.local and companyweb.domain.com meant to be the sam place"?

RobWill,
I am not able to goto https://xxx.domain.com:444 but i have forward port 444 from the router
Rob WilliamsCommented:
Perhaps verify nothing is blocking the port 444 traffic using the following test site http://www.canyouseeme.org
edmund7sAuthor Commented:
Error: I could not see your service on x.x.x.x on port (444)
Reason: Connection refused
Rob WilliamsCommented:
Sounds like you may have the source of the problem.
-A software firewall or ISA can block the traffic. Running the CEICW [server management | Internet and E-mail | connect to the Internet] should automatically configure ISA for you. Are there any security suites such as Symantec? They can block access.
-Are you sure the router port forwarding is correct, or might you also have a modem that acts as both a modem and router? If the latter it needs to have port forwarding configured to point to the router or be put in bridge mode
-There was also a recent DNS patch that is known to block some ports, especially on SBS with ISA. The fix is to manually add the ports to the registry. The following outlines the process:
http://blogs.technet.com/sbs/archive/2008/07/17/some-services-may-fail-to-start-or-may-not-work-properly-after-installing-ms08-037-951746-and-951748.aspx
edmund7sAuthor Commented:
I've added on the company web properties SSL port:444
and I'm able to see port 444 now...

And if I'm put in https://xxx.domain.com:444 it brings me to http://companyweb/default.aspx
But this works only from the internal network, from outside if I go to https://xxx.domain.com:444 it will ask for password but afterwards it says internet explorer cannot display the webpage
Rob WilliamsCommented:
Sounds like the port is open if you get the dialog box. Have you re-run the CEICW as of yet? You shouldn't manually edit IIS when running SBS. The CEICW will configure ISA, publish the site, allow access, configure DNS, and set permissions.
edmund7sAuthor Commented:
I'm afraid to run CEICW because I'm afraid to mess up the exchange and other pocketpc outlook access (push mail) and other configuration that has been done on the server...I have people using RPC over https and exchange webmail and PPC, I don't want to mess that up.  Do you think there is a risk for that if I do this?  Would you suggest for other alternative?
Rob WilliamsCommented:
Re-running the CEICW is "almost" never a problem. Just leave the configuration as is and only change any new services you want to enable. If the service is already configured re-running will reset permissions and such and often fix a broken service. The only time I have ever run into a problem is on a server where it was manually configured and the CEICW was never run. Basically the server wasn't working properly in the first place. I do however appreciate your concerns. Especially if it is a server others have worked on and you are not sure of what has been done to date.
edmund7sAuthor Commented:
Thanks guys for your help...I've figured it out after googling it.  The problem is that Microsoft doesn't support binding portals to a specific address in IIS so I've set each of their ports to port 80 and leave the IP setting for each of them to (All unassigned).  This resolve the issue...now I'm able to get to https://xxx.domain.com:444/default.aspx but not https://xxx.domain.com:444
I have to specify "default.aspx".

Also how can I configure sharepoint.domain.com to point to https://xxx.domain.com:444/default.aspx.  I tried configuring this on the Alternate Access Mapping with the following info:
Internal URL                                Zone      Public URL for Zone
http://companyweb                    Default  http://companyweb
http://sharepoint.domain.com     Internet  http://sharepoint.domain.com

Probably I should add this to a new thread...Thanks guys

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Rob WilliamsCommented:
I am not much help as I don't often work with IIS. With SBS it is all configured automatically with the CEICW. However, under the document tab of the site properties, is "enable default content page checked, and default.aspx added? (should also have Default .htm, Default.asp, index.htm, and iisstart.htm)
Rob WilliamsCommented:
Thanks edmund7s.
Cheers !
--Rob
edmund7sAuthor Commented:
Thanks Rob...You have helped in many ways and opened my mind to look for those answers.  Thanks again.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Forefront ISA Server

From novice to tech pro — start learning today.