Email being queued up and in RETRY state.

I am using "Use DNS to Route email" on our SBS exchange and random SMTP connectors, for the domain the emails are being sent to, were created in the queue of Exchange and ALL the emails are in "retry" state.  

I then tried to switch the outgoing server to our ISP's SMTP server.  Then they would bounce back immediately.  So i called my ISP and they said they dont require you to use their SMTP server and they dont block any ports??  I never had this issue before and im at a stand still.

any ideas??

Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

From your exchange server do a nslookup for an mx record of a mail server you want to send too

Then from the exchange server to a telnet <insert mx record> 25

Can you telnet to the server you want to send mail too???

Jerry SolomonNetwork  AdministratorCommented:
If you are able to telnet the other servers, then I would just rerun th e"connect to the Internet" wizard, and use DNS to deliver the emails.  Also make sure the dns servers you specify in the wizard are the ones provided to you by your ISP.
XChangingITAuthor Commented:

Well i did an nslookup from the exchange server to that domain, it "times out" i get the following..

C:\Documents and Settings\Administrator>nslookup

DNS request timed out.
    timeout was 2 seconds.
*** Request to timed-out

when i do an nslookup on my own network it responds with an IP....interesting but what and why would that be "blocked" from the exchange server?  I do have ISA installed on there but i have ISA installed on my own network too and the nslookup returns as it should...

Learn SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

XChangingITAuthor Commented:

when i use the smtp server from the ISP the email is returned immediately.  
Jerry SolomonNetwork  AdministratorCommented:
You may want to check your DNS forwarders under the properties of the DNS server.  the forwarders should be the DNS servers provided by your ISP.

Also, did you run the "connect to the internet" wizard? it usually fixes these kind of things very well.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Jerry SolomonNetwork  AdministratorCommented:
You do not wat to use your ISP's SMTP server; that will not work.

there is a mailhop service out there, but if you don't need it, son't use it. Rather fix the problem.
XChangingITAuthor Commented:
Yes i have run the "Connect to internet wizard" several times...i will look at the forwarders now tho and let u know.

XChangingITAuthor Commented:
wow i think that was it.  The DNS forwarders seemed to have done it but im just restarting the server to double check.  I remember doing that on the very first server i setup but never did it again for some reason and i never had this issue before....any idea why this would have to be done sometimes and not others??

thanks a million!
Jerry SolomonNetwork  AdministratorCommented:
You're welcome.

As to why sometimes, and not others:
Microsoft has to keep us computer experts in business somehow....
seriously, if you changes ISPs or your ISP changed the DNS servers they use, then those settings, which were created by the initial installation wizard would no longer work. Other than that, see my first explanation :)
XChangingITAuthor Commented:
one thing i noticed...

after running "Internet connection Wizard" it wipes out those DNS forwarders i entered.

this is driving me up a wall...any ideas would be great!
Jerry SolomonNetwork  AdministratorCommented:
1: hopefully, you won't have to keep running the wizard--I hope you meant, "connect to the internet" not "internet connection wizard"--2 VERY different tools

2: The connect to the internet wizard should, somewhere in the wizard, have a place for you to enter the DNS IP addresses.
XChangingITAuthor Commented:
This problem is still occurring.  Any other ideas??

this is making me nuts.  Why would there be a SMTP entry added to the Queue for these "stuck" domains??
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Email Protocols

From novice to tech pro — start learning today.