crw32.exe error

each time I try to insert anything into my report, I get the following error message, crw32.exe has encountered a problem and needs to close.  We are sorry for the inconvenience.
Here is all the info I could gather,
AppName: crw32.exe       AppVer: 11.0.0.1282       ModName: crw32.exe
ModVer: 11.0.0.1282       Offset: 00493073
00893073  push        dword ptr [eax+20h]
This happens each time I try to insert anything into my reports via Crystal Report.
I think it has something to do with my dual monitor setup, I have my laptop hooked into a docking station with a dual monitor setup, whenever I move the Crystal Report to my laptop monitor while in the docking station I am able to insert info into the report while the report is on my non-laptop monitor I get the error message, while this is a work around (only having it on the laptop monitor) is there a permanent solution?
wyogirl77Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MIKESoftware Solutions ConsultantCommented:
Something is NOT right with install. I'd first say to uninstall and reinstall the program.

If that does not work,..make sure your workstation has the correct minimum requirements for the CR program to run efficiently. I've encountered problem when a workstation was not running proberly or lacked the RAM or SPEED to handle the CR Program.

How old is your workstation by chance...????
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mlmccCommented:
I don't think it is the dual monitor.  I won't swear to that since I haven't used Crystal in that setup.

I agree.  It sounds like somewhere you have a bad installation.

mlmcc
0
MIKESoftware Solutions ConsultantCommented:
Additionally, I think that if it had anyting to do with the Dual Monitor..it would again ultimately go back to the resources available on the actual workstation.
0
Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

wyogirl77Author Commented:
I have uninstalled and re-installed a number of time with no change, any other ideas?
0
MIKESoftware Solutions ConsultantCommented:
What is the RAM and Processor Speed of your Workstation...?

I think it is related to RESOURCES required by the Crystal Reports program....

Also,...just for grins...try running DISK DEFRAG in Windows.....
0
MIKESoftware Solutions ConsultantCommented:
Also,...what are you using for the install...are they CD's or is it a downloaded file...?

Has the program  EVER worked correctly...???
0
ColB7533Commented:
I was so happy to see someone else is having this problem. I have a laptop for my work computer and frequently use a regular monitor while using Crystal Reports. The reason I do not think it is a bad instal is...
1. It works perfectly as long as the Crystal Window remains on the laptop monitor.
2. It has worked before on the external monitor.
I did do a uninstal/reinstalll just in case and no change.
This seems to me as a 'bug' in the CR program. Since all other applications I use work perfectly fine. Only CR cannot deal with the dual monitor.

Dos anyone have any idea what the issue could be??
0
mlmccCommented:
It isn't then dual monitor as such.  It will happen if you leave Crystal open on the secondary monitor when you close it.  The next time you open Crystal it looks to put it on the second monitor and actually does.  It is just you don't have a second monitor.

Before closing Crystal move the window to the primary monitor.

mlmcc
0
ColB7533Commented:
Thanks mlmcc. I think you are referring to another issue I have had concerning usage of dual monitors.
When you select an option that uses a secondary window (such as select expert) the window is displayed on the secondary window. If you do not have the dual monitor in use, then you cannot access that window. This is another issue....
Perhaps I was not clear...
When CR is open on the external monitor and a field is pulled into the report, then up pops the crw32 error. If I pull the window over to the laptop monitor, I can add a field with no errors.
It seems as if CR does not function if an external monitor is used when adding a field.
0
mlmccCommented:
I haven't used a dual monitor system with Crystal for some time and then only used 1 monitor for it so I don't know what the issue with that might be.

mlmcc
0
corobvCommented:
I had the same problem with Dual Monitors and I thought I should let everyone know what I found out.

I have PC with Dual Monitors (not a laptop) and have had the exact same problem with it on the expanded monitor.  Every time I tried to drag a field onto the report I'd get the crw32.exe error.  Figured out that the problem was that the expanded monitor was set as the primary monitor.  

It's a little confusing but the way it works is like this.   There is the ability to set Monitor 1, say your laptop monitor, up as the main monitor,  but set Monitor 2 up as the primary.  I have a third party program called UltraMon that allows this.  

When your setup is like this, the Monitor 1 has the start menu on it and all of the splash screens that pop up when you open a program will appear on Monitor 2.  If this is happening to you, then your main monitor is not setup as your primary monitor, and you will get the crw32 error as described on the second monitor.      

If you change the main monitor to the primary monitor, then the error should go away.  At least it did for me.  Now I'm not sure about laptops with expanded monitors, but maybe this information will point you in the right direction.

I hope this helps someone.  

corobv
0
ltgilbertCommented:
This fix worked for me.  When I am in designer and need to insert an image (the only time I get the error). I disable my secondary monitor (if using ULTRAMON). And CRYSTAL works fine.   When done with the edit in Crystal Designer, I Enable secondary again.

Ultramon and/or Crystal should address this issue.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Crystal Reports

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.