Setting up OWA and BIS for 3 Blackberry users

I have an Exchange 2007 server setup for corporate email and I have configured OWA but I cannot access OWA unless I am on my local network.  I have a SonicWall firewall and when I try to open up OWA from a PC that is not on the network by typing the URL (http://mail.companyname.com/owa), I get my log in for the SonicWall.  I want to be able to get a step by step process to make sure I have configured OWA correctly, to make sure the correct firewall ports are open, and then configure BIS for approx. 3 Blackberry users to access their email (they do not need to access public folders or calendars).
carilouAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

KutyiCommented:
It sounds like you have enabled remote management on your Sonicwall, not a good idea.  Your sonicwall is answering all port 443 queries.  You need to turn off this remote management and then port forward 443 to your Exchange server.
0
ccosbyCommented:
What Kutyi said but it looks like your sonicwall is answering on port 80. I'd still turn off the remote management and forward both port 80 and 443 to your server. If that is the only web app running on it I'd then go under iis and redirect mail.yourcompany.com to https://mail.yourcompany.com/owa. That way in a browser they just connect to mail.youcompany and it takes them right to the secure login. Chances are you will need to buy an ssl cert so it doesn't come up in their browser with an error saying the cert is bad. Godaddy changes like 30 bucks a year for them and others charge about the same. They will have insturctions for installing them.
0
carilouAuthor Commented:
OK, I disabled remote management on the SonicWall and was able to get OWA working from an external PC.  Now I need to be able to get BIS configured and working for approx. 3 Blackberry users.  I'm not sure if another rule has to be configured in my firewall and what port(s) the communication needs to take place over (incoming and/or outgoing).  Additionally, I am looking to make sure that BIS is configured on the Exchange server.  Any step by step processes would be greatly appreciated.
0
Challenges in Government Cyber Security

Has cyber security been a challenge in your government organization? Are you looking to improve your government's network security? Learn more about how to improve your government organization's security by viewing our on-demand webinar!

carilouAuthor Commented:
OK, I disabled remote management on the SonicWall and was able to get OWA working from an external PC.  Now I need to be able to get BIS configured and working for approx. 3 Blackberry users.  I'm not sure if another rule has to be configured in my firewall and what port(s) the communication needs to take place over (incoming and/or outgoing).  Additionally, I am looking to make sure that BIS is configured on the Exchange server.  Any step by step processes would be greatly appreciated.
0
KutyiCommented:
Are your Blackberry's not connecting now through your owa address?

Have you installed an SSL certificate that uses the same name as the as the url you have set BIS up with?
0
carilouAuthor Commented:
Yes I have. I was able to successfully configure the email accounts on all 3 Blackberry devices, got a congratulations email to all 3 devices, sent out test mails successfully from all 3 devices, but only 1 out of 3 devices received the test email and is picking up the rest of his mail.  The Blackberry that is working uses AT&T and the 2 that are not uses Verizon.  I cannot find any autosync options on the devices themselves, not sure if that is even the problem.
0
KutyiCommented:
You could setup POP3 as the connection method.  Port forward port 110 to your exchange server on the firewall and then connect using POP instead of OWA.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
KutyiCommented:
In answer to a previous question there is no setup of BIS on your Exchange server.  If you were using BES then we would need to do some stuff, but not BIS.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.