how do i prevent data displaying on the next portal row in filemaker pro 9

I have a portal in a purchase order form showing data from lines when I use a calculation field the field shows 0 values on the next portal row even though there is no data on the next row if i make the field auto enter by calculation this does not happen,as soon as i make it a calculation field again I have 0 in the next empty row again
DaryllvanGAsked:
Who is Participating?
 
lesouefConnect With a Mentor Commented:
a calc field is dynamic, everytime a layout is refreshed, it is recalculated.
an auto-entered value is recalculated only is any of the calc. members is changed.
you can decrease the recalc rate of a calculation if you have the "do not evaluate if all ref fields are empty" checked in the calc. window, bottom left.
personnally, I disable the "allow creation of records in this table via the relationship" feature as I hate this extra line hanging at the end of a portal and I use a script to create new related records together with a std "+" button.
0
 
DaryllvanGAuthor Commented:
Thanks
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.