Router Password Recovery

I Just picked up a used Cisco 2610 router and used the password recovery procedure to recover the password.


http://www.cisco.com/en/US/products/hw/routers/ps259/products_password_recovery09186a0080094675.shtml

after typing in confreg 0x2142 and typing in reset.

The router started throwing some garbage on to the console.

I can't make out what it is and repeated reboots is not fixing it.

Please, help.

?èý(B!.£$H'Mk+?MEwM(=.e.YmHH
F.wHB!H£B)eKQJI=B35VB)O)R'.Mt/Cv¯2
.B+)o/?
p0sreedAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

p0sreedAuthor Commented:
This is the whole thing i get


ýoýýýfHý^Xý1ýýHýýýýJýýž1ýjHýý)ýýý      –ýýýJý'ý!oýýýýtýýOoýýý)ýýoýÞ.ýýýXý11FHý'ýýýCJbýýýýýýHý1)$!œ88 ý‡oýýýýýýýHý
ýýýýýCýýýCýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýýBA!!!Q!ýýýýý9ýýýtMýý›FvMýýWýýýýeBvý³é'+Y1ýýý;Eýý3ýBýýfýcUóeý¨mýfVýý1;ýšýý‰ýýýý!Yý)ýJHýý]ýýý.hýý5ý(Ï(ýVýý6ýýDýiýýVýýU)ýV7%=ývýUýý*ý
ýFýýýjMý31ýýýýýýýýý(ý))n!i)/)ýn]!ý]ýýVýýýýýxVý5(­VýýýVýýýýýVý=ýýýý%%B!ýýCýIý!ýýýýýBýýGý_ýýuýýMýýýýýýýIýe6ýGÈýýýýVýdý5Vý(ýýýt$ýBýýýýFýýB!!!!ýBývMvýý3ýýý«ýýBYýý~ý)m+%ýU)ýývýýuýýý3ýýýVýýýBýývýQFýEB!a!ýBývý-ývýýýEý3hýýVýýýBýýýFýýýNýOHHýfýýýuý3ýýýVýýýBývý3SBQ!!A!=Býjfýýýý3ýsýVýIýBýýýSý!!!Q!ýýývý6ývÍýý3týý«ýýBýýfvGýýB!ýýNý7Mvýýýý3ýýýVýýB;ýV.ýN'N~R5ýýýuýývý.Výýýýý)ýýuý;Èý]ý¨GýwBýQ)ýýý6Nm~ýýý.Výýýýý)ýýuý;ÈNýŠuýMýýý))Y!;dýýý(ÏýýVýýýý«ýýýNNýýýnýýý;VýýBý))ý!5ýNýN~RýýýVýëý'%UvýýýFýýNýŠ)ýýjûýmVý
0
NotLogicalCommented:
Please ensure that you have your console set for the appropriate defaults - on Cisco products: 9600,n,8,1.

Since the previous owner of the system could have set the serial port speed to something else (to their liking), once the config register has been set to ignore the on-board configuration, it is back to the hardware default.
0
p0sreedAuthor Commented:
i was able to access the console and see it at 9600 baud rate when i issued a break to it and i got to the rommon promt, after typing in confreg 0x2142 and then reset. it throws garbage.


Do you think the output is due to improper terminal settings?

0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

NotLogicalCommented:
That is certainly odd: can you ensure that your terminal program is not trying to auto-baud?

You can certainly repeat the procedure - power the unit down, wait 10 seconds, and then re-start. Try sending break again, to see if you can get into the ROM monitor. Re-set the confreg (as per your steps above).
0
p0sreedAuthor Commented:
I tried with baud rate 19200 and it works.

why did it work earlier at 9600 and after i reset the rommon promt and it didn't work and now it works at 19200?

Any idea?
0
NotLogicalCommented:
With the router set at 19200, are you at a completely virgin configuration?

I must admit that I am a little puzzled, because the baud rate can only be set if the startup-config actually executed. However, the confreg register does allow you to set the baud rate, too. But only to 1200, 2400, 4800 or 9600 baud.

Another option, is to get the router to prompt you for every start-up option. At the rommon prompt, simply type "confreg" and press enter. You will be asked for the value of each individual field in the register interactively!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
p0sreedAuthor Commented:
I am using a mac to connect to the console using a keyspan adapter through usb port.

I use this command to access to it screen /dev/tty.USA19Hfa21P1.1 19200.

I reset the confreg again at the rommon promt and when that happened i started getting garbage at 19200 baud rate too.

Now, i reverted back to 9600 and when i do a reset at rommon promt, it doesn't throw me garbage.It is actually working at 9600 baud rate
0
p0sreedAuthor Commented:
I am new to routers. In what ways can i configure this very basic router?

I couldn't find much on the cisco site for this one.

Please, find the router version below.




cookie#sh ver
Cisco Internetwork Operating System Software
IOS (tm) C2600 Software (C2600-IO3-M), Version 12.0(5)T1,  RELEASE SOFTWARE (fc1)
Copyright (c) 1986-1999 by cisco Systems, Inc.
Compiled Tue 17-Aug-99 14:24 by cmong
Image text-base: 0x80008088, data-base: 0x8078D428

ROM: System Bootstrap, Version 11.3(2)XA4, RELEASE SOFTWARE (fc1)

cookie uptime is 4 hours, 14 minutes
System returned to ROM by power-on
System image file is "flash:c2600-io3-mz.120-5.T"

cisco 2610 (MPC860) processor (revision 0x203) with 20480K/4096K bytes of memory.
Processor board ID JAD035000HE (1292221592)
M860 processor: part number 0, mask 49
Bridging software.
X.25 software, Version 3.0.0.
Basic Rate ISDN software, Version 1.1.
1 Ethernet/IEEE 802.3 interface(s)
1 Serial network interface(s)
1 ISDN Basic Rate interface(s)
32K bytes of non-volatile configuration memory.
8192K bytes of processor board System flash (Read/Write)

Configuration register is 0x2142 (will be 0x2102 at next reload)

0
devangshroffCommented:
what u have pasted seems is correct , now u mest be getting router prompt , just cange password , than save it , and than cnage config regitery to 0x2102 and relod if
0
lrmooreCommented:
> In what ways can i configure this very basic router?
In about 10,000 differnet ways for 10,000 different purposes. Can you be a little bit more specific on what you want it to do?
0
p0sreedAuthor Commented:
I have 32MB of RAM and 8MB of flash, cisco site said i can only run IP and Remote Access Server code on this router with so much memory.

That aside, first of all i want to configure the Ethernet interface Ethernet0/0 to access the router than  through the console which i am doing now.

I tried running setup and assigned an IP address to it, but i am unable to access the router through that IP.

I want to achieve this first, then, before i reset the router there was a password promt at the console, now i don't see it, i want  to set that up as well  as now when i  connect to the console, i am directly in the router promt.

Your help much appreciated.
0
lrmooreCommented:
router>enable
router#config term
router(config)#interface ethernet0/0
router(config-if)#ip address 192.168.199.1 255.255.255.0   <== Use whatever address you want here
router(config-if)#no shut        <== don't forget to enable this interface
router(config-if)#exit
router(config)#username admin password PassWoRD privilege 15
router(config)#line vty 0 4
router(config-tty)#login local
router(config)#line con 0
router(config-line)#login local
router(config-line)#end
router#write mem
[OK]
router#

If you want to connect a PC directly to the Ethernet interface, you have to use a crossover cable. Else just connect both the router and the PC to a switch/hub.
0
p0sreedAuthor Commented:
I am able to connect to the router through the Ethernet interface and i followed all your commands by the word.

Now, i am trying to provide username as admin and the password as the one i provided, i get %Login Invaled
0
p0sreedAuthor Commented:
Ok, the below command worked.

username admin privilege 15  password 0 PassWoRD


Now, how can i setup this router for Remote Server Access.

I have some servers at home and a comcast cable connection.

I want to access my servers while i am at work.

Thanks again for your valuable hep lrmoore
0
p0sreedAuthor Commented:
Thank you, folks!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.