100% CPU (random), hard drive grinding,

Posted on 2008-11-08
Last Modified: 2012-05-05
Ok.  I'm very computer literate, but this one has me stumped.  Read this one all the way through as the first suggestions you might suggest have likely already been tried.  OS is Windows XP Home Edition SP2 with all the latest updates, Hardware is AMD Athlon XP 1800+, 1.5GHz, 2.00GB RAM.  

System randomly begins grinding on the 500GB hard drive, partition #2 (the G: Drive).  During this time, the hard drive activity light blinks rapidly at first, then steady on as system begins to grind to a halt - even the mouse becomes very sluggish.  CPU at this point is pegged at 100%.  Symptoms are brought on by anything - opening My Computer, starting Media Player, burning a disk, playing a game, etc.  System can be stable for 20 minutes, then grind to a halt for 10 minutes, then mysteriously CPU goes back to 2% (or less) and hard drive grinding activity comes to halt.  Upon rebooting, system can be unresponsive at the XP login screen for up to 2 minutes before I can click the user name and login.  After logging in (ten minutes later), everything is quiet and the PC is usable for some time before the grinding begins againn and the CPU pegs at 100% (no time pattern that I can see).

What I've Tried:
During the hard drive grinding, Windows Task Manager shows 100% CPU, but the the CPU offending process is not listed (show processes from all users is checked).  The sum total of all the processes CPU usage including Task Manager equal 3-5% yet the status bar shows 99%-100% CPU usage.  I/O activity shows normal with a few bytes read/written every now and then. Downloaded AnVir Task Manager....again, no offending task is shown.  Halted every non-critical task/process, still 100% CPU.  Turned of Search Index service and halted every non-critical service.  Loaded latest BIOS and reset settings to default.  Adjusted "Paging File" to many different drives/sizes/settings/system managed, etc.  Reinstalled drivers for IDE drives and tried 3 different graphics driver sets (current, 1 generation old, 2 generation old).  Removed ALL cards except AGP graphics card, unplugged CD-ROM & DVD ROM & Floppy, unplugged all USB devices, uninstalled all USB driver hubs.  Ran ChkDsk /f & defragged.  I've scanned system with 4 different virus scanners & 5 different MalWare detectors.  All clean.
I've disabled EVERY startup program using MSConfig.  Prayed, kick the desktop, tried the 3 foot drop test (kidding) and everything else I could think of.  No matter what I try, every now and then 100% CPU and total hard drive grinding for 10-15 minutes before I can use the system again. In safe mode, I do not see the 100% CPU.

Anything else I can try?  I don't really want to reformat because it would be 4 days of work to get the computer back to the configuration I have it in.  
Question by:BrianDeveloper
    LVL 26

    Accepted Solution

    You HAVE tried just about everything.

    How big is your hosts file?

    if you go to Control Panel/System/Hardware/Device Manager/IDE ATA/ATAPI controllers, and look at each of your IDE channels, (under Properties, and then Advanced Settings), do any of them say PIO, rather than some form of DMA?

    LVL 10

    Expert Comment

    you might have a bad hd, who makes the hd
    LVL 12

    Expert Comment

    Get a copy of the Microsoft rootkit revealer. Rootkits hide their presence from most tools and many AV packages.

    If the drive is a SMART drive, get a copy of one of the drive testing utilities. The drives are designed to help predict failure, and the tools will show you the stats and perform some drive tests.
    LVL 5

    Expert Comment

    I would put my money on a failing HDD
    i would try a new hdd with a fresh install of an os on it and see how that performs with a video game and enough software to run it, say video drivers, audio drivers etc.

    Author Comment

    Akahan:  Sorry for the delay, but I wanted to run this computer for a day to make sure the solution stayed working.  I believed you nailed it - you are a genius!  Something had set this drive to PIO mode, and Device Manager would not allow me to set it back to DMA mode.  Your comment allowed me to investigate further, and here is the link I ran across that ulimately fixed it since Device Manager could not change the drive back to DMA:
    In case the link goes dead, here is the solution:  
    Go to..
    Notes:  These keys are called SCSI solely for historic reasons; SCSI Port 0 is actually IDE1 and SCSI Port 1 is IDE2.

    DMAEnabled = 1 (DWORD value)
    Notes:  This is usually set to zero after a PIO failback.  Some systems may change your 1 to a 3 after a reboot - it seems to depend on how heavy your computer is already with DMA-enabled hardware.  One of my machines drives default to DMA3 and doesnt seem to act any differently, but I cant find a reference to this behaviour anywhere online.. shrug..  The machine in question is bristling with lots of tacked on hardware: 2 HDDs, CD, DVD, 3D video with TV-Out, wireless keyb/mouse, onboard sound, network, 4 USB devices.

    Go to..
    Notes:  0001 is the key for IDE2 and 0002 is the key for IDE1, go figure.  The string associated to MatchingDeviceId will tell you for sure what youre looking at (ie: primary_ide_channel or secondary_ide_channel.  If you dont know what those basic nuts & bolts terms are, I really really really think you should stop what youre doing RIGHT NOW.)  Also, you dont need to remember that entire long-winded numbered key, 4D36-etc& I just scan the fourth octet of the first dozen Class keys for 6A  (as underlined in the blue text above).

    Notes:  If you dont see a checksums associated with a particular slot, then theres no device detected.  If you cant work out which slot goes with which drive, well, that gives me misgivings about you messing about in RegEdit, but it doesnt matter if you simply delete all the checksums in the 0001 and 0002 keys (there can be a max of two devices for IDE1, two for IDE2).  At the next login, WinXP will notice something is up when the detected devices dont match the checksum flags and the devices capabilities will be re-examined.

    Notes:  Delete these keys if present, if you have a device that is not detecting or doesnt already have a checksum associated with it.  If theres a timeout=1 flag, Windoze doesnt bother detecting for a device in that slot at login.  Again, this is just a detection flag, so it doesnt matter if you delete them willy-nilly; if there truly is no device there, the timeout key will simply be recreated at next login.  If you still have access to a hard drive that has a timeout flag like this, chances are its running in the crippled Dos Compatibility Mode where XP is basically fudging your connection to it in real time.  I think you are told this under Device Manager > Disk Drives > (appropriate device) > General Properties tab, and also with a warning message at login.  If it is a newly installed device, you may have also forgotten to assign a partition and/or drive letter to it using the Microsoft Management Console: Start > right-click My Computer > Manage > Storage folder > Disk Management console.  Not recommended for n00bs! Very dangerous!

    ResetErrorCountersOnSuccess = 1 (DWORD value)
    Notes:  If this flag is present, the running tally of device access failures is reset to zero after every successful access.  (I mentioned earlier that a transfer mode downgrade is triggered after a sixth cummulative failure.)  Hopefully, this will lengthen the time before your next PIO failback as youll need six consecutive failures to trigger it.

    Notes: After youve rebooted, go back into the IDE settings and see if DMA is available now.  

    Featured Post

    Threat Intelligence Starter Resources

    Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

    Join & Write a Comment

    The term "Bad USB" is a buzz word that is usually used when talking about attacks on computer systems that involve USB devices. In this article, I will show what possibilities modern windows systems (win8.x and win10) offer to fight these attacks wi…
    Our Group Policy work started with Small Business Server in 2000. Microsoft gave us an excellent OU and GPO model in subsequent SBS editions that utilized WMI filters, OU linking, and VBS scripts. These are some of experiences plus our spending a lo…
    In this sixth video of the Xpdf series, we discuss and demonstrate the PDFtoPNG utility, which converts a multi-page PDF file to separate color, grayscale, or monochrome PNG files, creating one PNG file for each page in the PDF. It does this via a c…
    Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…

    728 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    22 Experts available now in Live!

    Get 1:1 Help Now