WM 6.1: Can't sync against Exchange 2003 after upgrade - WM 6.0 still can

We run 10-15 HTC s730 mobile phones. They are synced against Exchange 2003 (SP2).

We have an ISA 2004 in front of the Exchange.

Both exchange and ISA has SSL

We test upgraded one of the HTC s730 to WM 6.1, but this phone will not sync.

We normally just copy the server certificates to th emobile phones and install them, and then setup Activesync to sync against our webmail.domain.com (selecting ssl)
 
But un the one WM6.1 the phone active sync says:

activesync encountered a problem on the server
Supportcode: 0x85010001



On the Server (ISA 2004 in front of Exhcange 2003 sp2), it says:

Failed Connection Attempt ISA 09-11-2008 10:58:46
Log type: Web Proxy (Reverse)
Status: 12210 An Internet Server API (ISAPI) filter has finished handling the request. Contact your system administrator.  
Rule:  
Source: ( 11.111.111.111:0)
Destination: ( xxx..yyy.zzz:443)
Request: OPTIONS http://webmail.domain.com/Microsoft-Server-ActiveSync?User=XX&DeviceId=54CC790D48AF26FB698BD146B4D51C6D&DeviceType=SmartPhone 
Filter information: Req ID: 0d0c47f8  
Protocol: https
User: anonymous
 Additional information
Client agent: MSFT-SPhone/5.2.1000
Object source: Processing time: 453
Cache info: 0x0 MIME type:



But all phones that are still on WM6.0 sync without problems.

I have noticed that when a sync request from one of the WM 6.0's hit the ISA the log says:

Allowed Connection ISA 09-11-2008 11:54:13
Log type: Web Proxy (Reverse)
Status: 200 OK
Rule: OWA
Source: External ( 11.111.111.111:0)
Destination: (webmail.domain.com qqq.www.rrr.ttt:443)
Request: POST https://webmail.domain:443/Microsoft-Server-ActiveSync?User=YY&DeviceId=2CCC2EEF15923EAD218426BAFBC12C4B&DeviceType=SmartPhone&Cmd=FolderSync 
Filter information: Req ID: 0d0c4e92  
Protocol: https
User: anonymous
 Additional information
Client agent: MSFT-SPhone/5.2.404
Object source: Internet Processing time: 734
Cache info: 0x40040008 MIME type:  


Notice that in the first case (the sync with WM6.1) the request says "http://webmail.domain...."etc.etc eventhough it two linies beneath says: "protocol: https"


But on the successful syncs via the phones that runs WM6.0 it says https://webmail.domain...."etc.etc. here the request includes the important "s" in https...

Have anybody experienced something similar?
infareAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

buddholeCommented:

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JohnGerhardtCommented:
Is the HTC set up to use a proxy?
infareAuthor Commented:
No, unless it is set default on WM 6.1 and I have to uncheck it somewhere.
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

buddholeCommented:
It's not on by default.
infareAuthor Commented:
Buddhole,

I have read this blog and the error Code: 8503001C is all around the Internet and is related to WM6.1, but since my error has code 0x85010001 I didn-t pay much notice to it

But will try (tomorrow) to sync behind the ISA when I am in the office and do this via the USB cable and a connection set up via windows mobile device center
infareAuthor Commented:
Buddhole/JohnGerhardt,

Proxy: Just checked; no proxies set
buddholeCommented:
You're right about the different error codes. In my experience some solutions for activesync can resolve different issues. As you said, the error I mentioned is all over the web, but smae goes for 0x85010001 and HTC WM 6.1 with Activesync problems . To get some more info:
- Did the install of the root cert at the HTC went ok ?
- Is it possible to test without ISA 2004 to see if ISA of Exchange/Activesync is the problem ? (Or setup a non web server publishing rule and create an inbound HTTP protocol)
- Do you have any mobile device policies deployed in Exchange ? (based on http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_23784095.html )
 
infareAuthor Commented:
Buddhole:
- Install of root certificate went fine
- Testing without ISA 204 is more trick, but a  non web server publishing rule should be possible. I will try this on monday.
- There is one security policy enabled: the on that forces client to accept password on the phone. This policy is the first one to download (on WM6.0) when connecting to the server for the first time,
infareAuthor Commented:
Buddhole,
I'll be damned; your suggestion to look at this:
http://rickyspears.com/blog/2008/07/activesync-problems-with-windows-mobile-61-upgrade-on-samsung-sch-i760-support-code-8503001c/ 

did the job!!

Eventhough the support code was different it turned out that the problem was the same: there is some kind of difference between WM6.0 og WM6.1 and how they accept mobile device policies.
The security policy we have (that enforces company policy by locking the phone with a password and wiping it after 8 wrongfully attempts to unlock) is popping up as the first thing when trying to sync on a WM6.0 for the first time, but on WM6.1 it just stops syncing before the question to accept the policy comes up. and provides the errror code 0x85010001.

What I did was (as suggested in the link) was to sync via USB cable trough Windows Mobile Center (i run vista) from my desktop pc from within the company (that is; behind the firewall/ISA), selecting all items to be synced; email, contacts, calendar etc.  The first thing that popped up was the possibility to accept the security policy...
After accepting that it synced fine via USB. Then I disconnected the USB cable, went into ActiveSync >menu > options  and then changed all items (contacts, calendar, email & tasks) from being synec by PC to being synced by Microsoft Exchange.

That did it!! it now syncs fine both manually and via push.

 I suppose the difference in the two error codes relates to the difference in us using ISA in front of exchange 2003.




 
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.