• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 747
  • Last Modified:

Error:virtual directory not being configured as an application in IIS

The application runs from visual studio.
However it doesnot run when I try to use the browser address Http://LocalHost/Appname.aspx.

The error is:
virtual directory not being configured as an application in IIS

The directory that the app resides in is shown in INETMGR as a folder but not as a virtual directory.

How can I set the folder as a virtual directory?

Thanks,
0
Dovberman
Asked:
Dovberman
  • 2
1 Solution
 
stesomCommented:
You open properties on the directory in IIS, find the tab named 'Virtual directory" and look at the bottom half named: "Applications settings". Click "Create" to make the directory an application, that should do the trick.
0
 
DovbermanAuthor Commented:
There is no Properties option in the Right click menu. I am using Windows Vista and Dot net 3.5.

However thee was a "Convert to Application" option. That worked. Thanks for the hint.
0
 
stesomCommented:
Right, I just assumed it was a w2k3 server or something, glad it worked out though!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now