How to set Router's System Time using NTP

I am trying to set my RV082 to "Set The Local Time Using NTP Automatically". So, I go to it's admin page, then select Setup | Time, and then I:
 - Select Radio Button "Set The Local Time Using NTP Automatically"
 - Select the appropriate time zone
 - Enter an NTP server: time.nist.gov
 - Click on "Save Settings" and wait for browser to indicate setting are saved.
 - Power Router down and back up and wait a while.

When I got to "View System Log", the date/time is still in July, 2006.

Questions:
 - When does the router do its Sync with the Time Server?
 - Is there a way to tel the router to "Go Sync with the Time Server NOW"?
 - What is the syntax for the "NTP Server" textbox? I just put "time.nist.gov". Do I need to add the protocol prefix? If so, what is it? "NTP://"?





lee88Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jerry SolomonNetwork  AdministratorCommented:
first, set the time on the router within a few minutes of the accurate time, or it may not take.

then you can set the time server to "0.pool.ntp.org" (pretty cool rotating service)

You can then test it by checking the time after you save your settings, and see if it corrected it by the few minutes.
0
MysidiaCommented:
I would wait a few hours and check your router's log before concluding that it will not work.


There is no URI prefix for ntp.
Just specify a server name like you have.


However, since you have specified a hostname: it's only going to work if DNS works on your router.

Make sure you have configured the router to either have a proper list of DNS servers as provided by your ISP

Or that DNS servers are configured on your router automatically through DHCP.

In either case, check the router status page for active DNS servers
and attempt to verify they are working, i.e.

Start Menu>Run>cmd

nslookup   time.nist.gov    (DNS SERVER1 IP)
nslookup   time.nist.gov    (DNS SERVER2 IP)



If there is a firewall between your router and your ISP equipment, it is also necessary to allow NTP traffic  on UDP port 123 and TCP port 123   on your firewall.

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
akahanCommented:
It can take a few minutes for the router to get around to adjusting the time.  i've had better luck with time.windows.com than with time.nist.gov

0
lrmooreCommented:
Try using the IP address of a time server..
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.