• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 215
  • Last Modified:

SMTP Mail and Exchange Issue

We have two sites that we look after who are experiencing email problems.

Only a select number of senders who send mail to either domain get the following response after they have sent an email to the intended...

recipient@domain_name.co.nz
    SMTP error from remote mail server after RCPT
TO:<recipient@domain_name.co.nz>:
    host mx.clear.net.nz [IP_ADDRESS]: 501 #5.1.1 bad address
recipient@domain_name.co.nz

I've Googled this to there and back but nothing of much use.

I spoke to the ISP and they made changes to the A and MX Records and stated the problem would fix itself 3 to 24 hours when the changes had propagated whatever it needs to update. They said the issue was down to the MX record not pointing correctly to the A record.

The affected senders then experienced that not only was thier mail not making the destination but they were now not getting a reply to say so. All the while the majority of senders were having no issues at all.

I phoned the ISP again. They said they found another mistake and had rectified it. The affect was almost immedicate and now the organisations are receiving no mail at all!

Out of curiosity I downloaded a wonderful DNS look up tool called Dig. I entered the domain name for one of the affected companies and found it could not resolve the domain name to an IP address. Same happened for the other. I tried domains for other organisations, both customers and non-customers and in every case Dig was able to resolve the domain name to an IP address. So I added smtp to the domain name for the affected companies so it looked something like this smtp.domain_name.co.nz - surprise surprise! The domain names can be resolved now.

So what is broken? Is it Exchange at each of the sites or is it their ISP???

Anyone?
0
MSLCNS
Asked:
MSLCNS
1 Solution
 
PowerComputersCommented:
Check the REVERSE DNS lookup for the problem domain. Some ISPs require a successful Reverse DNS lookup when relaying smtp traffic. Go to http://www.dnsgoodies.com, they have great DNS tools.

As for your ISP the smtp.domain_name.com record is irrelevant if it is not the MX record target. From a command prompt, run NSLOOKUP enter
SET TYPE=MX  enter
type DOMAIN_NAME.COM  (use the domain name in question, don't use a prefix)
this will return the domain's MX records in order. make sure the lowest number, usually 10, matches the A record and IP address of your mail server.
0
 
MSLCNSAuthor Commented:
It seems propogation took a lot longer than 24 hours. With changes made to the MX record the issue did eventuall come right. Thanks for reponding.
0

Featured Post

Become an Android App Developer

Ready to kick start your career in 2018? Learn how to build an Android app in January’s Course of the Month and open the door to new opportunities.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now