Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 385
  • Last Modified:

Samba on Linux

Hi all,

I am running Samba on Linux. All the configuration seems to be ok. here is my smb.conf file and smbusers file. I have added a user by smbpasswd -a <username>. The problem is when i go to windows machine and try to mount the drive it prompts me for username and password so i enter the username and password which lives on Linux local system and also in smbusers but i am unable to map the drive to windows xp machine by providing those credentials.

smb.conf

workgroup = workgrp
netbios name = beorn
encrypt passwords = yes

[homes]
read only = no
browseable = no

[everyone]
path = /test
read only = no
browseable = yes

[apps]
path = /test
browseable = yes
valid users = smbusers, root
write list = smbusers, root

smbusers

# Unix_name = SMB_name1 SMB_name2 ...
root = administrator admin
nobody = guest pcguest smbguest
smbusers = inazir

Can anyone tell me what am i doing wrong?

Thank you very much in advance

0
inazir
Asked:
inazir
  • 4
  • 3
1 Solution
 
dhoffman_98Commented:
When you enter the username, are you preceding it with the workgroup name?

For example, instead of entering "inazir", you would enter "workgrp\inazir".
0
 
woolmilkporcCommented:
Hi,
additionally, you could try the following -
- In your local security policy, in the Microsoft network (client) area, enable this -
"Send unecrypted password to third-party SMB servers"
 
and try again!
 
wmp
 
0
 
inazirAuthor Commented:
I am typing wrkgp/inazir and the password but it comes back with same screen again.

About the local security policy on Microsoft client where exactly do i enable:

"Send unecrypted password to third-party SMB servers"

Thanks for quick reply
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
woolmilkporcCommented:
Hi,

Go to: Start - Settings - Control Panel - Administrative Tools - Local Security Policy
 Expand the Local Policies tree.
 Click Security Options.
 Find "Send unencrypted password to connect to third-party SMB servers" in the list in the right pane.
 Double-click on it.
 Click Enable.
 Click OK.
 Close everything and reboot.
 If you return to the Security Options folder after rebooting, the Local Setting and Effective Setting columns should say Enabled.
0
 
woolmilkporcCommented:
... an easier way to find the right place is to run 'secpol.msc' from a commandline or by Start->Run->secpol.msc
0
 
inazirAuthor Commented:
Hey,

I did change that option but still i am unable to do log in from windows machine to the linux share.

Is my config file and smbusers file looks okay???

Thanks
0
 
woolmilkporcCommented:
Hi,
your smb.conf looks OK. The only things are the entry I mention below, and - I once had problems with the 'netbios name'. Try to leave it out.
 
Now to smbusers -
To use it, you must set an entry for it  in smb.conf, in the [global] section -
username map = /[path/to/smbusers_file]
There must be an UNIX user with name 'smbusers' and a windows/samba user with name 'inazir', which has to be the one defined by 'smbpasswd -a ...'
 
Now a mount with \\servername\inazir should work.
 
wmp
 
0
 
inazirAuthor Commented:
that worked for me leaving the netbios name out.

Thanks alot
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now