USB Flash Drives are not mounting unless I reboot

I got a Dell D430 with Windows XP Pro SP2. Everytime I want to open a USB Flash Drive or memory stick or even my ipod, I will have to reboot the computer, otherwise it wont show up. I checked under Disk Management and when I try to mount it to a drive letter, I get the following error " The operation did not complete because the partition or volume is not enabled. To enable the partition or volume, restart the computer". No matter what I try to do I will get this error (including formating the drive)

I updated my Bios to the latest revision from Dell (A07). Still no good.
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

and they work normally on other PC's ?
you can also remove all your usb entries from device manager, reboot, and test
or try this :
Download devcon :
then run :   devcon enable @usb\*

OR :
Remove all USB drivers with:      ---> Now reboot and test.
Delete the "UpperFilters" and "LowerFilters" registry values from:
you can also reset the usb :
rundll32.exe setupapi,InstallHinfSection DefaultInstall 132 C:\WINDOWS\inf\usbstor.inf
TetraSAAuthor Commented:
I tried all the solutions you posted, but still its the same. It will only work on restart, and once I unplug the USB drive  and plug it back in. We are back to square one. It wont mount again and I will get the same error if I try to do anything.
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

TetraSAAuthor Commented:
and yes they do work fine from any PC. including mine, but only on reboot.
Do you see the devices in device manager?
Check that you have plug and play enabled in the bios.
TetraSAAuthor Commented:
Yes, It shows as Generic Volume under storage, but with an exlamation mark and it says "Windows successfully loaded the device driver for this hardware but cannot find the hardware device. (Code 41)

Click Troubleshoot to start the troubleshooter for this device."

Under Universal Serial Devices it shows as USB Mass sotrage device, no errors.
TetraSAAuthor Commented:
Plug and Play is enabled.
Ok the last time i saw something like this was with a cd drive.
I performed a REPAIR instalation of xp which solved the issue.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
and if recent, a system restore can help too
but you can try these if you like :
unplug pc from power for 30 minutes
then test
Remove all USB drivers with:      ---> Now reboot and test.
other things to try :
1- Delete the "UpperFilters" and "LowerFilters" registry values from:
2- check  also  :      +   the "SIMILAR PROBLEMS AND SOLUTIONS" section.
3- run this from the run box (you can copy the command) :
rundll32.exe setupapi,InstallHinfSection DefaultInstall 132 C:\WINDOWS\inf\usbstor.inf
or :start>run>services.msc
look for Removable Storage Service. Is it set to Auto, and if not started, click the Start link in the top left...
In c:\windowsc:\windows\inf.  look for usbstor.inf -  If not found, copy from another PC. If you find it, right click it and select Install
See if it rebuilds the USB support...  normally located at c:\windows\system32\drivers
4-Start the Registry Editor (Run -> Regedit). Check if under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion the item 'DevicePath' points to '%SystemRoot%\inf'. Additional items, separated by semicolons, are ok but '%SystemRoot%\inf' has to be one of them.
Then delete the file C:\WINDOWS\inf\infcache.1 - XP will recreate it.
The INF folder and the infcache.1 file are 'hidden'. To see them in the Windows Explorer:
Menu 'Tools' -> 'Folder Options' Tab 'View', mark 'show hidden files and folders'
5-The registry keys reside in the registry (click start, run, regedit) under the following keys:

 Under the headings USB, and USBSTOR. Right click "USB", click "permissions" click the "Allow Full Control" checkbox, and OK. Once you have completed this, right click the "USB" key, and click delete. Do the same for the "USBSTOR" key, delete both.
 Restart the PC, . After this has completed, plug your USB Jumpdrive back in, and it should recognize.

If it still doesn't work after a restart, the files in C:\WINDOWS\inf might be corrupt. A Windows repair install should correct this.

Select USBSTOR & on the right side change the value of 'Start' to '3'
TetraSAAuthor Commented:
Thanks, a windows repair did the job !! Thanks alot.
TetraSAAuthor Commented:
Thanks for your help Nobus. But i think i tried most of the steps you mentioned but didnt help either. Repair of windows was the only way to go .

But thanks alot for all your help guys.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.