OWA 2003 messed up after reinstalling W2K3 and Exchange 2003 Standard

I reinstalled a Windows 2003 Standard server that is a DC and runs Exchange 2003 Standard. I had prepared a backup DC, transferred FSMO roles there well in advance of the primary server reinstall. Reinstall went fairly smoothly, made sure that IIS was installed with ASP.NET before dcpromo'd the primary back to a DC. I then moved the FSMO roles back. All ok so far.

W2K3 is SP2 and patched with all latest patches.

Then I started to install Exchange 2003, and the troubles begun. I went through the usual check-list, did forest/domainprep (even though I wasn't sure whether I should since the domain technically already contained the Exchange structures from the previous installation). Install itself went through ok, but on the first pass none of the Exchange services had registered -- none of them showed up in Services. On the second try I tried /DisasterRecovery switch. That helped in a sense that now the services were present. I upgraded to SP2 (which was the same as the old installation). Even the datastores mounted without any problems. IMAP, POP, and Exchange connectivity seems to be ok, but OWA is messed up. The indications were somewhat similar as in another question here at EE (see http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_21844566.html), but in this case there are no different front-end and back-end systems that could be out of sync (it's a small office environment). I tried the hotfix that was mentioned in the post anyway, but it made no difference.

What could be wrong? Below are links to screen-shots of how the OWA looks when viewed with Firefox or with IE. If I click on a missing picture in FF, select properties, copy the link and attempt to view it directly the error given is "Error: Access is Denied." However, the virtual directory exists in IIS, and the image file in question is physically in the path.

Firefox 3.x:
http://i34.tinypic.com/zxmo37.gif

IE 7:
http://i38.tinypic.com/2e364nm.gif

One mistake I now realize I probably made was that I didn't uninstall Exchange in prior to reinstalling the server.. it possibly (?) left stuff behind in the AD. And now that I have reinstalled Exchange, it no longer allows me to uninstall it as the users in the AD are reconnected to it.

Please help!
LVL 1
vwalAsked:
Who is Participating?
 
vwalConnect With a Mentor Author Commented:

Most likely it had something to do with IUSR account though it did not appear to be locked out or disabled. I also double-checked that the IUSR password was properly set in IIS. To no avail.

Solution: I blew away OWA and replaced it with the excellent SquirrelMail running on a FreeBSD server, and connecting to Exchange via IMAP. Works perfectly and the webmail interface now looks the same no matter what browser is used to view it (OWA's interface looked very different if viewed in IE or in Firefox).

I've become very disillusioned (if there was ever any 'illusion' in the first place) with Exchange. What a cumbersome, bloated, resource-hungry and overly complicated mail server! I'm moving the current Exchange environment to Postfix/Dovecot within next two months and will enjoy the excellent stability and low resource demands as well as straightforward configuration and debugging of the new system. Obviously calendaring would need to be provided through some other means if it was needed, but in this environment Exchange's extra features were not used anyway.

This question can be closed.
0
 
LeeDerbyshireCommented:
Do you still have Anonymous Access enabled on the exchweb VDir in IIS Manager?  If not, then try enabling it.  If it is enabled, then it sounds like the IUSR account is locked out or disabled.
0
 
LeeDerbyshireCommented:
Yep, if you just want email, then Exchange is probably way over the top.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.