?
Solved

OWA 2003 messed up after reinstalling W2K3 and Exchange 2003 Standard

Posted on 2008-11-10
3
Medium Priority
?
551 Views
Last Modified: 2012-05-05
I reinstalled a Windows 2003 Standard server that is a DC and runs Exchange 2003 Standard. I had prepared a backup DC, transferred FSMO roles there well in advance of the primary server reinstall. Reinstall went fairly smoothly, made sure that IIS was installed with ASP.NET before dcpromo'd the primary back to a DC. I then moved the FSMO roles back. All ok so far.

W2K3 is SP2 and patched with all latest patches.

Then I started to install Exchange 2003, and the troubles begun. I went through the usual check-list, did forest/domainprep (even though I wasn't sure whether I should since the domain technically already contained the Exchange structures from the previous installation). Install itself went through ok, but on the first pass none of the Exchange services had registered -- none of them showed up in Services. On the second try I tried /DisasterRecovery switch. That helped in a sense that now the services were present. I upgraded to SP2 (which was the same as the old installation). Even the datastores mounted without any problems. IMAP, POP, and Exchange connectivity seems to be ok, but OWA is messed up. The indications were somewhat similar as in another question here at EE (see http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_21844566.html), but in this case there are no different front-end and back-end systems that could be out of sync (it's a small office environment). I tried the hotfix that was mentioned in the post anyway, but it made no difference.

What could be wrong? Below are links to screen-shots of how the OWA looks when viewed with Firefox or with IE. If I click on a missing picture in FF, select properties, copy the link and attempt to view it directly the error given is "Error: Access is Denied." However, the virtual directory exists in IIS, and the image file in question is physically in the path.

Firefox 3.x:
http://i34.tinypic.com/zxmo37.gif

IE 7:
http://i38.tinypic.com/2e364nm.gif

One mistake I now realize I probably made was that I didn't uninstall Exchange in prior to reinstalling the server.. it possibly (?) left stuff behind in the AD. And now that I have reinstalled Exchange, it no longer allows me to uninstall it as the users in the AD are reconnected to it.

Please help!
0
Comment
Question by:vwal
  • 2
3 Comments
 
LVL 31

Expert Comment

by:LeeDerbyshire
ID: 22940045
Do you still have Anonymous Access enabled on the exchweb VDir in IIS Manager?  If not, then try enabling it.  If it is enabled, then it sounds like the IUSR account is locked out or disabled.
0
 
LVL 1

Accepted Solution

by:
vwal earned 0 total points
ID: 22945313

Most likely it had something to do with IUSR account though it did not appear to be locked out or disabled. I also double-checked that the IUSR password was properly set in IIS. To no avail.

Solution: I blew away OWA and replaced it with the excellent SquirrelMail running on a FreeBSD server, and connecting to Exchange via IMAP. Works perfectly and the webmail interface now looks the same no matter what browser is used to view it (OWA's interface looked very different if viewed in IE or in Firefox).

I've become very disillusioned (if there was ever any 'illusion' in the first place) with Exchange. What a cumbersome, bloated, resource-hungry and overly complicated mail server! I'm moving the current Exchange environment to Postfix/Dovecot within next two months and will enjoy the excellent stability and low resource demands as well as straightforward configuration and debugging of the new system. Obviously calendaring would need to be provided through some other means if it was needed, but in this environment Exchange's extra features were not used anyway.

This question can be closed.
0
 
LVL 31

Expert Comment

by:LeeDerbyshire
ID: 22949674
Yep, if you just want email, then Exchange is probably way over the top.
0

Featured Post

Prep for the ITIL® Foundation Certification Exam

December’s Course of the Month is now available! Enroll to learn ITIL® Foundation best practices for delivering IT services effectively and efficiently.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Here in this article, you will get a step by step guidance on how to restore an Exchange database to a recovery database. Get a brief on Recovery Database and how it can be used to restore Exchange database in this section!
There can be many situations demanding the conversion of Outlook OST files to PST format and as such, there is no shortage of automated tools to perform this conversion. However, what makes Stellar OST to PST converter stand above the rest? Let us e…
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…
Suggested Courses

862 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question