RDP Stopped working on 2003 Server

RDP Stopped working on 2003 Server.  RDP all of a sudden stopped working.  No one can RDP to the server.
zito2000Asked:
Who is Participating?
 
zito2000Connect With a Mentor Author Commented:
Problem has been fixed.  Had to recreate a new RDP-tcp connection in the terminal Services Configuration.
0
 
nappy_dThere are a 1000 ways to skin the technology cat.Commented:
Do you have have local access to the server's console?

Have you checked the event viewer for errors?

Does the server have network connectivity?

Please provide as many details of the trouble shooting steps you have taken.
0
 
zito2000Author Commented:
Yes I do have acess to the server locally.

I have checked the event viewer and saw nothing there related to RDP errors.

Yes the server has a conenction to the Internet and users that use Citrix can connect successfully.

I have checked to make sure RDP is enable.

I also do not get a login screen when I rdp.

Here is the screen shot of the error.
RDP-Error.doc
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
nappy_dThere are a 1000 ways to skin the technology cat.Commented:
Is the RDP port of 3389 listening on the server?

From the server itself, can you connect to an RDP session?

Is the server in administration or application mode?
0
 
zito2000Author Commented:
How do you check if the 3389 port is listening?
Yes I can RDP to another machine from the server that is having the RDP issue.
How do I check the mode of the server?
0
 
zito2000Author Commented:
FYI:  We changed the mode of the server from Install to execute.
0
 
eetheredgeCommented:
The user profiles might need to be flushed.  We went through this several times.  There is a Profile Hive Cleanup (not sure of the exact title), but it will do this for you.  I will check for a download link.
0
 
zito2000Author Commented:
FYI:  The server is not listening to port 3389.
0
 
nappy_dThere are a 1000 ways to skin the technology cat.Commented:
ok but on the rdp server with issues, can u connect to 127.0.0.1? This will show whether the local machine can reach itself.

TO see f the port it listening, open your command line and type "netstat -an" look for 3389
0
 
nappy_dThere are a 1000 ways to skin the technology cat.Commented:
do you also mean that the server local administrator cannot connect as well?
0
 
zito2000Author Commented:
Try rdp to itself and it did not work.

Also ran the netstat -an and the port is not listening.
0
 
zito2000Author Commented:
Is the HIve cleaner related to this issue at all or was that a mistake submitted to this issue
0
 
Yossarian-22Commented:
I've had the same problem recently.
KB948496 fixed it for me.

http://support.microsoft.com/?kbid=948496
0
 
eetheredgeCommented:
The Hive Cleaner worked for us under the same situation.  No one could access the server via RDP either internally or via VPN.  I ran the Hive Cleaner and it solved the problem.
0
 
zito2000Author Commented:
Where can I get this Hive Cleaner.
0
 
eetheredgeCommented:
Do a search on Microsoft's website or even Google it.  
0
 
zito2000Author Commented:
ok got the hive cleaner and will you know what happens.

Thanks
0
 
zito2000Author Commented:
I installed the Hive Cleaner, but still no success.

Is there something I have to do to make the Hive Cleaner work properly.  I do know it is a service that it is running at the moment.
0
 
eetheredgeCommented:
Is the service running under an Administrator's login?
0
 
zito2000Author Commented:
yes.  It is running under the local system account.

I am currently logged on as adminstrator to the domain.
0
 
eetheredgeCommented:
Are your RDP users set up to access using their domain logins or set to login locally?
0
 
nappy_dThere are a 1000 ways to skin the technology cat.Commented:
I asked a similar question a few comments back.  Is the administrator alos prevented from logging on via a terminal session?
0
 
zito2000Author Commented:
users are using domain login accounts, but they can't even establish a connection to RDP.  Here is the attachment of the error just in case you didn't see it earlier.
RDP-Error.doc
0
 
zito2000Author Commented:
Administrator can not RDP either.  No one can.
0
 
zito2000Author Commented:
Since the server is not listening to port 3389.  How can I force it to listen to port 3389.
0
 
eetheredgeCommented:
Ok, let's take one step back for a minute.

Have restarted the services?  
0
 
nappy_dThere are a 1000 ways to skin the technology cat.Commented:
on your Terminal server with issues, at the console, open the command line and type netstat -an as show in the illustration and look for port 3389 as described.  Is it there?



Picture-31.png
0
 
zito2000Author Commented:
Which service would you like me to restart?

The server is not listening to port 3389 when I did the netstat command.

The terminal Service, Service can not be restarted.
0
 
eetheredgeCommented:
Have you tried to enable/disable the RDP protocol within the TS Config MMC?  This is how you restart it.  
0
 
nappy_dThere are a 1000 ways to skin the technology cat.Commented:
I would then suggest you remove Terminal services from the server, reboot and reinstall it.

This can be done from the add/remove programs>add/remove windows components.
0
 
zito2000Author Commented:
Does anyone know what could have caused this to happen?
0
 
eetheredgeCommented:
Sounds like corruption in the registry settings.  When was the last time this server was restarted?  updated??
0
 
zito2000Author Commented:
The server was restarted this morning thinking it was going to fix the RDP issue, but it didn't.  Before than Windows updates were installed on 10/11.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.