Registering files in Vista

Hello,

Apparently during installation of an application on Vista some files were not registered. "Component 'Vsocx6.ocx' or one of its dependencies not correctly registered: a file is missing or invalid"

How do you register missing components for 32 and 64 bit Vista?
MezczyznaAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

LeeTutorretiredCommented:
Your question is answered in this MS article:

http://support.microsoft.com/kb/282747
Error Message When You Run Regsvr32.exe on 64-Bit Windows
0
MezczyznaAuthor Commented:
Thank you. I tried it and it gives me this error:
 
The module "Vsocx6.ocs" was loaded but the call to DllRegisterServer failed with error code 0x8002009.
For more information about this problem, search online using the error code as search term.
 
So I will do, too.
 
Any more ideas?
Thank you.
0
LeeTutorretiredCommented:
This MS article tells about regsvr32 error message:

http://support.microsoft.com/kb/249873
Explanation of Regsvr32 usage and error messages

I'm still searching for the meaning of the hexadecimal error code you got.  But one thing:  if you are registering a 64-bit file, then did you run the version in the System32 folder?  Also, did you try running it from a CMD prompt which has been elevated  (right click and select Run as Administrator)?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
LeeTutorretiredCommented:
Mezczyzna, any feedback?
0
MezczyznaAuthor Commented:
Sorry,
Got pulled to do something different.
No. I did not run it as elevated. Should try that when the suer comes back tomrrow and yes, I run it in the System32 folder.
 
Sorry and Thank you.
 
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Vista

From novice to tech pro — start learning today.