How to disable kerning in Microsoft word for individual words or sections of a document?

Here is what I am trying to do (so you understand the context of my question): I am creating a program that will scan "printer ready files" for various printer languages. The program will replace various "tag" fields in the files to produce the final printed document.  So, it is a sort of "template merge" program.

My problem is, Word is over-agressively adding extra kerning to the text so I have to remove the PostScript XSHOW commands that Word is adding unnessarily.  Otherwise, when I replace the "tag" in the data with my actual text, it will look awful because the wrong kerning data is included with the PostScript.  The text looks fine without the extra kerning/XSHOW because the default kerning setup for the font looks good.

I tried selecting a block of text and going to the Font attibutes: Kerning was DISABLED. I tried enabling this, and setting it to kern for only larger fonts then I use. This made no difference, Word still wrote the kerning information.

I am working with ASCII85 PostScript to make this easy to identify the various codes.

So here is the specific question: How can I get Word to NOT add the kerning information for individual words or sections of a document?

Thanks,

Rob
RPannettAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

RPannettAuthor Commented:
More information: In the specific example, the text is in a text box in the Word document. I could try this "outside" of a text box if you think that would make a difference and see if the kerning gets disabled. However, I do need to use text boxes occasionally for this solution.
0
Joanne M. OrzechManager, Document Services CenterCommented:
Maybe a macro?
    With Selection.Font
        .Kerning = 0
    End With

Open in new window

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
RPannettAuthor Commented:
Wow, thanks! I'll have to try that..(hopefully soon, busy on another project).
0
Become a Certified Penetration Testing Engineer

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

Joanne M. OrzechManager, Document Services CenterCommented:
Ok - good luck!  Hope it works.... :)
0
RPannettAuthor Commented:
Looks like that does the same thing as what I was trying to do by selecting manually and changing the kerning attribute (which had no effect). I'll reward you for your idea anyway. I've had no time to try this but will when I get a chance. Thanks!
0
Joanne M. OrzechManager, Document Services CenterCommented:
Ok - well thank you....
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Word

From novice to tech pro — start learning today.