• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 880
  • Last Modified:

Enabling composite TV Out on a Sony PCG-F580 Laptop under Windows XP

I have an old Sony PCG-F580 laptop. It has a 3.5 mm TV Out jack on the side next to the headphone and microphone jacks.

I'm trying to get it hooked up to a TV. I tried two different adapters so far. One is a three wire connector from a Sony video camera. The other is a stereo headphone to RCA jack adapters. I can't get TV out to work no matter what I try. I've used every plug on both connectors, but still can't get a signal. I installed the hotkey utility and hit the TV button on the FN keys (it beeps, but doesn't do anything). I have the video driver from Sony's website that includes options for TV (though the TV out option is disabled).

Am I using the right adapter, or do I have to find a 3.5mm to RCA mono adapter? Once I do that, how do I get the driver to output video to the TV? Does it even work under XP, or do I need to roll back to Windows 98 (the original OS for this laptop)? Thanks.
0
thoffman
Asked:
thoffman
  • 3
  • 2
1 Solution
 
garycaseCommented:
According to the manual [http://esupport.sony.com/US/perl/model-documents.pl?mdl=PCGF580 ] that jack is a composite video output, so yes, you'll need a 3.5mm to mono adapter to get the correct connection.

In addition, the manual indicates the TV output only works with 640 x 480 resolution => so you have to set the display to that resolution for the composite output to work.   This is lower than XP will allow with most drivers ... so you may indeed want to install Windows 98.   I believe if you uninstall the video drivers and then reboot XP will revert to 640 x 480 when you reboot (although it may also automatically recognize and install your laptop's video card) ... or you could boot to Safe Mode.   Either of these should allow you to confirm that the Fn-F8 selection key is indeed activating the composite output as desired.
0
 
thoffmanAuthor Commented:
It looks like 640x480 made a difference, but it's still not quite working. I set it to 640x480, and the TV option under External Display on the NeoMagic tab of the advanced display options was still disabled. I dropped it to 16 bit color instead of 24, and it's enabled now. I don't have a mono 3.5mm to RCA adapter, though. I tried the 3.5mm to stereo and video adapter from the video camera (3.5mm to 3 RCA plugs) with all three plugs as well as a stereo to RCA adapter using both left and right for video. In both cases, the TV doesn't even flicker when I hit FN-F8. So, I either need a mono adapter, or my composite out is broken (quite possible). I'll have to buy an adapter tomorrow.

I'm hoping I can get TV out working. I've got a desktop with a capture card and am hoping I can hook the laptop up to the TV upstairs and use it to play back the video I recorded on the computer downstairs. It's proven to be more challenging than I thought it would be.

By the way, to get 640x480 under XP, you can go to the Advanced display settings, then click on "List All Modes..." on the Adapter tab. 640x480 is available under XP, it's just hidden. And, on this laptop, if the "expansion" option is enabled in the NeoMagic settings, it tries to stretch 640x480 to 1024x768, which looks horrible.. It's much nicer with expansion turned off, even though it puts a huge border around the desktop.  :)
0
 
garycaseCommented:
Sounds like you're about there -- just need the right cable.

If that doesn't do the trick, you may want to look at the Hauppauge MediaMVP, which is available in both wired [http://www.provantage.com/hauppauge-1000~7HAUP11X.htm ] and wireless [http://www.provantage.com/hauppauge-1016~7HAUP12J.htm ] versions.  This is a very simple way to watch (or listen to) media from your computer on your other TV's.
0
 
thoffmanAuthor Commented:
Thanks! That did the trick. I went rummaging through my box of cables and found another stereo to RCA splitter. I tried that one, and I get video off the red cable (I think that's the right channel). At first, it was flickering like mad, but it turned out that under the advanced settings on the NeoMagic tab, it was set to PAL. Switching to NTSC did the trick. I guess my other splitter is bad.
0
 
thoffmanAuthor Commented:
By the way, I did look into devices like the MediaMVP. The laptop's just collecting dust, and I don't need to watch captured video on my TV that often, so I figured it was a cheap solution. I'll probably get a real set top box eventually.
0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now