Changing gui startup on mythbuntu?

When my mythbuntu 8.10 system boots, it's launchs the xfce desktop.

Once xfce is ready, the mythtv frontend get launched.

What i want to do is...

1) leave the backend alone completely!

2) NOT launch the frontend on boot (but i still want it installed so i can manually start it when needed)

3) when xfce desktop has loaded do the following automatically...

sudo xset led 3
sudo xset -dpms
sudo xset s off
sudo xset s noblank
sudo xset s noexpose
sudo xvattr -a XV_COLORKEY -v 66048

then open a terminal, maximise it to fill the desktop and run this command within it...

while true; do df -Th; mythtv-status -c -e --encoder-details; sleep 15; clear; done

I don't know how to change the startup routinue for xfce so some help would be most useful.

Hope that all makes sense, let me know if not.
LVL 2
davepuseyAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Michael WorshamStaff Infrastructure ArchitectCommented:
I found this post that might help...

MythTV Ubuntu Installation Guide
http://parker1.co.uk/mythtv_ubuntu.php

Scroll down to the 'Run MythTV Frontend Automatically' and it seems all you might have to do is do a 'chmod -x /home/mythtv/.gnomerc' to disable the frontend from starting automatically.
0
davepuseyAuthor Commented:
That file does not exist on my system.
0
Michael WorshamStaff Infrastructure ArchitectCommented:
Since no one else has posted to this question, I will recommend that you might want to check out the Mythbuntu support forums as well:

http://www.mythbuntu.org/support
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
coandaCommented:
It's been a while since using Xfce so I don't really remember the location of the startup file (~/.config/autostart maybe) but you could try looking in your ~/.xsession file to see if the front end is launched there. Other places to look would be in rcconf, xfce4-autostart-editor or xfce4-session.

For the commands that you want to run as root, if you find an autostart file put them in there or in your .xsession file, but you would first want to add this line in the /etc/sudoers file:

username ALL=(ALL) NOPASSWD: ALL

It is however a security hole to allow for a user to execute commands as root in a script without a password.

Also, check out aterm for a nice terminal that can be configured to do what you're looking for. To get a full screen aterm running your while loop put the following in a file:

#!/bin/bash
while true; do
  df -Th
  mythtv-status -c -e --encoder-details
  sleep 15
  clear
done

Of course chmod +x on the file and run this command in your .xsession file:

$ aterm -tr +sb -bl -geometry 210x60+0+0 -e ~/myth-stats.sh &

you'll probably have to change the geometry settings to get it to be fullscreen for your monitor, 210x60 worked for me with the default aterm font size on a monitor resolution of 1440x900.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.