Logon problems when booting back and forth between Windows and Leopard

All of our lab Macs are dual booted to Windows XP using Boot Camp. We use a variety of design software which requires both sides. Both sides are bound to our Server 2008 Active Directory. Most everything works well with this arrangement except for booting back and forth.

Here are the steps of a typical user:
1. Logs into Mac side using AD account and does some work
2. Reboots to Windows XP, logs in using the same AD account, and does some work
3. Reboots back into the Mac side and is unable to logon using the same AD account.
4. Administrative user logs in locally, resets the time when prompted (it changes it to 4 hours off real time)
5. Initial user can now log on normally

We've so far isolated the issue as being a time based issue because the Mac always opens the set time dialog, and the time is always set wrong, but we haven't been able to get any further with it.

This is a significant issue for us, so any help is greatly appreciated.

Thanks
CIA-MikeAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jhyieslaCommented:
The time thing is a known issue.  But I think that OS X resyncs it's clock quickly after reboot.  Try coming out of Windows and way 2-5 minutes before attempting to log in to OS X.  As far as I can tell, there is no ready fix for the time problem other than to let it reset itself.

You might also try setting your AD users up with a Mobile account in the Directory Utility Advanced area.  I think that this is supposed to do like Windows in that it creates the user so that if its off-line from AD the user can still get to the desktop.

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
DJDecayCommented:
The Way OS X and windows stores time is different. Try to get mac-os to autoset the clock with ntpdate on startup against one of your DC's,




0
strungCommented:
Would running Windows inside VMWare Fusion be a reasonable alternative? If would avoid constantly rebooting.

http://macwindows.com/winintelmac.html
0
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

jhyieslaCommented:
DJ... may be right about the time server sync... I don't use that in my environment where I have BC running.

WMware Fusion and parallels both do a great job of running WIndows on top of OS X.  The only thing that still doesn't work well is graphic intensive programs like modern games.   Both also have the ability to run your BC partition as a VM.  So if you are happy with how your BC partition is set up, you wouldn't have to redo it all just to create a VM.
0
CIA-MikeAuthor Commented:
It appears that jhyiesla's initial response is going to give us the desired response - at least for now. The time server should work, but does not seem to update the time fast enough from our experience.

VM and Parallels are not good for us because we're using all the Adobe products plus digital video editing, so the issues with vm's are real for us.

I'll let you all know how this works out tomorrow.

Thanks
0
DJDecayCommented:
See Apple MAC OS comes with NTPD (an Network Time Daemon) that keeps the clock in check.
However if the clock drifts more than a couple of minutes you'll need ntpdate to set it.

From the terminal it looks like this

'
sudo /bin/bash
<enter your password>
bash-3.2# ntpdate time.nist.gov
10 Nov 21:31:56 ntpdate[3259]: adjust time server 192.43.244.18 offset -0.000359 sec
bash-3.2#

^^^^ above is a successful ntpdate sync. It's instant.

-- here is what an unsucceful ntpdate run looks like (this means ntpd is in background) turn it off by disabling "set time and date automatically out of system preferences"

bash-3.2# ntpdate time.nist.gov
10 Nov 21:34:06 ntpdate[3284]: the NTP socket is in use, exiting
bash-3.2#


Next thing you would want is for ntpdate (not ntpd) to fire up immeidately on system boot up from rc/launchd.

0
DJDecayCommented:
ntpdate will provide you with an instant clock sync from any NTP time server

time.nist.gov
time.apple.com
time.microsoft.com

or your local Domain Controller if configured.
0
jhyieslaCommented:
CIA-Mike... did anything suggested here solve your issue?

If the you do not know how to close the question, the options are here:
http://www.experts-exchange.com/help.jsp?hi=407
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Mac OS X

From novice to tech pro — start learning today.