The name of the the database files in this store is invalid

Hey guys, this morning after I rebooted my Exchange 2003 Standard server I'm getting The name of the the database files in this store is invalid after I try to mount the store.
Other Error:
ID No:C1041737

I have 1 store First Administrative Group
I backup the exchange using Symantec Backup Exec 11D, I have a good recent full back as of this morning 4am. I went thru the recovery in BackupExec and it ran successfully but still can't mount the Exchange store. Am I doing something wrong or missing a step.
Can anyone walk me trough how to recover the store and emails?
pbaptisteAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

hodgeyohnCommented:
it depends on what you have.
please provide a directory of what is in the mdbdata folder and i will try to help.
pbaptisteAuthor Commented:
E:\Ecchsrvr\MDBDATA\
4-FAB51DB0-D5F8D52.IFS
E00.chk        8kb
priv1.edb      6,419,528KB
priv1.stm       4,003,848KB
pub1.edb        24,584KB
pub1.INTEG.RAW   222KB
pub1.stm    8,200KB
hodgeyohnCommented:
ok so you have the standard file names.
start the information store service (if this does not start please provide the exact error code).
go to the properties of the mailbox store.  verify that the path, and file names actually match.  if not this would be the first things to fix.  dont forget to check the priv1.edb, and priv1.stm.  both files are critical.
SolarWinds® IP Control Bundle (IPCB)

Combines SolarWinds IP Address Manager and User Device Tracker to help detect IP conflicts, quickly identify affected systems, and help your team take near instantaneous action. Help improve visibility and enhance reliability with SolarWinds IP Control Bundle.

pbaptisteAuthor Commented:
All the services started with no error ad the patg under mailbox store are pointing to the correct file names and path.
hodgeyohnCommented:
then i am guessing that there is some type of weird corruption.
i would
1.  backup the existing files in case we decide to come back to this.
2.  delete the file and start the store to get mail running again.
3.  attempt to restore the IS from your backup exec.
hodgeyohnCommented:
actually you could run an

eseutil /mh against the files just to see what it tells you.
pbaptisteAuthor Commented:
In a command prompt? can you give me the command?
thx
hodgeyohnCommented:
pbaptisteAuthor Commented:
Ok I ran the util and its finished.
Lots of info but I'll post the one I think needs your attention
State: Dirty Shutdown
Streaming File: Yes
Shadowed: yes
ECC Fix Success Count : none
Old ECC Fix Success count: none
 All the rest says none also on that sections
pbaptisteAuthor Commented:
What about this error JET_errDatabaseDirtyShutdown, Database was not shutdown cleanly.
hodgeyohnCommented:
ok so now we have some idea where we are.

 you need to run
eseutil /p path to the edb file.  this will repair the database.

use the links below for more info on the repair switch /p

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
pbaptisteAuthor Commented:
I tried that and it gave another error that my log files was missing, I am now recovering the log file and I'll try again.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage Software

From novice to tech pro — start learning today.