Microsoft, InfoPath 2007, 2007, MOSS 2007, Web Services, username

I have been able to create forms and publish to MOSS 2007.  I have a field I've created before and pulled the "Preferred Name" of the user into the form with no problem using the web services.  All of a sudden, I can't.  I only get a SID.  I've tried using the action and "username()", but that comes in blank.  Any ideas would be great.
SherryDeveloperAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Clay FoxDirector of Business IntegrationCommented:
Try creating a test InfoPath form to get preferred name and see if it does the same thing.

If so the issue is that the web service may have changed, otherwise it is a form issue.
You may be filtering out the wrong field.
0
SherryDeveloperAuthor Commented:
I have tried creating a new form and pulling in that field.  Same thing.  Here's what I'm putting in

Value[Name="PreferredName"]

This is what I have used before with no problem.  I use the GetUserProfilebyName from the web service.  I even tried accessing the form from another computer, same thing.  We did have problems with our AD recently.  Most users were deleted and had to be restored.  I reindexed the SharePoint after running a new import.  No luck.  I checked the database, userdata tables and only find about 5 entries.  I may be checking the wrong database to find them, but don't see any other users.  I even pointed to another server for the web service in another farm, test environment, same thing.  I'm going to try configuring my service provider on the test environment today, import the profiles again and see if that helps.
0
Clay FoxDirector of Business IntegrationCommented:
Have you put all these variables on the form. Put your AD node in a repeating table so you can verify exactly what is being returned.  
Often it is a simple mismatch with a space or some other text issue.
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

SherryDeveloperAuthor Commented:
I've only tried to return the username on one field at this point.  I'm not sure what you mean by putting an AD node in a repeating table.  So far, I've only been programming a little, most of what I've done is out of the box.  I'll check on this and make sure I'm putting things in ok.
0
SherryDeveloperAuthor Commented:
I am still unable to retrieve anything except the user sid from the web service.  Can anyone tell me how I might try retrieving the user account instead of the preferred name.  Just to see if I can.  Thanks
0
SherryDeveloperAuthor Commented:
I am still unable to retrieve a user name from the web service in infopath.  Could it be that the web service is corrupt in some way and how might I fix this issue?  Any help would be greatly appreciated.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
InfoPath

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.