no Authentication methods enabled error

I have a web site in visual studio 2008, going to a MS web server 2008 web edition web server.

I have front page extensions installed on this server.

I am trying to use the copy web site menu item to copy my local files to my remote server. If I have forms authentication, instead of windows authentication in my web.config:
      <authentication mode="Forms">
          <forms cookieless="UseCookies" defaultUrl="~/Default.aspx" domain="" enableCrossAppRedirects="false" loginUrl="~/Login.aspx" name=".ASPXAUTH" path="/" protection="All" requireSSL="false" slidingExpiration="true" timeout="30" />
      <identity impersonate="false" />

I get this error when trying to connect to the site to copy:
Unable to open the web site". The web server does not appear to hvae any authentication methods enabled. It asked for user authentication, but did not send a WWW-Authenticate header.

What am I lacking? Why can't I copy using forms authetication. If I change to windows authentication, I can copy, but this is no good for my web site since I need forms authentication.


Starr DuskkASP.NET VB.NET DeveloperAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Starr DuskkASP.NET VB.NET DeveloperAuthor Commented:
That is IIS4.
I am using windows 2008 and IIS7.
I wouldn't know where the equivalent was in IIS7 and can't find anything equivalent. I know how to setup the anonymous user, but that's not what it's telling me to do.
The basic idea is the same.
Lauch IIS -> Web Sites ->Default Web Site, then right-click your application folder and select Properties. Then click Directory Security tab and click Edit to change Anonymous access. Then make sure "Anonymous access" is checked and "Intergrated Windows authentication" is also checked.
Let me know if it helps.
Amazon Web Services

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

Starr DuskkASP.NET VB.NET DeveloperAuthor Commented:
Are you familiar with IIS7? there is no properties folder. It is nothing like IIS4, or iIS5 or iIS6.
>>>Are you familiar with IIS7?
No, but it seems you are.
As I mentioned before, the basic idea is the same: you enabled the anonymous acess for your site, but no authentication is enabled.
Sorry for the confusion and since you are not satisfied with my comments, I am moving on to other questions. Hope other more advanced experts can assist you more.
Starr DuskkASP.NET VB.NET DeveloperAuthor Commented:
Okay, if anyone has any idea what needs to be done in IIS7 to get this to work, I'd appreciate it. I can get the authenticated user to work for windows authentication, but it's the forms authentication that is failing.
The IIS4 instructions do not pertain to IIS7 and I can't find an equivalent.
Starr DuskkASP.NET VB.NET DeveloperAuthor Commented:
Added note:
web.config only contains windows authentication, but if I check to include windows authentication in the actual IIS7, it allows me to copy. But it gives an alert:
"Challenge based and login-redirect based authentication cannot be used simultaneously."
It doesn't seem to choke on the website, but it evidentally is not the right way to do it.
What can I do to get forms authentication to work and still allow me to copy files?
Starr DuskkASP.NET VB.NET DeveloperAuthor Commented:
Sorry. The above is not true. I have another window open with another website I'm testing and got confused.
Still in same problem. Forms authentication is not allowing file copy. Ignore the previous message.
Starr DuskkASP.NET VB.NET DeveloperAuthor Commented:
In IIS7, you can go to the website:
In the middle panel, which is known as the FeaturesView, in the middle half, there is an icon called: Authentication under the IIS section.
This will bring up Anonymous Authentication and and Forms Authentication and Windows Authentication.
Click each one and in the Actions panel on the right you can set the status to Enabled or Disabled.
Starr DuskkASP.NET VB.NET DeveloperAuthor Commented:
IIS 7.0 supports both challenge-based and login redirection-based authentication methods. A challenge-based authentication method, for example, Integrated Windows authentication, requires a client to respond correctly to a server-initiated challenge. A login redirection-based authentication method, for example, Forms authentication, relies on redirection to a login page to determine the identity of the user. You cannot use both a challenge-based authentication method and a login redirection-based authentication method at the same time.
I will ask in other forums about this. Because for my web apps I need forms based authentication, but for copying up via visual studio, I need windows authentication.
I get an alert they can't be used simulataneously.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
I'm having the same issue but with IIS 6.0 instead of IIS 7.0.  Both "Publish Web Site" and "Copy Web Site..." methods fail.  I'm only using Integrated Windows Authentication and I'm a Power User on the server that I'm trying to deploy to.  When I try to publish I get the following error:

Error: The operation could not be completed. Unspecified error

And when I try "Copy Web Site" I get:

Unable to open the web site". The web server does not appear to have any authentication methods enabled. It asked for user authentication, but did not send a WWW-Authenticate header.

I've turned off forms authentication and turned on Windows Authentication in IIS as well.  Finally, I've restarted the IIS service many times in order to make sure all my changes would take effect when the IIS service restarted.  Nothing seems to work.  

What am I doing wrong?
Starr DuskkASP.NET VB.NET DeveloperAuthor Commented:
You should maybe start a new post just for this so you'll get better responses?
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
.NET Programming

From novice to tech pro — start learning today.