?
Solved

Two websites, same connection, same web.config, error

Posted on 2008-11-10
5
Medium Priority
?
176 Views
Last Modified: 2013-11-26
I have two websites on a windows 2008 web server web edition server.

They both use the exact same connection string in the web config:
       <add name="TUConnectionString" connectionString="Data Source=xx.xx.xx.xx;Initial Catalog=TU;Integrated Security=True" providerName="System.Data.SqlClient" />

They both are setup in IIS7 with the exact same settings. They both have frontpage extensions installed.
They both have the same Authentication, Anonymous user with the same password.
The MS SQL Server 2008 database has the same user setup with permissions.

However, in one website I can hit the database just fine. But the second website gives me this error:
Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'.

I cannot for the life of me figure out why one website can connect and the other cannot. Again, the anonymous authentication specific user is exactly the same. I have typed it in numerous times and retyped the password numerous times for both sites to make sure they are the same.

What am I missing?

0
Comment
Question by:Starr Duskk
  • 3
  • 2
5 Comments
 
LVL 32

Expert Comment

by:Daniel Wilson
ID: 22925701
Sounds to me like a Kerberos issue.  Kerberos is set up for the DNS name you're using to get to one site, but not the other.

Maybe I'm wrong ... but when I'd covered all the bases you describe, that was the one I missed.
0
 
LVL 2

Author Comment

by:Starr Duskk
ID: 22925818
Where is Kerberos set up? Becuase I am not doing anything with it myself.
 
0
 
LVL 32

Assisted Solution

by:Daniel Wilson
Daniel Wilson earned 2000 total points
ID: 22930128
There's a lot to read on it ... and I haven't done it myself, so I'll refer you to some who have:
http://support.microsoft.com/kb/319723
http://support.microsoft.com/kb/326985
0
 
LVL 2

Accepted Solution

by:
Starr Duskk earned 0 total points
ID: 22934471
It wasn't kerberos. I had that on.
The problem was, I believe, the two sites weren't the same, I needed:
    <identity impersonate="true" />
in both.
 
0
 
LVL 2

Author Comment

by:Starr Duskk
ID: 22934485
Kerberos in IIS7 is in:
select web site.
go to features panel
select authentication icon
enable windows authentication
select advanced settings
enable kernal mode authentication checkbox has to do with kerberos. read info below that.
 
 
0

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Hello there! As a developer I have modified and refactored the unit tests which was written by fellow developers in the past. On the course, I have gone through various misconceptions and technical challenges when it comes to implementation. I would…
This shares a stored procedure to retrieve permissions for a given user on the current database or across all databases on a server.
SQL Database Recovery Software repairs the MDF & NDF Files, corrupted due to hardware related issues or software related errors. Provides preview of recovered database objects and allows saving in either MSSQL, CSV, HTML or XLS format. Ensures recov…
Stellar Phoenix SQL Database Repair software easily fixes the suspect mode issue of SQL Server database. It is a simple process to bring the database from suspect mode to normal mode. Check out the video and fix the SQL database suspect mode problem.

609 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question