3.5 SP1 error: Could not load file or assembly 'AjaxControlToolkit' or one of its dependencies. Access is denied.

I have a windows 2008 web server and have copied up a web site that uses ajax.

However, I am using visual studio 2008 with 3.5 SP1 locally and have 3.5 SP1 on the server as well. So I shouldn't have to download and install it, should I?

http://www.asp.net/ajax/downloads/
>>The Microsoft AJAX Library 3.5 is a standalone collection of the standards-based JavaScript classes that are automatically included when using ASP.NET AJAX in ASP.NET 3.5 SP1.

What do I need to get this to work with IIS7, 2008, etc?

Thanks.
LVL 2
Starr DuskkASP.NET VB.NET DeveloperAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Juan_BarreraCommented:
Hi Bob,

The AjaxControlToolkit is still a separate download, but you can deploy it to the server with your web site, it's just a .dll (which you can download from the website).
0
Starr DuskkASP.NET VB.NET DeveloperAuthor Commented:
I checked my /bin and the dll is in there.
Any other ideas?
thanks.
 
0
Starr DuskkASP.NET VB.NET DeveloperAuthor Commented:
I made sure I had the latest version in the /bin and downloaded it from here:
http://www.codeplex.com/AjaxControlToolkit/Release/ProjectReleases.aspx?ReleaseId=11121
and copied it to the server. still the same error.
:( sigh.
 
0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

Juan_BarreraCommented:
Is the file blocked by Windows Server 2008 / Vista?
0
Starr DuskkASP.NET VB.NET DeveloperAuthor Commented:
I'm using windows server 2008 web edition, not visa.
Blocked?
 
0
Juan_BarreraCommented:
Yes, if the file can be blocked "if it comes from another machine", in WS 20008 and Vista.
Right click on the file > properties > General.  If it's blocked, at the bottom, under "Advanced", you'd have an "Unblock" option.
0
Starr DuskkASP.NET VB.NET DeveloperAuthor Commented:
No. there is no blocking on there.
 
0
Starr DuskkASP.NET VB.NET DeveloperAuthor Commented:
I finally got it to load.
I had to close some VS2008 project windows to make sure I had enough memory and reinstall the toolkit in the toolbar and make sure both the project and the kit were the same build.
I started with a zipped project and I don't think it was compatible with my "upgrading to 3.5" on loading it.
 
 
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
.NET Programming

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.