• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1387
  • Last Modified:

flash recovery area is corrupt/missing?

Hi, I had configured my flash recovery area on an external drive ( a usb drive). Now the configured drive is missing / corrupt and when I do a startup command I get the followig errror;

SQL> startup
ORA-01261: Parameter db_recovery_file_dest destination string cannot be translated
ORA-01262: Stat failed on a file destination directory
Linux Error: 2: No such file or directory
SQL>
What do I do? How can I run the following cammand to change the FRA
 
alter system set db_recovery_file_dest='\home\oracle\FRA' ?

Thanks for the help.

A

0
aej1973
Asked:
aej1973
  • 4
  • 3
1 Solution
 
Richard OlutolaConsultantCommented:
You need to change the db_recovery_file_dest parameters in the parameter file (init<sid>.ora) and start the database using the changed pfile.

R.

0
 
aej1973Author Commented:
Great! Thank you.

A
0
 
aej1973Author Commented:
I realized that I do not have an init<SID>.ora file, the parameter file I have is spfile<SID>.ora file. What do I need to do? Thanks for thehelp.

A
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
Richard OlutolaConsultantCommented:
That is a problem. The spfile file is binary and cannot be edited.

In a deperate situation I have tried to open the spfile and copied it into a pfile (init<SID>.ora).

R.
0
 
aej1973Author Commented:
how do I make sure that  I also have an updated init<SID>.ora) file on my system? Thanks for the help.

A
0
 
Richard OlutolaConsultantCommented:
You can periodically issue the following command from sql*plus

SQL>create pfile form spfile;

This saves your server parameter file in pfile (ASCII) format. If you have problems starting the database in future you can edit the pfile and start the database using that.

R.

0
 
aej1973Author Commented:
Thanks a ton rolutola, that worked.

A
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now