Creating mail-enabled groups in Exchange 2003

Ok We've got a small business here, Server 2003 shop.  We've got a exchange server that I need to create a mail-enabled group on.  Now I know how to create the group and add users.  But when they reply, it comes from there user exchange mailbox and not the group.  Basically I have 1 user thats needs the alias "manufacturing@acme.com".  I've set that up sucessfully but when the user replys, it comes from his user mail box.  Heres what I need:

1)  I want the world to be able to send email to manufacturing@acme.com
2)  I want those messages to be sent to a specific user mailbox.
3)  When he replys, I want to those emails I be sent from manufacturing@acme.com and not his user mailbox.  So the recipient only sees From: maufacturing@acme.com


Is this possible?  I've got steps 1 and 2 configured... but how do I setup step3?


-Alex
sna1almAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

tenaj-207Commented:
Assuming that it is not acceptable to have in the from field;
User@acme.com on behalf of manufacturing@acme.com

Then you only have a couple of options.  The main issue is that you can only have one exchange account per Outlook profile.  To work around this you only have two real options

1) You could setup the second email account using IMAP or POP3.
2) You create a second profile in Outlook.  In the more commonly used profile you can open the other users mailbox using the "Open these additional mailboxes" features then when you see and email come in you can close the one profile and switch to the other profile, and send the email.

This post goes over the "Open these additional mailboxes"
http://www.experts-exchange.com/Software/Misc/Q_21869847.html

I've also gone over this in detail in this other post.
http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_23843503.html

good luck,
tenaj
0
sna1almAuthor Commented:
I was afraid of that.  So do you have a doc avail on setting up SMTP?  I have control of over my registrar (external DNS control), as well as router control... (inbound\outbound pop\smtp).   I'm concerned about security with SMTP, and misconfiguring something with the end result being that spammers can use my exchange box as a relay?
0
wolfcamelCommented:
the second account method wont work - as you want to send from the groups email address.

do you need to have the group?
can you have ..
a user - manufacturing
with a rule to forward a copy to all the group members
and then use a second smtp account on each user to be able to send FROM the manufacturing user.

smtp will be safe internally if you have good antivirus and you must have for external anyway.
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

wolfcamelCommented:
so once you have the manufacturing user
you need to set up a second account - the second account should be pop/smtp with the internal ip address and AD username and password - and the alias email address you want to use.
Then you can configure outlook not to receive mail for this account (in define send/receive groups)
then when you create an email you will have a new button on the toolbar for account.
You will also be able to define a second signature that will change automatically.

in exchange..
default smtp server, access, relay, users - allow authenticated users to submit and relay

this will ensure you arent open relay
0
tenaj-207Commented:
You don't need to setup SMTP, just IMAP (or POP3).  

To do this,

1) Make sure the IMAP service is started
2) Then go into the ESM and enable the protocol there.
3) Make sure that ports 443 and 993 (993 is only needed if you are using SSL) are open on the firewall.

If you are using a certificate then you will also need to do the following;
1) Right-click the Default IMAP4 Virtual Server and select Properties.
2) Select the Access Tab, and click the Certificate button.
3) Click Next.
4) Select Assign an existing Certificate and click Next.
5) Select the appropriate SSL Certificate and select Next.
6) Click Next, then click Finish.
7) Stop and restart the Default IMAP4 virtual server. You have now enabled the use of the SSL certificate with IMAP4

The setup for POP3 (use port 110 and 995 for SSL) is very similar but I like IMAP more.
For more information see this link.
http://www.azaleos.com/blog/index.php?q=node/43

Hope that helps,
-tenaj
IMAP-enable.jpg
0
wolfcamelCommented:
but imap and pop3 both need a SMTP server to send - and it is sending that is the issue?
imap has the advantage of leaving the mail in the manufacturing mailbox - but you still need to send as
0
wolfcamelCommented:
you could use the exchange send as permissions to give the user sending permissions to choose manufacturing in the from field - but then you have the on behalf of issue.
0
tenaj-207Commented:
@wolfcamel - If the exchange server is already setup and working then it's using SMTP to send emails.  When you setup IMAP it uses the same exchange SMTP server.  There is no need to reconfigure it or create a new one to use IMAP.

@sna1alm - if you want to make sure that you aren't an open relay you can follow wolfcamels directions or you can go to http://mxtoolbox.com and type in your domain name, click on MX Lookup, then click on Diagnostics, then click on test email server.  This will let you know if you server is an open relay.

-tenaj
0
sna1almAuthor Commented:
Alright guys so this is what I did...

1)  Had my user that needs both accounts to start using terminal services (hes at a remote site).  So now hes accessing the network locally.
2)  I deleted the universal group account, and created a new user manufacturing.  
3)  I added relay rights the manufacturing account in ESM in the SMTP virtual server.
4)  I created DNS A records on the DC for pop3.acme.com and plugged the internal ip of the exchange server under "SMTP Server", and added the manufacturing user credentials.
5)  So it works and he can send and receive email from the manufacturing account, but its whacked.  When ever he sends from the newly created pop\smtp account (while simultaneously accessing his user exchange account)  Outlook pops up with the new recieved mail "fade in\fade out" alert down near the system tray.

So I think I got it work, but I back-doored it.  My DNS is working but not correctly, I had to add the exchange IP and not use the new DNS A record "smtp.acme.com" record (which pointed to the exchange IP) because when I attempted to send using this record, I got instant bounce backs.

Should I be using cnames instead of A records?  

Also what about using the internet email wizard in ESM?

Feedback is much appreacited!
0
wolfcamelCommented:
You didnt really need another DNS record but it should have worked - a bit hard to see why not if you are internal and you set the internal IP.
The send/receive fade in out is normal as this is what a POP account does, whereas exchange doesnt need this send/receive feature.
My guess with the DNS is that acme.com is hosted externally but you added the pop3.acme.com to your internal dns and this has likely confused things - if you ping pop3.acme.com does it resolve correctly to the server IP?
You dont need to run the internet email wizard as exchange is working - sending and receiving external email - which is what the wizard sets up.

My comments re SMTP server - where that you need to have one for exchange to work at all - and you must already have one setup - there was never any need or suggestion to setup a new one - just that it should be used (as you have done) to send mail from an internal source rather than just as a connector to the outside world.

With your relay rights in ESM for manufacturing - just make sure that manufacturing still requires a password to relay - otherwise spammers will soon relay from manufacturing.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
sna1almAuthor Commented:
Thanks guys.  I appreciate everyone taking the time to help me out.  Take care.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.