?
Solved

Missing wireless network. How do I find it?

Posted on 2008-11-11
28
Medium Priority
?
1,635 Views
Last Modified: 2012-05-05
I have a client using an Asus Notebook. He connects to a D-link DWL-2100AP wireless access point. He is using Windows Vista. Yesterday he was working fine and today he can't see the wireless network.
Viewing available networks shows 7 other networks in the area but his one isn't in the list. There are 8 other users of the network who are working fine. One other user on a desktop PC had the same problem this morning, after much fighting with it, I changed the wireless network card and it worked instantly. This led me to believe the MAC address had been blocked....nothing blocked on the router. I changed my test notebook to his MAC address and I still have access. I have restarted the AP and notebok, the diginet router for the internet connection and stopped short at throwing the notebook out the window. Any ideas?
0
Comment
Question by:findingsolutions
  • 13
  • 7
  • 5
  • +1
28 Comments
 
LVL 3

Expert Comment

by:24play
ID: 22929921
is the SSID broadcasting?
0
 
LVL 3

Expert Comment

by:24play
ID: 22929923
a sorry - just re-read

So you changed the wireless card and it worked fine?

You also tested his wireless card in your machine and it worked fine?
0
 
LVL 1

Author Comment

by:findingsolutions
ID: 22929996
The SSID is broadcasting. All other PC's and notebooks can see it. I have also added a second SSID on the primary AP and this can't be seen by the troublesome notebook so I have removed the second SSID.

The first PC was a desktop so installing a new wireless card was easy. The second problem is a notebook. Can't test teh card in another machine. It is able to pick up other wireless networks in the building and moving it around it shows signal strength changes for these networks. So the card appears to be working.

Seems strange that 2 machines had the exact same problem this morning. Is it possible something else on the network can be causing this? I have a cisco router that provides DHCP and this has caused a few problems before by blocking internet access but it has never caused a wireless connection problem. (don't see how it cause block the SSID from being seen)

Basic layout of network.....  10 pc's and notebooks connect wirelessly to 3 APS (identical), the primary AP connects to a 8 port switch which connects to a cisco diginet router for internet access.

I"m pretty sure it's something on the network causing it as my own notebook lost the SSID earlier while doing testing but a restart fixed that.

I have also tried testing with the 2 extra AP's switched off in case it was a relay problem.
0
 The Evil-ution of Network Security Threats

What are the hacks that forever changed the security industry? To answer that question, we created an exciting new eBook that takes you on a trip through hacking history. It explores the top hacks from the 80s to 2010s, why they mattered, and how the security industry responded.

 
LVL 1

Author Comment

by:findingsolutions
ID: 22930054
just to elaborate...

there were two problems. PC wouldn't see SSID but could see 7 other wireless networks. Notebook can't see SSID but can se 7 other networks.

Problem one with PC was resolved by changing the wireless lan card.

Problem 2 still exists as it's a notebook so i can't change the card.

What I have tried in point form...
disabled and re-enabled card
manually configure wireless conection
reinstalled card
changed IP to static
attempted to change mac address but Vista won't change it.
tried problem mac address on my own notebook and still have access.
0
 
LVL 1

Expert Comment

by:ZJuanS
ID: 22930135
It seems to me that the problem is on the pc and not the router. You can try renew the ip address and also reinstall the pc wireles drivers again. I have a dell XPS and was having the same issue. My router was fine but my pc was not seeing the wireless connection. I reinstalled the quickset drivers and it worked fine.

You sould reset all the wireless configurations that are already configured on your pc.

JS
0
 
LVL 1

Author Comment

by:findingsolutions
ID: 22930280
The notebook is able to see other wireless networks but specifically not the one it's normally connected to. Both the notebook and pc lost this connection at the same time.

Until it sees the SSID it won't pick up a DHCP assigned IP so I assigned static. This didn't work.
I reinstalled drivers, restored PC to when it was last working and still no luck.
0
 
LVL 3

Expert Comment

by:24play
ID: 22930317
Silly question

you haven't got a limit set in the AP's have you?

Try disabling 2 other machines wireless cards so they don't connect - maybe even reboot the AP and then see if you can see it

when you uninstalled the wireless cards did you uninstall it then reboot before re-installing?
0
 
LVL 1

Expert Comment

by:ZJuanS
ID: 22930333
What about the IPconfig and seleting that pc from the router? Have you tried to connect to the other networks??
0
 
LVL 1

Author Comment

by:findingsolutions
ID: 22930377
no, no limits set and I have had more connections active at one time on this network. The SSID should stil be seen even if the AP is busy, over-loaded or has security preventing access.

I tried various configurations of rebooting, reinstalling, uninstalling etc.

Except for the fact that I don't have the network keys I can almost connect to the other networks. The ones with higher signal strength ask for the key, the ones that are extremely low just give an error (as I expect)

I  have even tried playing with the MAC filtering to see if that's the problem. Nothing is set there.

 
0
 
LVL 3

Expert Comment

by:24play
ID: 22930441
Change the channel on the wireless card to 11 if its not already on it
0
 
LVL 1

Expert Comment

by:ZJuanS
ID: 22930445
Okay. So try to delete that pc from the router. Since your pc can see other routers, and cannot see your, that tells me that the problem is between your router and your pc. But most toward the router. Can you reset the router or as i said, delete all the configuration and information related to that pc on the router. Also, try to check if there is any security configuration enable that is preventing you from seeing the connection.

Check the antivirus too. Firewall and anything that may be blocking you from seeing it.

JS
0
 
LVL 3

Expert Comment

by:24play
ID: 22930447
sorry on the AP **

what channel are you using?
0
 
LVL 1

Author Comment

by:findingsolutions
ID: 22930510
The device is a D-link Wireless access point. It has very limited abilities. Can't seem to find anywhere where it lists attached devices or lets me look for a device.
0
 
LVL 1

Author Comment

by:findingsolutions
ID: 22930535
The AP is set to autoscan channel. I have changed this on the card and no luck.
I have disabled all firewalls and anti-virus.
I have told windows to diagnose the problem and obviously this doesn't work.
0
 
LVL 1

Author Comment

by:findingsolutions
ID: 22930579
I have also tried a hard reboot and soft reboot of the AP. (much to the disgust of the other users)
0
 
LVL 3

Expert Comment

by:24play
ID: 22930655
hehe Mr Popular rebooting the AP ;)

So the AP is not set to a particular channel to broadcast on? Not heard of the auto scan before but I don't use an AP standalone as such
0
 
LVL 1

Author Comment

by:findingsolutions
ID: 22930720
The AP has an option labelled auto channel scan. This supposedly selects the most appropriate channel to use. Probably the only smart feature on the device. I'll try changing and setting a channel manually but unfortunately most of the users have gone home now so tomorrow morning i'll find out the result if they all lose access ;-)
0
 
LVL 1

Accepted Solution

by:
ZJuanS earned 600 total points
ID: 22930778
Well I have never used a a D-link Wireless access point. However, there should be a place where you can manually assign Mac ipaddress through the router. It will display you a list of all the pc connected to it and you can delete them.
In addition, please do the ipconfig if you have not done it. make sure that you delete the previous internet wireless conection that is saved when you connect to internet through a wireless conection and tell the pc to logon automatically. That should be found on control panel under network connection.

The ipconfig can be done through CMD so let me know if more information is needed to perform this.
0
 
LVL 3

Assisted Solution

by:24play
24play earned 300 total points
ID: 22930800
ok good luck tomorrow

try a few different channels just incase
0
 
LVL 44

Assisted Solution

by:Darr247
Darr247 earned 600 total points
ID: 22935048
> Can't seem to find anywhere where it lists attached devices or lets me look for a device

Advanced tab on the top, DHCP Server button on the left... that gives 3 submenu options just below the Advanced tab.
Dynamic Pool, Static Pool, and Current IP Mappings.  That last one will show you the currently connected clients.

If you've never noticed those submenus before, you might want to re-check all the tab/button combinations because they're used on a lot of config screens in D-Links. The Filters button on the Advanced tab has the MAC access control lists... there are 2 options - accept and reject, but if it's set to disable instead, it's NOT the MAC filter keeping the laptop out... there's a submenu in the Filters section (WLAN Partition) with options similar to the Linksys 'AP Isolation' option, but it can be set to block networking between wireless and/or wired clients too.


Can you delete the wireless network from the vista profiles, then see if the network shows up in View Available?

Oh - and is it using the windows wireless zero config service, or a 3rd party connection manager?
0
 
LVL 1

Author Comment

by:findingsolutions
ID: 22937719
Right, let's see if I can answer all the questions...
The user is in another part of the country today so I can't test from his notebook but I can go through all the settings and hope when he returns it works...

On his notebook yesterday I deleted all wireless networks including other networks he frequents. He'l have to reconnect to them later but htis is the most important one.
He is using indows to configure wireless networks. There is no application to do this. I went looking for one in the hope of enabling it so that I could connect.

MAC filtering on the AP is disabled. I tried enabling it and the disabling again in case it had glitched.

On the advanced tab I found the IP list. There's nothing in t. Dynamic pool is disabled. Static pool is disabled. Current IP - nothing in list. Just says Binding MAC Adress.

I did find a list of attached computers under the status button. Can't make any changes there as it's just a status screen. Shows the current 4 PC's that are here with their MAC address and signal Strength. Signal strength is nothing under 85% so it's not a signal strength issue. Also there are 2 AP's acting as relay stations which are literally on the other side of the room so we have a very powerful wireess network here.

I have gone through again checking all the newly found options I can select. There aren't many, only 1 or 2 on the other screens. Nothing that is set or can help me. All that is set on this wireless AP is the SSID, WEP Encryption 128bit and any other default settings. Most items are set to disable.

I'm going to try a firmware uograde as it is version 2.20eu. Althouhg this shouldn't be a problem as they have been using this AP with this notebook for nearly 6 months with no problems.

The only envronmental change that happened recently is the internet connection was changed from ADSL to Diginet so the router changed and a 2008 server was setup on the network. The Diginet router is the DHCP server and not the 2008 server. The Cisco router attached to the Diginet line is a Cisco 2800 series. It has caused a few little glitches on the network - randomly blocked internet acess for 3 of the connecting machines. 1 - the desktop that had this problem. 2 - the MD's notebook. 3 - my notebook. A power cycle fixes that. I have been assured by the ISP that this won't affect a unit not seeing the SSID.
0
 
LVL 1

Author Comment

by:findingsolutions
ID: 22937873
It appears there isn't a newer firmware version on the D-link site.
0
 
LVL 44

Expert Comment

by:Darr247
ID: 22939153
2.11 is the newest version on the americas site.

If you have multiple 2100AP's you might benefit from using the AP Manager software. Its interface is a bit different than the web GUI, and may make keeping track of them easier. Most of them allow telnet CLI access too (you can also specifically disable that), though available commands differ greatly between the Atheros and Broadcom based units (I believe the G-only models like the 2100 use Broadcom chipsets). The AP Manager software is on the CD that comes with the AP, or you can download it from the D-Link site.
0
 
LVL 1

Author Comment

by:findingsolutions
ID: 22947971
Thanks Darr247, I'll try download that and see about using it. I've been using the web interface to manage the APs. Generally they just sit there minding their own business until i have funnie slike this happening.

Furtehr details I have found out and changes on the network.
The AP's get their power from the same circuit as the lights. So every evenig the units are switched off when the office lights are switched off. In the morning they are switched back on. Basically they are reset on a daily basis.

I have moved DHCP  and DNS from the Cisco router to the 2008 server due to other issues on the network. This seems to have made a few things more stable but the problem user didn't show up to work today.  Hopefully he's in tomorrow and I can test further.
0
 
LVL 44

Expert Comment

by:Darr247
ID: 22956984
> The AP's get their power from the same circuit as the lights. So every evenig the
> units are switched off when the office lights are switched off. In the morning they
> are switched back on. Basically they are reset on a daily basis.

That sounds beneficial from a security standpoint - Nobody can even try to break in while the APs are turned off. :-)
0
 
LVL 1

Author Comment

by:findingsolutions
ID: 22957650
Well it seems the problem is fixed.

The user came in this morning and automatically connected to the network with no problems. It's working fast and stable (better then it has for a while)

Appears it may have been related to the Cisco router providing DHCP. The ISP checked the logs and found multiple instances of IP address conflicts as well as some comment they made about the ARP information (went over my head). Seems the router was assigning and IP, the client would disconnect at some point and because it's all wireless the router couldn't track the IP's so it reassigned the same IP to other clients.

Now that DHCP is on the server and the server provides the DHCP, we don't have this problem. Not totally convinced of all this info as I did try assigning static IP's outside of the DHCP range. But perhaps the explaination of the ARP that I didn't quite get would explain something more related to MAC addresses (hence changing the first problem pc's lan card fixed the issue.)

Your help has been tremendous, thanks guys.
0
 
LVL 1

Author Closing Comment

by:findingsolutions
ID: 31515488
Thanks for the help guys, although my ISP esentially provided the solution I have split the points for everyone for putting in the effort to assist. Greatly appreciated. Hopefully this thread will assist other people in knowing what direction to look in if they have the same problem.
0
 
LVL 1

Expert Comment

by:ZJuanS
ID: 22959383
Thanks, I am glad your problem has been Fixed!!!!!!
0

Featured Post

 The Evil-ution of Network Security Threats

What are the hacks that forever changed the security industry? To answer that question, we created an exciting new eBook that takes you on a trip through hacking history. It explores the top hacks from the 80s to 2010s, why they mattered, and how the security industry responded.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Need WiFi? Often, there are perfectly good networks that don't have WiFi capability - and there's a need to add it.  - Perhaps you have an Ethernet port into a network but no WiFi nearby. - Perhaps you have a powerline extender and no WiFi at the…
DECT technology has become a popular standard for wireless voice communication. DECT devices are not likely to be affected by other electronic devices and signals because they operate in a separate frequency-band.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…
Suggested Courses
Course of the Month13 days, 8 hours left to enroll

749 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question