[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1056
  • Last Modified:

crystal reports selection criteria

the first report that I set the .selectionformula property

.SelectionFormula = " WHere policyid = " & Session("policyid")

and the report prints correctly, then I select a different customer, the Session variable gets reset, (I'm sure) but the report outputs the report from the first PolicyID.

I've tried many times, selecting customers in many different orders, but the report always prints with the first policyid

Is there something I need to reset in the report to get it to accept the new .SelectionFormula ?
0
jbh_blue
Asked:
jbh_blue
  • 2
  • 2
1 Solution
 
mlmccCommented:
I assume if you use different policy id on the first run you get the correct data.

Crystal has a bad habit of caching the data.  Make sure IE and IIS are clearing the cache between runs.

mlmcc
0
 
jbh_blueAuthor Commented:
Yes, it is correct on the first time and the session vars which have the key are clear and reset correctly before the next try.

I tried

Response.Cache.SetCacheability(HttpCacheability.NoCache)

but got the same results

Thanks,
0
 
mlmccCommented:
I don't know what the settings are, I know from what I have read on this site that it is an issue.

You might ask in the IIS and Web Browser froums

mlmcc
0
 
jbh_blueAuthor Commented:
thanks, because of licensing issues that I just found out about, I'm moving my reporting back into vs2008 using rdlc reports
thanks,
0

Featured Post

Upgrade your Question Security!

Add Premium security features to your question to ensure its privacy or anonymity. Learn more about your ability to control Question Security today.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now