Boot problems only when 2nd HD is turned on

Posted on 2008-11-11
Last Modified: 2013-12-01
My motherboard recently crashed.  I had an HP motherboard installed.

I am running Ubuntu dapper on the first of two removable HDs.  I use the second HD for backup and storage.

The only way I can get HDA to boot properly is to turn off HDB.

When both HDs are turned on and it boots up, it has a long pause at "Files needed to boot". About half of the time it gives me hda1 errors. Every so often it will run a check on hda1 files. a couple of times it told me to run fsck. When It does run I get all kinds of strange errors (mainly keyboard and video errors).

I ran testdisk on HDA and got the following:

Disk /dev/hda - 38166 MB - CHS 77545 16 63

Check current partition structure

Partition Start End Size in sectors
1 * Linux 0 1 1 74587 7 63 75184137
Warning: Bad ending head (CHS and LBA don't match)
2 E extended 74587 8 1 77535 14 63 2972025
Warning: Bad starting head (CHS and LBA don't match)
5 L Linux Swap 74587 9 1 77535 14 63 2971962
Warning: Bad starting head (CHS and LBA don't match)

(Seems to me that HD partition and keyboard are two different issues. All I can tell you is that I get keyboard and video errors when I boot with HDB turned on and I don't when I boot with HDB off.)

I even changed out the keyboard but got the same errors.

When I try to run kate (my favorite text editor) from the terminal with the 2nd HD turned on I get the following errors:

X Error: BadDevice, invalid or uninitialized input device 168
Major opcode: 145
Minor opcode: 3
Resource id: 0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 168
Major opcode: 145
Minor opcode: 3
Resource id: 0x0
Failed to open device
kio (KMimeType): WARNING: KServiceType:ffers : servicetype ThumbCreator not found
QObject::disconnect: Unexpected null parameter
QFile:pen: No file name specified

Kate will not start.

When I get it to boot with both HDs turned on I can open a terminal, but when I try to type an entry  it acts as if the F1 key is stuck.  When you press any key the "File" menu drops down instead of recognizing the keystroke.

I cannot  check HDB with testdisk beause when I boot up with HDB turned on I get keyboard errors that prevent me from running anything from the terminal.

I can boot up from a rescue disk with both HDs turned on and don't seem to have any problems.

I ran fsck from the rescue disk and it came up hda1 is clean!

I also ran testdisk from the rescue disk and it says I need to run MBR from testdisk!!!. This is getting kind of scary.  I certanly don't want to have to start messing with master boot records!!!

Any ideas of how to fix the problem? If you have any suggestions, please be VERY specific. I am afraid I am geting into uncharted areas when it comes to partitions. It would be very easy for me to blow up the whole thing and have to start over from scratch. Not fun to even think about.

I backed up critical data files and pictures on an external laptop, but still would not like to have to rebuild from scratch.

I found a post on another forum with the same testdisk error message (Warning: Bad ending head (CHS and LBA don't match).  They solved the problem by enabling ACPI in the BIOS.  I tried that and it worked for a while and then went back to the same behavior.

Thanks for your help.           
Question by:KenSpeedie
    LVL 31

    Accepted Solution

    It gives the impression, superficially, that you have messed up the Master/Slave relationship here. Removable hard drives: how "removable"? The "hda" indicates an IDE drive, is that correct? Verify that you use the correct identification scheme for the drives: Master/Slave-jumpering, or Cable select jumpering with the correct cable. Not all controllers support Cable select.

    Author Closing Comment

    "Removable" HDs are each contained in individual trays that side in and out of the HD bays on the deskktop.  Each has it's own key so that you can turn it on or off.

    I had used the "cable select" jumper settings.  I used that setting so that I could use either HD in either slot and let the cable select which one to boot from.  Did not know that the new HP motherboard would not recognize "cable select".

    Reconfigured jumpers and everything runs like it should.

    I still get testdisk error (Warning: Bad ending head (CHS and LBA don't match) on hda, but it seems not to cause any problems.

    I am not going to worry about it until it gives me a problem.

    Thanks for you help.


    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    6 Surprising Benefits of Threat Intelligence

    All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

    I have purchased two new systems and both are now Universal Extensible Firmware Interface (UEFI) based. UEFI is replacing BIOS for the desktop PC. It is a Linux based firmware with enough robustness it can communicate with a website without loading …
    The purpose of this article is to show how we can create Linux Mint virtual machine using Oracle Virtual Box. To install Linux Mint we have to download the ISO file from its website i.e. Once you open the link you will see …
    This video discusses moving either the default database or any database to a new volume.
    In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor ( If you're interested in additional methods for monitoring bandwidt…

    760 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    11 Experts available now in Live!

    Get 1:1 Help Now