• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 397
  • Last Modified:

have to type in index.html after domain or we get an error

Hello,

We are having to type in "index.html" at the end of our domain or we get a 403 error:

How do we change it so that we can just type in our domain and get to our site:

www.queenbedroomset.net
0
weikelbob
Asked:
weikelbob
  • 7
  • 6
  • 5
  • +2
4 Solutions
 
3asfouriehCommented:
Can you please give more info ?
Like :
What are you hosting on for example ?
0
 
weikelbobAuthor Commented:
0
 
kdtreshCommented:
Make sure index.html is listed in the DirectoryIndex line of httpd.conf.

It should look something like this: DirectoryIndex index.php index.cgi index.html default.html

An amble through Apache config: http://www.onlamp.com/pub/a/apache/2000/03/02/configuring_apache.html
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
kdtreshCommented:
I believe you also need 755 permissions (rwx r-x r-x) on all the folders and 644 (rw- r-- r--) on all the files in those folders. Whatever account apache is running under needs to be in the group for those folders and files as well.
0
 
weikelbobAuthor Commented:
This is shared hosting on 1and1. I don't have access to the server files.

@kdtresh:

I changed the file attributes on what files I have access to with no luck.

Is this a problem for the hosting company to fix?
0
 
3asfouriehCommented:
By more info i meant :
Hosting machine OS : Linux/Windows/BSD ???
Server : Apache ? Mini httpd ?
0
 
kdtreshCommented:
Try creating a folder in your webspace and in the 1&1 domain configuration point your domain to that folder, rather than to your main webspace.
0
 
Andrew DoadesCommented:
You can also try to rename the file to index.htm (without the l on the end)
0
 
kdtreshCommented:
index.html should work, here's a link from the FAQs:

http://faq.1and1.com//domains/using_and_setting_up_the_domain_/4.html

Here are the accepted file names and their priorities on Linux Shared Hosting Packages:

index.html
home.html
index.htm
welcome.html
default.htm
index.php3
index.shtml
home.shtml
index.cgi
home.cgi
home.wml
index.wml
index.php4
home.php4
0
 
weikelbobAuthor Commented:
OK. More information.

I placed an image inside an empty folder, repointed the domain to that folder, and I still get the 403 - Forbidden error even if I CMOD the folder and file to 777

What could be causing this?
0
 
kdtreshCommented:
It might be something on their end, I'd suggest you call their support at 1-877-GO-1AND1.
0
 
eszaqCommented:
If initially you were able to access homepage after just adding index.html to your domain name, then all you needed to do - have this file name as default homepage in your .htaccess file. Change the DirectoryIndex to read

DirectoryIndex /index.html

0
 
eszaqCommented:
If you are unable to edit your master configuration files, you can use this directive from .htaccess. Just edit the .htaccess file located in your main HTML directory. If you do not have this file, feel free to create it!

To change the default page, either edit the existing DirectoryIndex line or add the following:

    DirectoryIndex index.shtml index.html

This will make index.shtml the default page.

By using a .htaccess file in a subdirectory, you can specify a different default page for that one directory without affecting the rest of your site.
0
 
weikelbobAuthor Commented:
Thank you.

Except I need the default domain to be

www.diningroomset.org

for SEO purposes,

Which is different in the search engine's eyes than

www.diningrommset/index.html
0
 
weikelbobAuthor Commented:
oops, I misspelled. I meant

www.diningroomset.org/index.html
0
 
eszaqCommented:
I am not sure how your last comment changes the initial question. You wanted to get rid of error 403, right? That is: when type into browser location bar just domain name without specifying name of the file  - index.html would open.
If this is the problem, then creting .htaccess file in your root directory with line that reads
DirectoryIndex index.html
should take care of the issue.
0
 
kdtreshCommented:
What did 1&1 support say?
0
 
weikelbobAuthor Commented:
They said it was my htaccess file.

I've attached the current htaccess code.

Please let me know what to change.
############################################
## uncomment these lines for CGI mode
## make sure to specify the correct cgi php binary file name
## it might be /cgi-bin/php-cgi
 
#    Action php5-cgi /cgi-bin/php5-cgi
#    AddHandler php5-cgi .php
#    php_flag cgi.fix_pathinfo on
 
############################################
## this line is specific for 1and1 hosting
 
    #AddType x-mapp-php5 .php
    #AddHandler x-mapp-php5 .php
 
############################################
## default index file
 
    DirectoryIndex index.php
 
<IfModule mod_php5.c>
 
############################################
## adjust memory limit
 
    php_value memory_limit 64M
    php_value max_execution_time 18000
 
############################################
## disable magic quotes for php request vars
 
    php_flag magic_quotes_gpc off
 
############################################
## enable resulting html compression
 
    #php_flag zlib.output_compression on
 
###########################################
# disable user agent verification to not break multiple image upload
 
    php_flag suhosin.session.cryptua off
 
</IfModule>
 
<IfModule mod_security.c>
###########################################
# disable POST processing to not break multiple image upload
 
    SecFilterEngine Off
    SecFilterScanPOST Off
</IfModule>
 
<IfModule mod_deflate.c>
 
############################################
## enable apache served files compression
## http://developer.yahoo.com/performance/rules.html#gzip
 
    # Insert filter
    #SetOutputFilter DEFLATE
 
    # Netscape 4.x has some problems...
    #BrowserMatch ^Mozilla/4 gzip-only-text/html
 
    # Netscape 4.06-4.08 have some more problems
    #BrowserMatch ^Mozilla/4\.0[678] no-gzip
 
    # MSIE masquerades as Netscape, but it is fine
    #BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
    # Don't compress images
    #SetEnvIfNoCase Request_URI \.(?:gif|jpe?g|png)$ no-gzip dont-vary
 
    # Make sure proxies don't deliver the wrong content
    #Header append Vary User-Agent env=!dont-vary
 
</IfModule>
 
<IfModule mod_ssl.c>
 
############################################
## make HTTPS env vars available for CGI mode
 
    SSLOptions StdEnvVars
 
</IfModule>
 
<IfModule mod_rewrite.c>
 
############################################
## enable rewrites
 
    Options +FollowSymLinks
    RewriteEngine on
 
############################################
## you can put here your magento root folder
## path relative to web root
 
    #RewriteBase /magento/
 
############################################
## workaround for HTTP authorization
## in CGI environment
 
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
 
############################################
## always send 404 on missing files in these folders
 
    RewriteCond %{REQUEST_URI} !^/(media|skin|js)/
 
############################################
## never rewrite for existing files, directories and links
 
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-l
 
############################################
## rewrite everything else to index.php
 
    RewriteRule .* index.php [L]
 
</IfModule>
 
 
############################################
## Prevent character encoding issues from server overrides
## If you still have problems, use the second line instead
 
    AddDefaultCharset Off
    #AddDefaultCharset UTF-8
 
<IfModule mod_expires.c>
 
############################################
## Add default Expires header
## http://developer.yahoo.com/performance/rules.html#expires
 
    ExpiresDefault "access plus 1 year"
 
</IfModule>
 
############################################
## By default allow all access
 
    Order allow,deny
    Allow from all
 
############################################
## If running in cluster environment, uncomment this
## http://developer.yahoo.com/performance/rules.html#etags
 
    #FileETag none

Open in new window

0
 
eszaqCommented:
Once more. It should be:
DirectoryIndex index.html

You have:
DirectoryIndex index.php
0
 
weikelbobAuthor Commented:
I see.

Yes, I just fixed it.

Thank you guys.

0

Featured Post

How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

  • 7
  • 6
  • 5
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now