How to disable scrollbars (vertical and horizontal)?

I am new to Dojo 1.2.
 I am able to use the DataGrid for displaying contents of an array.
How can I turn off the scrollbars (horizontal and vertical)?
In other words, the scrollbars should display when there are 20 or more rows being displayed?


A snippet of my markup is as follows:
 
<div dojoType="dijit.layout.ContentPane" region="center">
     <div dojoType="dojox.grid.DataGrid" id="_grid"
          elasticView="1" query="{id: '*'}"
          rowsPerPage="20" store="mydatastore"
          structure="mygridlayout" rowSelector="0px">
    </div>
</div>

Open in new window

cwatkinsAsked:
Who is Participating?
 
justinbilligConnect With a Mentor Commented:
I don't think you can turn off the scrollbars for the page but you an encapsulate the div inside another div for scrolling. You'll need to adjust the size of your outer div to fit your needs.
<div style="overflow:scroll" >
<div dojoType="dijit.layout.ContentPane" region="center">
     <div dojoType="dojox.grid.DataGrid" id="_grid"
          elasticView="1" query="{id: '*'}"
          rowsPerPage="20" store="mydatastore"
          structure="mygridlayout" rowSelector="0px">
    </div>
</div>
 
 
</div>

Open in new window

0
 
cwatkinsAuthor Commented:
Create the Grid within an addOnLoad function, the rows rendered to the expected size. Calling the sizeChange() method forced the Grid to recalculate the size.

var grid = new dojox.Grid({autoHeight:true,id: "gridCardDef",model: model, structure: layout},dojo.byId("grid"));      
grid.sizeChange();
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.