Logon script is not running from the \\servername\netlogon directory.

I have several different logon scripts for various departments.  I use a simple .bat file to map the appropriate drives and other various functions.  I have made some significant changes lately and I changed the script, but now it does not run at logon.  I have all AD accounts , under the profile tab using JUST the longon.bat, but that isn't working.  I have also tried putting the full path to the file \\severname\netlogon\logon.bat.  This did not help either.  And help would be appreciated!
DevilDog7856Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Rob WilliamsCommented:
Verify the user has read privileges.
As a test, from a problematic workstation, logged in as the user, within a DOS window, try running the script using the same path \\severname\netlogon\logon.bat and see if any errors are displayed
If the script runs but you cannot see the output, you can insert a pause statement any were in the batch file to allow you to diagnose.
0
DevilDog7856Author Commented:
The users have the correct permissions.  If I run the script while anyone is logged in the script runs correctly.  I just can't get it to run when the users logon to the machine each time?
0
Rob WilliamsCommented:
Perhaps it is a DNS or timing issue.
- I assume the PC points ONLY to your Internal DNS server/s for DNS and not an outside server such as the ISP's?
- Try running NetDiag on the problematic PC to see if it exposes any issues:
http://www.lan-2-wan.com/Diag-FAQ.htm#q1
- Also try gpresult to see if any policy issues:
http://www.microsoft.com/windowsxp/using/setup/expert/gpresults.mspx
- There can exist a 'race' condition where the network is not contacted before logon completes and policies and logon scripts are not applied. To address this try implementing the following policies. You will likely need to run from the PC   gpupdate /force    if you are having problems with GPO's being applied.

Computer configuration | Administrative templates | System | logon | always wait for the network at computer startup and logon

User configuration | administrative templates | system | scripts | run logon scripts synchronously
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
DevilDog7856Author Commented:
The 2 GPO settings you mentioned was the issue!  Thanks for the help!
0
Rob WilliamsCommented:
Thanks DevilDog7856. Glad to hear it is working.
Cheers !
--Rob
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.