HOw do i enable RUN-AS in GPO

i'm wondering where i can enable the "Run-as" command in a GPO.
Thanks
ArrowstreamAsked:
Who is Participating?
 
Joseph DalyConnect With a Mentor Commented:
The service that needs to be started for "run as" is the secondary logon service. If this is not running you can not hold shift to get the run as box.

This service start type can be controlled through group policy at the following location as seen in the pic.


Image removed at Expert's request (sensitive information) by Netminder 12 Nov 2008

Open in new window

0
 
Joseph DalyCommented:
Can you give a little more info on what your trying to do? This will help us determine the best way to assist.
0
 
sk_raja_rajaCommented:
why do you need this ?
0
Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

 
MightySWCommented:
Ditto, are you trying to do it on startup or shutdown?
0
 
ArrowstreamAuthor Commented:
my users are set up as Users on their work stations and i have to log them out when i need to install various apps...so i'de like to have the ru-as command enabled so i can just use my UN/PW.
0
 
Joseph DalyCommented:
Group polcicy gives you the ability to push out applications using software installation rules. These install under the local system account and therefore do not need any process elevation.

I dont know if this is what you are trying to do but I believe a lot of people utilize this functionality. Once drawback is that it can only push out MSI's.
0
 
Joseph DalyCommented:
I think i might have read your last statement wrong. If you want to enable run as you would need to set the "secondary logon" service to start automatically. This would allow the run as by hoilding the shift key and right clicking.
0
 
ArrowstreamAuthor Commented:
no it's not what i'm looking for...i just want to have the feature enabled on all user computers..i thought pushing it out via a GPO would be my best bet.
0
 
Joseph DalyCommented:
The services can be modified in the GPMC under computer configuration, security settings, windows settings.
0
 
Joseph DalyCommented:
Ok if you want run as enabled then setting the secondary login to automatic will take care of that for you.
0
 
MightySWCommented:
Yes, what he is saying is that it is there, all you have to do is right click on any installable app and hold down shift and select run as.  

If that is not it then what is the 'feature' that you are looking for?  You want it on perpetually so if a user or you selects Run as then it will automatically log you in?

I know that this is a tall order.  I don't think that can be done with standard templates.  You would have to script that out.
0
 
ArrowstreamAuthor Commented:
Sorry where is it?
i'm looking in gp and still can't find it...sorry
0
 
sk_raja_rajaCommented:
you cannot find it on Group policy
0
 
ArrowstreamAuthor Commented:
yes...what's the full path to it.
Thanks
0
 
MightySWCommented:
Sorry, that doesn't help
0
 
sk_raja_rajaCommented:
Refere these KB's

http://support.microsoft.com/kb/294676
http://support.microsoft.com/kb/325859

These KB's have procedures,let me know if you have any queries.
I will be really surprised if "run as" option is available in group policy :)
0
 
ArrowstreamAuthor Commented:
yeah those are great articles on how to do it on locally...there must be a way to enable it via GP.
i really don't want to walk to each machine and enable the service EVERY machine.
am i looking for something that doesn't exist?
0
 
Joseph DalyCommented:
Look above your last post.
0
 
McKnifeCommented:
As it was said before: The services can be modified in the GPMC under [some policy] computer configuration, security settings, windows settings [ - services - secondary logon]. This service needs to be enabled on any workstation if it ain't already, so check it out. If enabled and some .exe/some link still does not offer runas, use rightclicktogether with shift (as said before).

No points, please.
0
 
McKnifeCommented:
wow... 7 postings happened in the meantime :)
0
 
ArrowstreamAuthor Commented:
Excelent!
0
 
MightySWCommented:
why wouldn't this be enabled by default?  
0
 
sk_raja_rajaCommented:
I think you should follow "xxdcmast"...just try to enable the secondary logon service in the group policy and do remember to make it automatic........Once this policy is applied in your domain you should be able to do "run as"
0
 
ArrowstreamAuthor Commented:
Thank you guy!
you have saved me so much time!
0
 
sk_raja_rajaCommented:
glad you found the fix soon.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.