ftp from windows 2003 server to vsftpd on redhat AS3

Posted on 2008-11-11
Last Modified: 2012-05-05

I am having problem with ftp transfer from  Windows 2003 servers to a RedHat AS3 server. I have tried from several Win2k3 servers and it fails from all of them.

The file transfers, but user rights on the files are blank:

----------    1 root     root            9 Nov 11 23:46 asdf

I have tried from XP and win 2k and there are no problems with those OS.

Anyone has any idea whats wrong?

Hans Bent
Question by:hansaa
    LVL 68

    Expert Comment


    could it be that you accidentally set an umask of 777 somewhere (possibly on the target host)?


    Author Comment

    Thanks for quick response,

    I use the same user and uploads to the same folder from win 2k, xp and win2k3 and the problem only apears om the win2k3 server. (tried different folders with same result). Umask in vsftpd.conf is set to 066.
    LVL 68

    Expert Comment

    I heard somewhere that there are clients which are modifying the permissions on upload.
    Which client do you run? win2k3 native? I don't have a win2k3 machine, so I can't look for myself.



    Accepted Solution


    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    How to improve team productivity

    Quip adds documents, spreadsheets, and tasklists to your Slack experience
    - Elevate ideas to Quip docs
    - Share Quip docs in Slack
    - Get notified of changes to your docs
    - Available on iOS/Android/Desktop/Web
    - Online/Offline

    INTRODUCTION The purpose of this document is to demonstrate the Installation and configuration of the Data Protection Manager product. Note that this demonstration was prepared on the basis of Windows OS is 2008 R2 and DPM 2010. DATA PROTECTI…
    When you upgrade from Windows 8 to 8.1 or to Windows 10 or if you are like me you are on the Insider Program you may find yourself with many 450MB recovery partitions.  With a traditional disk that may not be a problem but with relatively smaller SS…
    Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
    Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.

    760 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    7 Experts available now in Live!

    Get 1:1 Help Now