Offer Remote Assistance XP the HelpAssistant does not log in

When trying to Offer Remote Assistance to an XP machine the "HelpAssistant" does not login properly.  There is nothing different in the eventlog vs. a machine that works.   We've noticed this happening after updating the machine offering RA to XP SP3.  Is anyone else seeing this?

I've already tried recreating the user with a batch script that contains this:
------
net stop rdsessmgr
:: From http://blog.netnerds.net/2006/12/remote-assistance-fixing-offer-remote-assistance/
reg add "HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server" /v fInHelpMode /t REG_DWORD /d 0x0 /f
:: This reinitializes service and will recreate HelpAssistant user.
sessmgr.exe -service
net start rdsessmgr
-------
Image.jpg
LVL 1
nummagumma2Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

pablovrCommented:
I hope it helps:

How to configure a computer to receive Remote Assistance offers in Windows Server 2003 and in Windows XP:
http://support.microsoft.com/default.aspx?scid=kb;en-us;301527
nummagumma2Author Commented:
Thanks for the comment.

We have been using Offer RA for 5 years without incident until we started upgrading the machines that offer RA to SP3.  The receiving machines are mostly SP2 with some SP3.   If we try to Offer RA to a problematic computer using an SP2 machine it works fine.

It's definitely something about SP3 on the Offering machine.
Rob WilliamsCommented:
Hi nummagumma2. Though I don't believe it applies to your problem,you haven't had a lot of response so I thought I would mention the following couple of items.

-Remote Desktop and Remote Web Workplace are known to fail (but differently) after SP3 is applied due to some enhanced security "features" which blocks the active-X add-on required for terminal service connections, on the client/connecting machines.
There are 2 ways to remedy.
1) In most cases you can; go to Internet Explorer | tools (on the menu bar) | Internet options | programs | manage add-ons | in the drop down list select: add-ons current loaded in Internet explorer | look for "terminal services client" | see if set to disabled, if so enable (may not be present
2) Only perform the following after backing up the registry. If you are not familiar with editing the registry be aware doing so incorrectly can damage your system. Delete the following 2 registry keys {number string may vary}:
HKCU\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{7390f3d8-0439-4c05-91e3-cf5cb290c3d0} HKCU\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{4eb89ff4-7f78-4a0f-8b8d-2bf02e94e4b2)

-There were two recent DNS patches that were released that result in blocked ports on some systems. This is most often systems with ISA server but has been reported elsewhere. You may want to verify if the patches were install. If so perhaps try the registry changes in the following article.:
http://blogs.technet.com/sbs/archive/2008/07/17/some-services-may-fail-to-start-or-may-not-work-properly-after-installing-ms08-037-951746-and-951748.aspx
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

nummagumma2Author Commented:
This was solved this past week by MIcrosoft supplying an as-yet-unreleased hotfix.  " Enhancements" to SP3 affected how OfferRA worked on machines with multiple NICs - in this case machines that have a virtual Cisco adapter.  If you leave this posted I'll be able to reply to anyone else that needs the file, until MS posts it or adds it to the next rollup.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
XellizCommented:
Numma...where can I get this file?  I seriously need to be able to use RA again since we have about 30 problem children around the world.
nummagumma2Author Commented:
Xelliz - sorry that i didn't see your post.  the KB # on the hotfix we were given was 957070 - and appears to have been posted, finally:  http://support.microsoft.com/kb/957070
XellizCommented:
Its ok...I found it a few hours after I posted, however even applying this hotfix to my test computer resulted in no change.  You say this hotfix worked for you though?
nummagumma2Author Commented:
I don't know if the hotfix that is posted is the same as the one that I was given, with the same KB number.  I received it prior to the KB article having been written... however, I got the fix after calling into Microsoft PSS.
 
nummagumma2Author Commented:
Xelliz, still having this problem?   I can send you the file I received, if it helps.
XellizCommented:
It seems to have resolved itself...of course, now that I've asked our help desk coordinator I'll likely need those files.  If you still have them that would be great.
nummagumma2Author Commented:
Here's what I was sent.
WindowsXP-KB957070-x86-ENU.zip
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.