Setup of Cisco Router With NAT

Hello Everyone.
I am working on a Cisco Router 2621 to replace our production DMZ router. I have very little skill in setting up routers with Cisco IOS. I have only done these in college.
Can someone be so kind and assist me with setting it up I know that we use B8ZS on the wan side?
The following objects will need to be created:
Basic Global Configuration (Domain, DNS, Timing)
WAN Configuration
1 Interface configuration including 13 Nat'd adresses.

If I have forgotten something, then please let me know. I will continue to post updates to this thread as I search more documentation using google. I am determined to figure this out tonight. I would be glad if anyone can come up with documentation, or other resources, that wil provide me the support needed.
scotv453Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

bkepfordCommented:
It depends on what your T1 module isif it has the CSU/DSU and just plugs into a serial port or has the built on CSU/DSU.
Is this just an Internet T1 or a point to point T1?
The default timing is to get the timing from the line. You can keep this unless you have a Point to point where one side must be changed to internal. the command is in the config although if it is setup it may not show up because "clock source line " is the default and any default setting don't show up in the config.
lastly some T1 module will have you configure directly on the Serial interface
router(config)# interface serial 0
router(config-if)# service-module t1 clock source line
router(config-if)# service-module t1 framing esf
router(config-if)# service-module t1 linecode b8zs
router(config-if)# service-module t1 timeslots 1-24 speed 64

ip domain-name mycompany.com
ip name-server <DNS 1 IP> <DNS 2 IP>
 
card type t1 0 0 
 
controller t1 0/0
 framing esf
 linecode b8zs
 clock source line
 channel-group 1 timeslots 1-24 speed 64
 
 
interface Serial 0/0:1
description WAN Interface
ip nat outside
interface fastethernet 0/0
ip address 192.168.0.1 255.255.255.0
ip nat inside
 
ip nat inside source list 100 interface serial 0/0/0 overload
ip nat inside source static 192.168.0.10 <public IP 1> extendable
ip nat inside source static 192.168.0.11 <public IP 2> extendable
ip nat inside source static 192.168.0.12 <public IP 3> extendable
ip nat inside source static 192.168.0.13 <public IP 4> extendable
ip nat inside source static 192.168.0.14 <public IP 5> extendable
ip nat inside source static 192.168.0.15 <public IP 6> extendable
ip nat inside source static 192.168.0.16 <public IP 7> extendable
ip nat inside source static 192.168.0.17 <public IP 8> extendable 
ip nat inside source static 192.168.0.18 <public IP 9> extendable
ip nat inside source static 192.168.0.19 <public IP 10> extendable
ip nat inside source static 192.168.0.20 <public IP 11> extendable
ip nat inside source static 192.168.0.21 <public IP 12> extendable
ip nat inside source static 192.168.0.22 <public IP 13> extendable
 
access-list 100 permit ip 192.168.0.0 0.0.0.255 any

Open in new window

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
scotv453Author Commented:
Thanks for the info. Sorry I didn't mention everything in the begining. I already had a netopia in place but it doesn't default to CLI as it is menu driven, I knew what was needed, but didn't know how to convert into CLI format that the IOS can understand.

You have anwered my line encoding question as I couldn't figure it out, but it works with whatever default you have. I will change that to be on the safe side. The router has in embedded CSU/DSU WIC. The only part I configured with clock is making sure it was getting this from the line. I figured out most of the nat by myself, but I didn't do the extendable part. I will research the different methods of natting to get in understanding of how it works. Thanks so much and I implimented almost everything you sent which works great.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.