server can ping but can't browse internet

We recently moved a network from one location to another. Everything was working fine at the old location. At the new location we have a different ISP and I have amended the firewall (separate unit to server) and DNS accordingly.  All clients that get DHCP from the server have no problem in browsing the internet.  The server can ping and resolve names from a command prompt. But the server can't browse to anything on the internet.  
jamesitAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Rob WilliamsCommented:
Have you re-run the CEICW (server management | internet and e-mail | connect to the internet) since relocating? You should. This will update the DNS forwarders and gateway information.
0
jamesitAuthor Commented:
Yes I have already run the ICW and the Remote Access wizard twice. Still no luck.
0
Rob WilliamsCommented:
Definitely sounds like a DNS issue. You can confirm by testing if you can access a site such as Google using the IP  http://64.233.187.99/  
-If that works it is DNS related. Make sure the server points only to itself for DNS, and the ISP's DNS has been added to the DNS forwarders (should have been done by the CEICW).
-If it doesn't work, it may be malware related and you have WinSock corruption.
-Also if 2 NIC's make sure the LAN NIC does not have a gateway.
0
Cloud Class® Course: Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

jamesitAuthor Commented:
-Tried to access the IP address, but still no.
-Only 1 nic installed
-Should I run some software to find the malware? ie. hijackthis??
-How do I fix winsock corruption?
Thanks.
0
Rob WilliamsCommented:
1 NIC so I assume ISA server is not installed?

One other thought, have you installed updates lately? There are 2 recent DNS patches that could cause this issue. The following link outlines the issues and repair by adding manual registry entries. See if the updates are installed, and if so follow through with the reg changes:
http://blogs.technet.com/sbs/archive/2008/07/17/some-services-may-fail-to-start-or-may-not-work-properly-after-installing-ms08-037-951746-and-951748.aspx

As for the Winsock fix (usually, but not always caused by malware), there are utilities to repair this for you, but I have only seen them for non-server O/S's, I don't know that I would recommend them. Microsoft outlines the manual repair method:
http://support.microsoft.com/default.aspx?kbid=811259
0
jamesitAuthor Commented:
No the DNS patches were not installed so I skipped that one.

With the Winsock fix on the Microsoft site, I couldn't see any reference of how to check on SBS, it only referred to XP, Vista, etc.  So I installed the XP tools anyway and ran the netdiag, it said the Winsock test passed.

I went to try the second manual method on the Microsoft site, but when I type Msinfo32, it says to start the Help & Support service, but that service doesn't exist in the services list???
0
jamesitAuthor Commented:
OK, I got the helpsvc installed and checked the msinfo32 according to the microsoft article and determined that Winsock is fine.
0
Rob WilliamsCommented:
Very bizarre. Can you access any local web page to see if IE is working such as the SBS http://companyweb  ?
0
jamesitAuthor Commented:
No, I can't even get to the companyweb.  Went into IIS, right-clicked on the companyweb and clicked browse, still nothing.
0
Rob WilliamsCommented:
Sounds like IE is "broken". Does the browser open but just not display a page? If so, one thought, verify under IE's tools / Connections that a proxy server is not configured.
0
jamesitAuthor Commented:
Hi,
No, there isn't a proxy server on the network and it isn't configured in IE.  I installed firefox also and that has the same problem
?!?!?!?!?!  
0
Rob WilliamsCommented:
Can you open anything local with a browser, perhaps something from C:\Inetpub\ClientHelp\______.htm? or, even a jpg?
If so it is some sort of connection issue, if not browsing is "broken". Either way I am stumped.
0
jamesitAuthor Commented:
Yes, I can open those files with a browser no problem. If browsing is "broken" what might the steps be to fix ?  I have have some malware checkers and the system has come up clean.
I tried telneting to google on port 80 (which I can do fine from my workstation), on the server it seems to connect, but as soon as I start typing a command it drops out of thee session and back to the prompt.
0
Rob WilliamsCommented:
Is this SBS std, or SBS premium with ISA?

See if port 443 might work instead of 80 by using an SSL site such as  https://www.royalbank.com/  That site will probably indicate a certificate error if it does work, but good as a basic test.

Are there any security applications installed such as Symantec, McAfee, or any 3rd party firewalls?

Make sure enhanced security is disabled, at least for admins (logon as an admin). to do so go to add/remove programs | windows components | IE Enhanced Security Configuration | details | un-check for administrator groups | and save

Go to control panel | network connections | on the menu bar -advanced | advanced settings | adapters and bindings | try putting the adapter used to connect to the internet at the top of the binding order

Again verify if you can connect to Google by IP http://64.233.187.99/ 

You could try reinstalling IE7, but I don't think that is the problem (save the small download to a PC, copy to server, and click on the exe):
http://www.microsoft.com/downloads/details.aspx?FamilyID=BC327D94-4F2C-481F-8595-FA5B90B11BFC&displaylang=en
0
jamesitAuthor Commented:
This is SBS Std

Yes port 443 works fine, tried it on several https sites and no problem at all.

It is running AVG for servers and has been for some time, no 3rd party firewalls. The only recent software change has been the installaiton of a product called "No Spam Today!". I might un-install this to see if it is causing anything.

Enhanced Security is not installed at all ( I un-installed it a few days ago thinking it might be causing the problem).  Ethernet adapter was already at the top of the binding order.

Still no luck with browsing to the google IP address.
0
Rob WilliamsCommented:
Browser is working properly then, so it seems something is blocking the port 80 traffic. If it was winsock, 443 would not have worked either.
Anything custom on the router or anything else you can think of?
0
jamesitAuthor Commented:
AVG got it's last definition update on 24th October. No Spam Today was installed on the 23rd Oct. Server was touched until it was moved to the new address on 6th Nov.
I have to race off now, but will uninstall No Spam Today first thing in the morning and see if that makes a difference.
0
Keith AlabasterEnterprise ArchitectCommented:
download and install Microsofts net Monitor 3.1 on the server. Start a trace going and then try to access an external web site - where does the trace say that the traffic is being directed to?

keith
0
Rob WilliamsCommented:
Help at last ! :-)  Hi Keith, excellent idea.
0
Keith AlabasterEnterprise ArchitectCommented:
Lets hope so :)
0
jamesitAuthor Commented:
I have net mon running but am having a little difficulty filtering the results.
How do I get it to filter on http, google, etc. ?
Thanks.
0
X-ITSupportCommented:
I have been having exactly the same problem, I fixed it by uninstalling AVG and installing a fresh copy. You didn't say what AV software you were running but it might help.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jamesitAuthor Commented:
Brilliant.  That was it. AVG has been re-installed and the internet is now working fine.
Thank you all very much for your help.
0
Rob WilliamsCommented:
Glad to hear you have resolved.
Something you may want to verify with AVG, is do  they officially support SBS. Most Anti-virus software does not where it needs to support server 2003 and Exchange. There are only a few that specifically say they work properly and are supported. CA, Trend Micro, GFI, I think Sophos now, and a couple of others have versions that specifically address SBS. I noticed SBS is not listed on the "system requirements" page of AVG. Just food for thought.
http://www.avg.com/product-avg-anti-virus-network-edition#tba2
Cheers !
--Rob
0
jamesitAuthor Commented:
Hi Rob,
We have the SBS edition installed...
http://www.avg.com/us.product-avg-internet-security-sbs-edition
but even on the SBS page it doesn't explicity say that it supports SBS. Kinda odd.
Cheers,
James
0
Rob WilliamsCommented:
Excellent, that should be fine. I didn't realize they had one. Several years ago when I checked they did not. I just thought I would give you a heads up as some folks have had problems using "unapproved" ones from time to time.
Thanks for updating.
--Rob
0
Keith AlabasterEnterprise ArchitectCommented:
Good call X-IT. i didn't think about the AV either.
0
X-ITSupportCommented:
No Problem, I was digging through some tech emails from AVG and its and a known bug on version 196.

Took me a while to fix it too!

0
AxeonTechCommented:
X-IT -you are MY HERO!  Endless time spent trying to resolve this obscure issue on a server I've never been on so we went down a lot of wrong roads for 12 hours straight.  Now, found your message on AVG and voila, it WORKS!

Thanks man!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.