[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Cannot open backup device sql2005 log shiping

Posted on 2008-11-11
4
Medium Priority
?
1,916 Views
Last Modified: 2012-08-14
trying to set up log shipping on sql2005.
The backup sage was ok but when it start copying it fails with following error.
Cannot open backup device '\\primarydb\tranlog\chrisprod.bak'. Operating
system error 5(Access is denied.).
RESTORE FILELIST is terminating abnormally. (Microsoft SQL Server, Error:
3201)
sqlagent is started by the user i created and has admin and also sysadmin on both servers and sql2005. Also has full access to the same folders on both servers
FOund some solutions on the new regarding this to set up a domain account but I am using work group.
I have set up a same account with same password on both servers but still got the same error.

Open in new window

0
Comment
Question by:Ftr_Tech
  • 3
4 Comments
 
LVL 5

Assisted Solution

by:funnymanmike
funnymanmike earned 80 total points
ID: 22946518
if the users were create after you setup the job trying doing the following
login to both systems as that user just once, ensure that they can login fine
delete the job, recreate the job
check the job properties, make sure its not adding the computer name in front of the user name
has event logs revealed any other information?
0
 

Author Comment

by:Ftr_Tech
ID: 22946838
THKS.
Yes the user can login fine on both.
I don;t think the job gets created at all when i set run the log shipping setup.

The process is backup->copy backup file to SECondary-> recover SEC from backup file
The first backup job suceed but the secound failed. All the rest are skipped and rollback.
I don;t see any jobs details in the JOB in management studio nor do i see any errors relevant to my log shipping process in the event log.

still no go yet...
0
 

Author Comment

by:Ftr_Tech
ID: 23001126
Still have not configured log shipping sucessfully.
However a reinstall of sqlserver on the secondary appears to have cleared the permission issue but now I am getting network error due to bad connection.

Still unable to get the network going so no need to reply to this.

0
 

Accepted Solution

by:
Ftr_Tech earned 0 total points
ID: 23001190
It seems that the problem was that the group that the original installation user belonged to no longer exists. The reinstallation by a user with a valid group is probably what fixed the problem.
0

Featured Post

Threat Trends for MSPs to Watch

See the findings.
Despite its humble beginnings, phishing has come a long way since those first crudely constructed emails. Today, phishing sites can appear and disappear in the length of a coffee break, and it takes more than a little know-how to keep your clients secure.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

SHARE your personal details only on a NEED to basis. Take CHARGE and SECURE your IDENTITY. How do I then PROTECT myself and stay in charge of my own Personal details (and) - MY own WAY...
Container Orchestration platforms empower organizations to scale their apps at an exceptional rate. This is the reason numerous innovation-driven companies are moving apps to an appropriated datacenter wide platform that empowers them to scale at a …
Learn how to automatically add page numbers in your next InDesign project. This can be very helpful in multi-page books and magazines that you are designing. Make sure your Pages window visible.:  In the document you wish to add page numbers to. Act…
In this video, viewers are given an introduction to using the Windows 10 Snipping Tool, how to quickly locate it when it's needed and also how make it always available with a single click of a mouse button, by pinning it to the Desktop Task Bar. Int…
Suggested Courses

831 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question