Cannot open backup device sql2005 log shiping

trying to set up log shipping on sql2005.
The backup sage was ok but when it start copying it fails with following error.
Cannot open backup device '\\primarydb\tranlog\chrisprod.bak'. Operating
system error 5(Access is denied.).
RESTORE FILELIST is terminating abnormally. (Microsoft SQL Server, Error:
3201)
sqlagent is started by the user i created and has admin and also sysadmin on both servers and sql2005. Also has full access to the same folders on both servers
FOund some solutions on the new regarding this to set up a domain account but I am using work group.
I have set up a same account with same password on both servers but still got the same error.

Open in new window

Ftr_TechAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

funnymanmikeCommented:
if the users were create after you setup the job trying doing the following
login to both systems as that user just once, ensure that they can login fine
delete the job, recreate the job
check the job properties, make sure its not adding the computer name in front of the user name
has event logs revealed any other information?
0
Ftr_TechAuthor Commented:
THKS.
Yes the user can login fine on both.
I don;t think the job gets created at all when i set run the log shipping setup.

The process is backup->copy backup file to SECondary-> recover SEC from backup file
The first backup job suceed but the secound failed. All the rest are skipped and rollback.
I don;t see any jobs details in the JOB in management studio nor do i see any errors relevant to my log shipping process in the event log.

still no go yet...
0
Ftr_TechAuthor Commented:
Still have not configured log shipping sucessfully.
However a reinstall of sqlserver on the secondary appears to have cleared the permission issue but now I am getting network error due to bad connection.

Still unable to get the network going so no need to reply to this.

0
Ftr_TechAuthor Commented:
It seems that the problem was that the group that the original installation user belonged to no longer exists. The reinstallation by a user with a valid group is probably what fixed the problem.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
File Sharing Software

From novice to tech pro — start learning today.